English

FP2 Frequent crashes requiring reboot by holding power button >10s

Hi, just wanted to state that same happened to me twice within the last 3 days, in both cases I wasn’t actively using the phone - just found it to be not responding to anything when I picked it up again and the screen remaining black.

Maybe it could have been related to ongoing app installations? I think that was common for the 2 times in my case.

After all I had to remove the battery and then I could start the phone again.

Besides also random resets happened to me a few times already (e.g. found it asking for SIM pin when I picked it up this morning, which only happens after a reboot)

7 Likes

Hi,
my FP2 crashed / restarted itself today 5 times (within 3hours range).
Id never happend before and started today just right after I switched the 4G/3G mode to my second SIM Card.
After switching it back to the “old” SIM card it worked fine again.
So in my case its definitely caused by one of my SIM cards and the data transfer with 4G/3G.

2 Likes

How old are your SIM cards?

For crash analysis, I would again suggest to plug the phone in ADB, start an adb logcat and wait for or make the crash happen. If you post here the last log lines just before the crash, some geek on the forum might be able to get a clue about what is happening.

Hi all!

I just registered in the Forums to look about this issue, and saw that is happening to other people as well.

I’m happy with my user experience with the FP2, except that it happened to me exactly the same problem described in this thread, two times in 3 days. In both cases, the phone were just laying on the table next to me. I took it and saw it is unresponsive, screen pitch black, no feedback from any button press.

Second time I connected the phone to the computer via USB cable, to check if it was just a screen issue, but the phone went undetected by the computer. So I guess it just shut off.

Only after remove the battery, and then put it again in place, I was able to switch the phone back on.

I have stock ROM r4275.1_FP2_gms36_1.1.7

2 Likes

@Jon1 when the screen freezes it freezes, so I can’t lock the screen. I have at least found I can restart the phone by holding down the power button for about 10 seconds. When it restarts it works fine until it crashes again. It has at least only crashed once in the last week

1 Like

@jaymanu just googled and is an adb an android debug bridge? If so, does the phone have to be plugged into anything, or can it just be running in the background. I can’t predictably say when my phone will crash and it might be a few days before it crashes again

The SIM card that works fine: 1 month
The one that is not working: 1 year

There is a slight possibility that the SIM card of 1 year old is to old.
Perhaps you could try a SIM card from somebody else in your phone to see if it’s really your SIM card that’s having a problem.

@rachels42 yes, for ADB you need to have your phone plugged to your computer with USB.
Then you install ADB software on the computer side, and enable USB debugging on the phone.

You can do a logcat to display the system log, which is the journal where we could look for hints about what caused the crash.
It might work if you logcat right after the crash, if the crash is not too much severe, but it would be more accurate if you were already logging while the crash happens.

@jaymanu I’ll see what I can do. Hopefully will have some time this weekend to work out hot to install ADB and display the system log. Then hopefully will have a crash when I’m by my laptop. Do you have any idea of the maximum time window I would have after a crash to do the log?

Well if you remove your battery, unfortunately it will reset the phone and delete its internal log.
You might anyway try to use ADB on your phone while its in the frozen state. There’s a (small) possibility that the underlying system could still respond while the user interface is crashed.

Hmm, if I manage to restart by doing a long press on the power button does that also reset the phone / delete the log?

We can’t know without trying. But if the power button responds, there’s some hope that you might be able to talk to the phone via ADB while it’s frozen, without even having to reset it.

I had the same issue without another phone (not fairphone). Some module crashed everytime i connected to an unknown wifi network. The faulty module tried to analyze captive portals. I could disable the module and fix it.

Sounds promising. I’ll try and set things up soon. Might just take a while as I’m very much an amateur at this type of thing, so working out how to set these kind of things up requires a lot of googling for me and rather a lot of trial and error!

I have this too sometimes, usually when scrolling. But the other day, something very unusual happened.

We were in the car (on the way from Vienna to Schladming), with two FP2’s sitting in our pockets, doing nothing in particular. At some point on the way, we tried looking at our phones and realized that they were both frozen and needed their battery to be removed. So, something (not user-triggered, we had the phones in our pockets, of course screen lock was on) made them both freeze.

[quote=“vivia, post:28, topic:12049”]
…were both frozen…
[/quote]Funny story.
I think you both passed an NSA surveilled cell mast, and the FP2s defended themself from beeing spied :wink:

1 Like

Just another disappointed user that has random freezes. I haven’t actually discovered reboots, but the phone just goes black. Doesn’t turn on anymore, even when pressing 10 sec on power button. It just vibrates and the red LED lights up. I am able to restart it after 10 minutes or so, it then re-optimizes all apps.

To me this seems like a hardware problem. I have experienced blackscreens at full battery charges and at low ones, however, when I’m able to turn on the phone again and look at the battery usage, there is a time-period that where no battery usage is not shown at all, like in this picture:

Anyone has an idea what this means?

I moved your post here as you don’t have reboots. Even though the topic title says “requiring removal of battery to restart” I guess it’s the same issue, because the others probably didn’t wait ten minutes like you.