FP2: Fairphone OS & Fairphone Open 22.02.0-rel.0 (Android 10)


Thank you for that very clear advice!

I’ve now managed to transfer the APK to the updated phone, but I haven’t been able to install the app…

When I open the APK file with the Package Installer, it says

“Do you want to install an update to this built-in application? Your existing data will not be lost. [Cancel] [Install]”

I’d far rather install it as a separate stand-alone app than as an ‘update’ to the existing one, but if I select “[Install]” anyway, a message flashes up briefly, saying


to be quickly replaced by one that says

“App not installed. [Done]”

I seek further advice, please!

Ah, in that case you can uninstall the existing App first.
If it’s not possible in Settings - Apps etc. (I can’t check momentarily), it should be possible via ADB, steps are here for instance.

Hi, I just tried to update from “21.10.0-rel.2-sibon-1ee7158a-ota.zip” to “22.02.0-rel.0-sibon-f257e06b-ota.zip” via TWRP.
This didn’t work correctly. When trying to boot I get the message:
“Cannot load the Android system. Your data may be damaged. If you continue to receive this message, you may need to reset the factory settings and delete all user data stored on this device.”
Luckily I had made a backup with TWRP before trying the update. However, I can’t go into TWRP now any longer. Did this update overwrite TWRP? As mentioned above, I initiated the update from within TWRP!
What do I do now?

Fairphone updates have been replacing TWRP with the AOSP Recovery for 2-3 years now (I think this happened in the 19.08.1 or 19.11.2 update), as far as I remember. If you manually replace the AOSP Recovery with TWRP again afterwards, the next Fairphone update might not properly install. I think this might be what happened on your phone.

I recently had the same problem when installing the beta 22.02.0-rel.0, but after I did a factory reset in the AOSP recovery and then rebooted into system, the update had succeeded.

Sunny Spring greetings to all,
I was last night prompted to update the OS on my FP2 to Fairphone OS 22.02.0-rel.0. The process was straightforward with no immediate, noticeable issues. Apart from the Android clock alarm not working. The following methods can resolve the issue and are copied from WeTheGeek.com

  1. Restart the phone
  2. Check the volume
  3. Check alarm notifications
  4. Check the DND settings
  5. Clear cache and data
  6. Reset app preferences
  7. Uninstall updates on the clock app
  8. Force stop the clock app
  9. Use a new clock app
    Good luck!

It might have been reported in this forum before and it was somewhat to be expected, but I have just read the first FP2 user (in the German language Facebook group) report that confirms the well-known issues with SD cards formatted as “phone storage” (internal storage) under Fairphone OS 22.02.0-rel.0 (Android 10), too.

If my memory isn’t completely wrong, the issue started on the FP3 with the Android 10 upgrade, too.

A recommendation to FP2 users with “internal” SD cards still on Android 9 to switch the card to portable storage prior to the upgrade probably does not hurt.


Hi all!
I understood that FP Open differs from the standard FP OS regarding the absence of Google services, but does FP Open come rooted as well? And if yes do you know how can I install google services on FP Open?

Dear Fairphone company,

many thanks for this great Android 10 update for my Fairphone 2!

From your perspective, this are 7 years of valuable software support. But from a customer perspective, the lifetime of a device starts at purchase and for me this was October 2018. I hope that my Fairphone 2 is usable for me at least as long as my Samsung Tab Active bought in January 2015, which is still in use, but unfortunately without newer software updates. (I fear it will die by software obsolescence some day.)

Got the update yesterday, went smoothly and without any data loss. Thanks for the ongoing effort to keep this antique smartphone running.


Update went smoothly here, too. No data loss and with Android 10 no reboots and no bootloop anymore (got that lately a lot with Android 9, some problem with the sim card i guess). Thank you so much for the effort!!! I am now able to continue using my phone (from 2016) for the next years. :slight_smile:


Last time I’ve seen it (which is some time ago), Fairphone Open OS didn’t come rooted by default, but you could just enable root in the Developer options.
Perhaps somebody can confirm the current situation, I’m unable to check momentarily.

I think you don’t need root for that.
You can install different amounts of Google services and Apps by installing e.g. Open GApps (for the Fairphone 2 choose ARM, the major Android version your Fairphone Open OS is on, and a package of your choice, “pico” is the minimum to get the Play Store).
Installing is done in recovery mode via ADB sideload, or in case you use TWRP simply via “Install”.

1 Like

Did anybody notice a problem with the spelling checker after the update? In some apps like Messages, the red underlining of misspelled words follows the previously used language, and not the current language. Word prediction works correctly in the newly selected language though. If I close the app and then reopen it, the language resets correctly to the newly selected one. This is happening in many apps, maybe in all apps (didn’t test them all yet).

PS: the spell checker in reality doesn’t reset, seems to be stuck in the system language (English in my case).


Thanks for this link, so it’s not just my phone. For me it was working in the previous version though.

PS: in reality, my previous version was Android 9, so I suppose that it’s exclusive of Android 10 versions.

Did anybody notice a problem with the app for downloading after the update? I continously receive an error message

I launch Fairphone Updater and it says “Download started”. Just sits there - saying “Just a moment…”. Nothing happens - reverts to previous screen. Tried for days , on two different wireless networks. No difference. Is the server very busy / overloaded ? Using latest version of updater…

I can confirm :slight_smile:


Did you try to delete cache and data of the updater?

No. How do I do that ?

Settings->apps->updater->storage and cache->delete storage