FP2: Fairphone OS 19.11.2 release

Fairphone OS 19.11.2 is now available. You can get it through the Updater.


Issues fixed since the previous Android 7 maintenance release (Fairphone OS 19.08.1).

1 This release includes a new system setting for enabling OpenGL ES 3.0 support. On first boot you will receive a notification linking to the setting. You can also find it in Settings → Maintenance → Enhanced 3D graphics support.

Please report any (new) issues through the public bugtracker and upvote existing issues if you are affected. As usual, please specify the steps to reproduce, and provide as many details as possible.


Update via WiFi from 2019.08.x to 2019.11.2 went fine. The teamwin boot process of patching files etc still shows that red line as the third message, that it cant find partition for /system/ it claims. Dunno what to make of it. Wonder why there is no partition for system, or how this can be a proper state of the phone, or why this needs to be printed out in red to confuse the user and make the user ask questions and wonder?

Either it is pretty severe that there is no partition for system, or it is not. Why would you otherwise print it, and even in red letters as a warning?

Weird. :frowning:

The 19.11.2 update replaces TWRP with AOSP recovery, which will improve the update installation experience for future updates. The 19.11.2 update itself is still installed through TWRP though.

Once you have 19.11.2 installed, AOSP recovery will be used for future update installations. You can boot into AOSP recovery by hand if needed by holding up the Volume Up button while powering on the phone.

1 Like

I was just reporting that red line, and this same message has been printed out in the past with the update to 2019.08.x as well.
Wondered about the reason for it to complain about lacking something /system/… and if it was bad and background information.

Your reply doesnt really help to understand the situation. Never mind we will see if updates via aosp will behave any differently, if some lacking partition for /system/ will be still relevant, or will be still printed out or if this all doesnt matters at all.

Part of the improved update installation experience of AOSP recovery is no more red lines (or even better, no lines at all, just a progress bar and an animation) :slightly_smiling_face:

Can you please update the download links here:

and here:

Thanks! :slight_smile:


Our customer support team is updating these as we speak :slightly_smiling_face:


Applies without trouble on my phone and does appear to have made WiFi connections a bit more stable. The only minor catch was that I did not see the promised “first boot notification” to toggle OpenGL ES 3. Found the toggle myself though :wink:

1 Like

It never was relevant.
Users using more recent TWRP versions from twrp.me never got this message as far as I know, it was exclusive to the older TWRP version bundled with Fairphone OS and Fairphone Open OS and had no consequence in practice.

1 Like

Does this release contain a fix for the Android “StrandHogg” vulnerability?

No it does not. There is no fix available from Google for any of the current Android versions. The only protection known to us at the moment is to only install apps from trusted vendors.

According to the original publication by Promon, malicious apps exploiting the StrandHogg vulnerability could be installed even through the Google Play Store. Of course this makes it difficult to protect against this vulnerability. Unfortunately, we do not have any other information at the moment.


One fp2 updated with no problems, the other fails in TWRP with" Zip signature verification failed" and leaves me in TWRP, booting from there gets me back to the OS but retrying gives the same result, tried clearing the cache incase the download was corrupt but no joy

I tried again with the zip verification off and got an error
E3001: Package expects build fingerprint of Fairphone/FP2/FP2:7.1.2/19.02.1/gms-dc48370a:user/release-keys or Fairphone/FP2/FP2:7.1.2/19.11.2/gms-24df0be9:user/release-keys; this device has Fairphone/omni_FP2/FP2:6.0.1/MOB30M/13:eng/test-keys

The Fairphone updater says my existing OS is Fairphone OS 19.02.1

During the update process my FP2 ended up in the TWRP main menu without any idea what to do next. Rebooting only brings me back to this menu. How to proceed from here? Is there a way to still boot properly?

Welcome to the community forum.

Worth a try when in TWRP …

A little more detail in between …

Apart from TWRP a manual install has helped people …

1 Like

Many, many thank. Locking up the .zip in the /cache was exactly the information I needed. I was certain that the updated version has to be located somewhere within the filesystem, but I did not dare to poke around. Again many thanks

1 Like

Update went without any issues, notification after first boot was there, too, system continues working just like it did before. Thanks for the smooth update experience!


Running this update for a few days definitely makes me very happy. I feel like all regressions since the first Android 7 release (that I cared about) have been fixed. The WiFi fixes are a big step forwards to being practically usable again, and coincidentally seem to have improved battery life as it’s no longer constantly reconnecting.


Installation went fine, but I had no possibility to connect to Wi-Fi anymore at home. I have Mikrotik Access Points using their CAPsMAN method (wlan controller) and I could connect to them anymore with my FP2.

Other devices like windows10 laptop and an iPad tablet did still work fine.

Removed associations on FP2 and tried to connect, not possible, requests denied.

After puzzling with the FP2, I tried to experiment with the Mikrotik and it seems that with their software version 6.46 I needed to provision the configuration again, no changes in configuration are made, just the provisioning whereby the AP’s renewal their Wi-Fi configuration.
May be related to the software update changes from Mikrotik last week (or week before) and some security fixes on both sides.

Installation went for me very smoothly.
Just the first boot after install lasted very long. Just after that, I got a notification to enable OpenGL ES3