FP2: Fairphone Open 19.05.2 release

Fairphone Open 19.05.2 is now available. You can get it through the Updater.


Issues fixed since the previous Android 7 maintenance release (Fairphone Open 19.02.1).

Please report any (new) issues through the bugtracker and upvote existing issues if you are affected. As usual, please specify the steps to reproduce, and provide as many details as possible.


And the source code for this release? :slight_smile:


I updated modem.zip to 19.05.2. Get it in its habitual place:


Is this done just to match the modem.zip to the OS release, or are there differences compared to the previous version (can’t check right now)?

The update went smoothly.

Same here : update without any problem.
UnifiedNLP is now perfectly working again :smiley:
Thanks for the great job!

No, some BLOBs were updated (baseband version is still the same, though). Noone can know exactly what changes they have, they’ve always been opaque black boxes, :man_shrugging:


That’s why I wrote “differences” (binary ones) :wink: .

1 Like

Are there any changes in aboot or modem files for this release worth flashing for LoS users :)?

I whish Fairphone could tell us more about such changes, technical users want and need such information IMHO…

1 Like

The modem/baseband files should be exactly the same as in Open 19.02.1. Also the proprietary blobs are the same. Please let us know if you notice any difference! In fact, we didn’t change anything on the modem layer since the upgrade to Android 7 (18.10.0).

Thanks for the comment, we will keep that in mind and explicitly mention if we change anything on the modem files.


Hi, during installation appeared console log “Running Recovery Commands” with error message “unable to find partition for path ‘/system’”.
The installation however is gone successfully (in about 10 minutes).
Should I get scared from this message? thanks

I have trouble flashing opengapps again.
Before and after I updated TWRP in the official app, I get the zip verification error. I downloaded the current version of opengapps. Why is this so difficult with every update? And how do I solve this problem this time?
If I don’t uninstall all gapps I use, the phone drains >25% battery per hour and gets very warm.

1 Like

Which TWRP version is installed now?

For troubleshooting purposes you can make absolutely sure not to use Fairphone’s TWRP by booting a signed image of community TWRP without flashing it, see twrpwoflashing.

Sadly my FP2 is not happy with the updates tp 19.05.2.
I had reboots before updating, but now the phone is rebooting several times a day.
The drain on my battery is huge and the phone is feeling very warm. In the app Temp. monitor the reading for pm8941_tz is around 58 °C and rises to temps between 60 °C and 75 °C when I am using the phone.
A full battery lasts for 5 hours only when hardly used.
I am thinking of running the update again this evening, through the manual update which I found on https://code.fairphone.com
But first I will re-install Gapps.
I switched my phone of overnight and now I am charging the battery again.
Screenshot of the battery last evening.

First impression after re- installing Gapps is good. Phone is at temp 53 °C.
Of course I used the Official TWRP app to get the right TWRP version to be able to re-install Gapps.

I have trouble flashing xposed. even if I do not check the “check verification” flag, it checks and declines… Did xposed work for the rest?

Before the update I used twrp-3.2.3-0, as it was neccessary for the last Open OS update.
I got the latest version in the TWRP app which is twrp-3.3.1-0.

My problems sound very similar to Lidwien’s, but I have not managed to solve it yet.

UPDATE: Problem solved by updating to latest TWRP and directly booting to it. At the first try, the phone was plugged to a charger, thus automatically rebooting after shutting down (this must be a common bug?), and booting Open OS instead of TWRP. So even with the official TWRP app, it’s still a problem that you must directly restart into it after flashing, otherwise it seems to get overwritten by the old version again.

If your TWRP version is 3.1.1-0 (Fairphone’s own TWRP bundled with Fairphone’s OSes), try community TWRP, I still recommend 3.2.3-0 as the most reliable version.

1 Like