FP2: Fairphone Open 19.02.1 release

Fairphone Open 19.02.1 is now available. You can get it through the Updater.


Issues fixed since the first official Android 7 release (Fairphone Open 18.10.0).

Please report any (new) issues through the public bugtracker and upvote existing issues if you are affected. As usual, please specify the steps to reproduce, and provide as many details as possible.


Update went smoothly.
I am now able to shutdown my phone without the torch on. Great job. Thanks!!


To be honest, Fairphone Open without sources isn’t really Open… I really hope that you will publish them soon - especially with not publishing the sources for the kernel, it’s a clear violation of the GPL license the Linux kernel is under.


Thanks not no thanks, missed opportunity again bugtracker #55 was not resolved with this update. While this Dual SIM disabling feature is a very important feature for the users of FP2 there continue to be a large amount of unhappy customers that are forced to use a non supported Android 6 version.

1 Like

Many thanks to the team for their ongoing massive efforts.

I believe this was by far the hardest nut to crack. Good that they succeeded.

Yes, yes and of course yes - you are right and I agree. But the team had to crack a few quite solid nuts in the past few months. The team needs some cooling down and maybe a bit more time 4 cleaning up the code before publishing.
But I am most sure it will provide the code just as is if one put pressure on it.

Yes I agree. Another missing feature holding me back from updating. Anyway the hardest nut seems to be cracked, a proper shutdown process without workaround. No luck this time for the dual-sim switches, maybe next time. But hey - a higher security level after all, that’s more than other phone owners can ask for.


Updated last night and since then phone is super slow to charge and processor is burning up.

Has been stuck on 77% charged for the last 40 minutes; does charge slowly when powered off.

This second image was taken 15 minutes later

Touch screen swipe to unlock is poor to respond and takes several attempts to do it!

If this is the wrong place to post this let me know and I will repost and remove this one




As an update my phone battery is now only lasting less than 3 hours whereas before the update I was getting over 24 hrs per charge

1 Like

See the hints in the #batteryguide .

Thanks, will do. Not sure why it an update should do this though. I didn’t have the problem before the update.


1 Like

QKSms stopped working after the update. Opening the app causes a very short flashing up of QKSms but it’s shutting down right away. Worked fine some minutes before the update. Any ideas?

So this may be an answer to both questions.

Updating (upgrading) may generally be possible although some installed apps may not be compatible to the new OS.
But as I see it there is no proper pre-check done prior to an OS upgrade to sort out incompatible apps installed .
So the new OS begins it’s job not bothering any further about app compatibility. One may be lucky nearly having no troubles with incompatible apps while another may suffer from crashing, freezing apps or an unstable device.
Rebooting generally after any update could help and/or clearing the main cache (somewhere in settings->storage->cache).
If not, a more detailed investigation, maybe app related, should be done if there is one or more specific troublesome app known. Read about the compatibility level which may be provided in the store. Perhaps an alternative has to be found.

1 Like

Also experienced battery drain after updating to 19.02.1 from 18.10.0.
Additionally the Play Store App wouldn’t open.
And (somewhat annoying actually) TWRP was downgraded to 3.1.1.

Manually restoring Google Play Store/Services apps via Titanium Backup did not work.

What did work:

  • Update TWRP 3.2.1 (via previously installed TWRP app)
    • now I can mount my encrypted SD card (adopted storage) again
  • Installation of GAPPS (https://opengapps.org/) via TWRP over existing GAPPS

–> Play Store is working again.
–> Battery usage seems to be back to normal.
–> Phone doesn’t get hot anymore.
Downside is that I had to fix permissions for most apps manually.



Similar destiny, I have also installed again Xposed and XPrivacyLua.
Probably not so smooth as I hoped.

There is also another process, Google Play Services for instant apps, that have some issue because sometimes it stop suddently…

Thanks! My FP2 was suffering the ‘camera module prevents shutdown’ issue, now I can turn the phone off again!

Update went smooth though the linux-shell window during update had me frowning a bit (usually there’s just a progress indicator, right?)

No charging anymore

Google Play won’t work

Apps are now very slow

Various apps won’t work anymore

Phone becomes very hot

Phone won’t last for more then 1 hour

Great update… NOT

Is it possible to go back to an earlier version?

Hello all,

Sorry for those experiencing problems. :-/

I’m a lucky one as this update through the updater went smoothly yet again.

I have the original FP2 with original cam modules and never experienced the shutdown issue.
As for the battery I have the feeling it now last longer actually.

As a result, thank you. :slight_smile:

Hi all,

Same here, the upgrade went smoothly and it works fine so far. I will keep an eye on it as many of you appears to have been experiencing issues :roll_eyes:

I hope it will be something fixable :thinking: Thank you very much FP Team for the effort though!


Isn’t possible I now know to go back to the previous version.
The phone need to be charged a minimum of 50% and mine won’t charge further then 40% since the update I did yesterday.

So what now?

Buy a different phone? I had almost none problems with my FP1. After I and my wife both have a FP2 the problems start.
I think after this update I quit the FP2. It is not a reliable phone I know now. To bad because I like the idea

Tried and now System-UI is stoped. No working phone anymore. All data lost…Thanks FAIRPHONE!!!

Hi there, I am another unlucky updater:

I updated to the latest version of the Open OS yesterday (19.02.1).
Since then, my FP2 runs really hot at the back and the battery only lasts
about an hour so. What´s more, text messages are not sent out.

I have a big exhibition this weekend and need the phone to work realiably,
like before. Please help.