FP2: Fairphone Open 18.10.0 (Android 7.1.2)

For TWRP: one that works. IIRC the latest version should work.

For OpenGapps: ARM (not 64), Android 7.1 (not 7). The final bit (e.g Pico) depends on what you want/need.


Thanks for the fast response.
Updating TWRP and Open OS worked, but OpenGAPPS does not work even though i successfully flashed the latest version of ARM 7.1 :face_with_raised_eyebrow:

edit: Most Google Apps work, but some don’t (Mail, Maps are the most important ones).

Also, my TWRP version always resets to 3.1.1-0 even though I did follow this advice:

I’m not sure what to make of this, as you say updating TWRP worked, but the at the same time the version number doesn’t change (suggesting it didn’t work), yet you mention successfully flashing openGapps, which doesn’t work with 3.1.1 (suggesting the TWRP update did in fact work as you must be on a different version to not run into zip verification problems).

I can recommend this topic for more background on what people have done to get things working:


I updated TWRP via fastboot. Then rebooted into TWRP, it was the new version. There I successfully flashed OpenGAPPS latest version. But not all Google Apps work and when I rebooted into TWRP again, it was the old version. In the old version, flashing OpenGAPPS did not work (as expected). I did the same thing twice, same result.
I will read the linked topic and give it some time, thanks for your help!

1 Like

One suggestion, you might want to use TWRP to make a backup of only your system partition before installing OpenGapps in case you want to uninstall them. In my case I just install OpenGapps to get the play store and download my paid-for apps, then restore my system partition.

Android 7 will finally be the point where I switch from a rooted FPOS to FPOOS with OpenGApps.
So, I wonder if this guide is still up to date (and this one)? The questions in this tread seem to suggest some versions and other things have changed. Which links/instructions should I follow and which ones have changed?

Thanks ahead!

The procedure to follow has changed (it’s written in the firts link you’ve given).
you should use this procedure : https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-installation-instructions.html

The second link in your post is to install the gapps, which is not mandatory (I use Fairphone open OS without gapps form ore than one year now), I don’t know if this part is still valid or not.

1 Like

The general gist of the TWRP llooks okay, but there are some changes for FPOOS/Android7:

  • FPOOS comes with TWRP, but this version doesn’t work for installing openGapps. There is a topic about that here. Most success seems to have been had with installing a newer image from here (.img via downloads section). Pitfalls are that in TWRP the file manager browser needs to be toggled from .zip to .img, and that after installing you need to reboot directly into TWRP to avoid changes being reverted.
  • The openGapps package is still ARM, but now for Android 7.1 (obviously).
1 Like

I tried to switch to FPOOS with this guide but when I type “sh flash-for-unix.sh” I get this:
sh: 0: Can’t open flash-for-unix.sh
an nothing further happens. Does sombody know what the issue is. By the way i run Ubuntu on my PC

Before executing the script, cd to the directory where the script actually is.

1 Like

but the phone is not recognised

Which error message do you get?

1 Like

When I start the phone in fastboot mode an plug it into the PC nothing happens and I don´t know how I can find phone.

1 Like

When the phone is in Fastboot mode, execute fastboot devices on your PC … what does it say?

1 Like

Well, I hope it’s not a stupid question but did you make flash-for-unix.sh executable?
chmod a+x flash-for-unix.sh

It says:
725b300 fastboot

That means fastboot works and your phone is recognised.


Sorry but I still dont know where I have to put the location of into the command

Following the guide, you extracted the ZIP file of the OS somewhere … and that’s where the script is, and that’s where you need to go to execute it.

The README.txt that comes with it is more clear than the online guide:

'2. In a terminal emulator, navigate to the extracted archive directory.
3. Execute the flashing script by typing “sh flash-for-unix.sh”.’

1 Like

Oooooooooh, now! I extractet the files on my phone :scream::joy: