FP2 drops all connectivity

I recently got a new Fairphone 2. This is my third! I am experiencing a new problem that I have not come across previously.

The phone randomly drops connectivity, including WiFi and 4G. The effect is as if I quickly turn aeroplane mode on and off (though note that the aeroplane mode icon does not show). Whenever it happens, I am unable to access the Internet for around 10-20 seconds.

It appears to be entirely random and has happened when I open apps, while using apps, and even before I open any apps. It happens very frequently - perhaps as many as 20 times a day. Almost every time I use it.

Has anybody else experienced this problem and found a way to stop it?



Seem also encountering same effect in my new FP2 twice yesterday. I though I did something wrong, but in fact I did absolutely nothing in the settings.

I’ve had similar problems with my FP2. In my case the connection with my provider (data and telephone) dropped unexpectedly. For as far as I can tell it was less frequent than 20 times as day. I tried using different sim cards and switching both sim cards, but that did not help.

I sent my phone to the FP office at the start of Januari. Their analysis did not provide clues to the source of these issues.

Unfortunately I am experiencing the same problem for months now. I contacted the customer service and they advised to re-install everything which I did. It seemed to help, but it’s back.
To be honest I begin to dislike my FP very much. It is also ''Random rebooting" several times (maybe even 10 times) a day.
So, sorry, I have no solution for you. What I do is to switch wifi on and off, but that shouldn’t be the solution.

1 Like

Same Problem at my phone… :frowning:

Same here.
And several times a day I’m getting these great “managed roaming”-pop-ups.
At first I thought it’s about my provider - and I changed the contract. Nothing changed.
Than I tried an network-reset and an soft reset too - nothing changed.
More than a week ago I contacted the customer service - no response, but my ticket is “solved” now. Ahh!
Additional to that I used the bugtracker - no response so far.
So what should I do next? Sit and pray? Selling my phone?

Hi disdel,

i also had sporadically the “Managed Roaming” Message after i manually switched network while abroad.
I fixed the Problem the following way:
Goto Settings -> More -> Mobile Network (Name not shure, German: Mobilfunknetze) -> Mobile Provider or Service Provider (Name not shure, German: Mobilfunkanbieter)

Wait until all Networks are found and then choose “Choose automatically”.
After that all Managed Roaming Messages are gone. This Message always deactivated my Data connection an was very annoying.


Also I have the same problem. Very often my FP2 looses all dataconnections. Most of the time I experience it with WiFi, but also the mobile connection is suddenly gone.

Hi Heinz, yes - these “choose automatically” notification disappears with this workaround. But it dose not help for any connectivity problems. I still need some luck to send and receive calls …

But when I am using the same SIM with a different phone, the signal is super stable :frowning:

I guess I found something out: It seems like a problem of the Fairphones 3G / 4G connection. When I set preferred network to 4G, nobody is able to call me and I can’t send calls - even when my phone is receiving some signal. When I change it to 2G manually, no problem at all.
It sounds like a problem of my provider, but: When I put the same SIM card in another phone, I am able to send and receive calls with 4G enabled. And meanwhile I’ve tested the third different provider.
It seems normal that a phone is choosing the preferred network from 4G to 3G / 2G to gain a better signal for calls, but when my Fairphone is doing so, it always stopps and can’t send calls …

Same with me! Under 4G no phonecalls in/out! Set to 3G works good, but that’s rubbish! Please FP6ers! Solve this issue!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.