English

FP2 completely dead (no red LED, reset/battery removing doesn't work)

My FP2 suddenly died today (it had about 40% battery left) while the screen was off. It’s not responding to charging (at least there’s no LED). I’ve tried everything - removing the battery, resetting using the power button, trying to switch it on without SIM card or SD card but nothing seemed to work. I’ve removed all the modules and cleaned them but that didn’t do anything.

Oddly enough, when I plug it in to my laptop with an USB my laptop constantly makes the sound for connecting and disconnecting a USB device, so there seems to be some life somewhere…

Any help?

Perhaps a battery reset can get your phone working, see for details #batteryguide

I would try, but I’ve got no way to run my battery down ATM (can’t tell for sure if my phone is even on… and with the screen black I imagine it’s going to take weeks if it is on at all :P)

Do you know if there’s a way to drain the battery in some other way? Either way, thanks for your help :slight_smile:

I still would suggest that you try the battery reset, what ever battery percentage you have.

Also try different cables. If plugging in to your laptop makes a sound but doesn’t light the LED that could mean that the data cables are working but the charging cables are broken.

I’ve tried but no succes so far :frowning: I guess I’ll contact the fairphone customer service…

A post was merged into an existing topic: FP2 Won’t turn on or charge - See first post for troubleshooting

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.