FP2 Bricked - Recovery Help

Josuttis wrote some very detailed instructions about adb and windows. Have a look at them: https://forum.fairphone.com/t/adb-on-the-fairphone-2-windows-driver/11529/15?u=irina_spitznagel

Hi Barney,
did the flashing via fastboot with the -w option do anything different?
In my case, flashing the ota image via adb worked fine. My system was running nicely again afterwards. Apparently you also managed to flash the new system but something different must be changed. Can you install any apps at all? I would be interested, in seeing your partitioning of the internal memory. I’m not a specialist on this, but I have an app called flashfire which lets me see the partition table and make backups of the individual partitions. Maybe you could download it and check what your partition table look like? Download is here: http://flashfireapk.com/FlashFire-Download.html
I’m attaching my FP2 partition table:

I can make individual backups of each, so if we can identify which one has a problem i might just send you a backup that you can flash back to your phone…

Thanks very much to all of you helpful posters!
I can’t access the devices properties since it’s blocked by the welcome-wizard which I can’t accomplish because of the error messages and it terninates automatically and starts again. So I can’t enable USB-debugging.
In recovery mode I chose “reboot to bootloader” (or something like that) and the phone gets accessible for fastboot commands but not for adb.
I tried the fastboot flash command.
But the system say either “cannot determine image filename for ota.zip”
(which I renamed to ota.zip and copied to the minimal adb-folder on PC and to c:\ ; I tried with and without paths)
or it says
unknown partition FP2-gms36-1.1.7-ota.zip

And of course I can’t install any apps unfortunately

the fastboot command goes as follows:
update filename => reflash device from update.zip
flashall => flash boot, system, vendor and if found, recovery
flash partition [ filename ] => write a file to a flash partition

so it expects a partition name first when you use the flash command. rather try flashall or update and see if that works…

Thank you Moritz, Irina and IKlaus for your kind help and also Freibadschwimmer!

None of the fastboot commands could be executed. The only thing that at least BEGAN to do something was the partition command. But of course (:wink:) it failed.

I found again the recovery wiki for the FP1 and executed it as I did it before by installing the ota.zip from the sdcard in recovery mode.
The new thing to me was the advice to now execute the factory reset AFTER the reinstalling!!!
And that worked!:grinning:
After a despaired week I got a working phone again and of course I’ll root it now :grin:
Jesus bless you all!:innocent:


How is that done? Does one have to edit the source code before compiling?

Yes, yolu’ll have to do some patching. It’s written in the wiki post [HOWTO] ✏ Compiling Fairphone Open OS / Rooting
with a wonderfull work from vivia

I’m glad you got your phone to work again! :smile: And to get general writing access on your SD card, try https://play.google.com/store/apps/details?id=nextapp.sdfix . It works well and there’s no risk to brick your phone again :wink: .

Thank you, Irina,
sorry, I don’t use google any more.
I tried again with adb push and pull. But again that didn’t work because of insufficient user rights as far as I understand it.
But I followed Freibadschwimmer’s hint (?, jedenfalls: seinen Tipp :slightly_smiling:), to edit the platform.xml with the Amaze-Editor. Worked phantastically without brick :grin::innocent:
Good night!


or you can take the easy route and just flash a finished twrp recovery from this threat :slight_smile:

1 Like

I’m glad to hear you have a working phone again, and finally managed to get write permissions for the SDcard. So in the end all your patience and persistence on solving the issue paid off. Well done!


I softbricked my FP2 and had contact with the support but they seam not to be happy at all, about some people try to change their system.
The reply was that i should better not push them. (i rewrote them that i didn’t get an answer within 8 days, so i wrote again and asked if my question wasn’t clear or if they need more information…)
Seams not that i will get help from the Fairphone support Team so im asking here…

What i wold like to have is any OS on my phone. Doesn’t mater if its a Fairphone OS or a FreeOS.
The momentary status is, the phone doesn’t boot now. I can see the chargerscreen (batery geting filled blue) when pluged to a wallcharger. But normal booting doesn’t show any screen at all (stays black and doesn’t vibrate when pwr button pressed).
But im able to get in to fastboot mode some times and i can get the device nr. with fastboot devices so i think it not totaly broken.

I found some informations about loading binaries to a FP1/1U but not for FP2.
Are the binaries to be released soon or are there licence problems that will prevent that totaly?
And what i don’t understand is why i need a tool to load binaries like that:http://mtk2000.ucoz.ru/load/soft/soft_mtk/sp_flash_tool/5-1-0-14
Is that not possible in fastboot mode?

Thanks for any help.
Regards, Novski

Hi @novski, did you tried to perform an hard reset ?
You need to boot your phone in recovery mode (not fastboot)…

i forgot to say that i can not reach recoverymode anymore…

I’m sorry to hear that. As long as you can still connect using fastboot installing the offical FP2 OTA image should be possible. Have you tried that already?

Hi, Thanks for the help…
what i did: I loaded this file to the sdcard:
and performed a flash from sdcard. Unfortunately after that, the phone showed the withe screen “loading…” for 3-4h befor i pushed the pwd button and the phone whent black and a reboot or recoverymode wasn’t reachable anymore.

I think you or I might confuse recovery/fastboot. Can you still boot the phone into the fastboot mode or the recovery? How does that look like? How did your fastboot command line looked like?

If fastboot still works: Try to install a recovery first
If recovery still works: Try to install the OTA (works with the default recovery) or the Stock Android (needs different recovery).

I’m not sure if the OTAs are complete “full” FP2 software versions (1.1.5, 1.1.6 and 1.1.7 exist) or just partial upgrades. If all fails, I (or others) can send you a recovery that should be able to install the stock Android. But it’s important to know what your phone can still do and how it can be “reached”.

1 Like

Im not able to reach recovery
Im able to reach fastboot and see a device nr. with fastboot devices
I wold love to get a recovery and install a stock Android.

Try this first:
Installing stock Android + recovery: You can just install the stock Android (no other recovery needed) using the stock build images (they contain recovery.img*, boot and system) using fastboot flashall.

If all that works, you can try the TWRP:
TWRP-recovery: Can you ask @Moritz | @Max_S (!) for a link (23 days old! Don’t use this one, maybe there is a better one out there!) to his latest recovery?

Hey there,
the link is not by me, but by @Max_S. He ported the TWRP recovery and as far as I know it’s the latest version. I flashed it just 4 days agp and it worked fine on my FP2, so if there is no valid recovery on the phone at the moment, I would second @fp1_wo_sw_updates’s suggestion on putting one there. I believe I mentioned that earlier in this threat somewhere already :slight_smile:
I believe, the ota does not include the recovery, so probably flashing the TWRP and then using it to flash the ota stock system is the best way to go…
Good luck and keep us posted! :slight_smile:

1 Like