FP2 bricked during update to 1.4.2 - no recovery mode

Running fastboot -w update softwareupdate.zip with the -w flag you are overwritting the recovery and boot flashed on the previous steps PLUS deleting all your userdata from the phone. ALL.

$ fastboot help ... -w Erase userdata and cache (and format if supported by partition type).

I really hope you made a backup of important stuff from TWRP before executing the third step you describe. That was the only purpose of my tutorial.

And why did you flash TWRP as recovery without using it? The file you downloaded holds the images for the whole OS, so flashing it all has to remove the just flashed recovery and boot.img.

Instead you could have used TWRP to backup the images “system”, “cache”, “boot” and “userdata” and then flash the images from the zip-file (without “recovery”) via TWRP.

Try again, this way you’ll learn …

Thanks for your concern, I did what I did perfectly knowing that I would erase my userdata partition.

Maybe I wasn’t clear enough, but I did not succeed in any of the steps, so I couldn’t either have TWRP running. I have a backup of all important things because a phone is just a phone…

My concern now is that there may be tens, or hundreds, or thousands of Fairphoners in the same trouble and that I’m not going to have an FP2 up and running any soon… as the repair service is « overwhelmed » as they are stating it.

Best regards,

Guillaume

1 Like

By any chance, maybe you didn’t wait enought time on the “Fairphone / powered by Android” black boot screen?

who are you actually talkin to?

Sorry, you are right, I should have pointed my answer to Lomig.

Each time, I waited for several minutes, let’s say 3 to 5, isn’t that enough ?

No definitely not!
If I am correct, I red in this forum that some people had to wait at least half an hour (or hours?) before the device finally finish installing everything.
Can everybody confirm that?

1 Like

I had the same problem. Fairphone powered by android for hours.

Volume up plus power button for 15-20 sec. solved it for me. dont release after it vibrates!
After 15-20 sec. TWRP started and i was able to restore a backup.

@Zwetschke: I guess you are using the free software version for FP2, as you mention TWRP which is included in it.

On my side, I reflashed the normal 1.3.6 version of Android with fastboot, which went smooth, but then the reboot was still stuck on “Fairphone powered by Android”. I tried what you said, waited for a few seconds after the vibration (but not too long either because after another 10 to 15 seconds, another reboot occurs) and released volume up and power buttons. Same behavior, no recovery tool being launched :frowning:
Questions: how long did you wait after vibration before releasing buttons ? Does it matter whether the USB cable is connected to the computer ? Does it matter whether battery is inserted or not ? Mine seems to be discharged now and I’m not sure that it gets charged without any OS controlling it.

I’m going to reflash the latest open source 16.06.0 image for fastboot, which includes TWRP as far as I know. But I’m not expecting much out of this. I’m afraid there is something else wrong with the phone.
[update] nothing better with this open source version :cry:

@Gauthier67, did you make any progress on your side ? Did you get any feedback from Fairphone support ?

@Lomig, I did exactly the same as you, and still nothing better. I have no answer from the support either.
The only news is that last time I didn’t manage to flash the system.img, and now it worked.
Just for info, what system are you using on your computer? I’m on Ubuntu 14.04. I’ll try the procedure from windows tomorrow.

I’m using MacOS 10.11.5 El Capitan. I currently gave up and I’m waiting for the support to answer, hopefully during the week to come. I will try it from windows if you report some success, which I doubt very much.

If you all flash so much, why don’t you simply flash TWRP as recovery. If that works, you won’t have any trouble flashing the other images oder single images, doing backups and restores. And if you are working with TWRP be aware, not to flash any recovery-image - or tell TWRP to prevent that. Flasing the update via this recovery is under 15 minutes.

By the way: working with adb and fastboot is always the same on Mac, Win, Linux …

Update: After reseting the phone, it still bricks. So, it’s probably not a problem with the update…

What kind of reset did you do? Only after a hard reset you can eliminate a software isse.

1 Like

In my case, I can not go to the recovery mode, as the phone never gets out of the black “Fairphone powered by Android” screen.
The only communication channel that I can open with the phone is from computer to phone with the fastboot mode / protocol, which reports a successful flash of either the regular 1.3.6 OS, or the latest open source version, but no reboot occurs in either case, even after waiting for several hours. This fastboot reflash is somewhat the equivalent of a hard reset, isn’t it ?

As the only thing that I performed so far is software operations, I would say that my phone is soft-bricked. But then maybe there’s something wrong with the memory or some other hardware.

Sounds like you are in Fastboot mode (Power + Vol. down). If you want to get into the recovery, you need to press [Power] + [Vol. Up].

1 Like

Let me be more precise, I already several times to enter recovery mode (i.e. power + volume up press for ~10 secs): after the phone screen goes black for one second (tentative reboot ?), then lights up again with the “Fairphone powered by Android” screen, and does not change for hours whatsoever.

This is why I’m saying that I cannot enter the recovery mode.

You don’t need to press both buttons for 10 sec., it is sufficient to release the buttons once the phone vibrates.
Though I don’t know if that denies you to get into the recovery.

Since you have access to fastboot, you could try to only flash the recovery image. Unfortunately I can’t find the file for the latest release, but since you already tried to install the 1.3.6, the corresponding recovery image is available here; just unzip. If I’m not mistaken, you would then flash the recovery with the command

fastboot flash recovery.img

The whole archive would also be the proper file to flash from fastboot, if you want to install the 1.3.6. system (note, that for fastboot you should NOT use the *ota.img file).

Hello
If for any reason you’re unable to flash anything (like flash partitions messed up), you could try to run TWRP without flashing it :

fastboot boot recovery.img

instead of fastboot flash