FP2 bricked during update to 1.4.2 - no recovery mode

Nop, it is just like the rabbit and the hat thing: “Look, this is Twrp. Pay closed attention… Voila, Twrp is not here anymore!”

1 Like

I don’t have TWRP installed, but I have bricked my Fairphone by trying to update to 1.4.2.

The notification came as normal, so I used the updater app, and it’s been stuck in a bootloop since.

Similar problem in this thread: https://forum.fairphone.com/t/update-1-4-2-cant-open-dev-permission-denied/18994

I can confirm this behaviour on FP Open OS 16.05. I downloaded the fastboot version, unzipped the stand-alone images and just flashed system/cache/userdata. Afterwards my recovery switched to TWRP 2.8 and replaced my newer TWRP 3.0!

Solution (in my special case):
After flashing, DO NOT restart system and immediately boot into your recovery instead! TWRP 3.0 will be still present and shows a dialogue whether to allow modifications on system. Confirm this and TWRP is able to prevent to be overwritten by the system!

So now I have fastboot and adb installed on my ubuntu. I can see a device connected to through fastboot.
But when I type “sudo fastboot -u update FP2-gms54-1.3.6-img.zip” in the shell, the update fails :

archive does not contain 'boot.sig’
archive does not contain 'recovery.sig’
archive does not contain ‘system.sig’

Bootloader Version…:
Baseband Version…:
Serial Number…: XXXXXXX

checking product…
OKAY [ 0.002s]
sending ‘boot’ (13662 KB)…
OKAY [ 0.431s]
writing ‘boot’…
OKAY [ 0.145s]
sending ‘recovery’ (12292 KB)…
OKAY [ 0.388s]
writing ‘recovery’…
OKAY [ 0.138s]
sending ‘system’ (919305 KB)…
FAILED (remote: data too large)
finished. total time: 1.111s

Any idea on how to bypass this “FAILED (remote: data too large)” error?

The file you used is not the latest version. Though I don’t know if that caused the problems. Apparently the newest version is not yet linked on the website.


I also got the fastboot link from my Mac. So what I did is the following steps with no success. Each time, the fastboot process went smooth without any error, but each time, the normal reboot ended up with the same lasting “Fairphone / powered by Android” black boot screen.

  1. Just installed the recovery.img from the FP Open OS, using "fastboot flash recovery recovery.img, as a way to install TWRP as stated by Roboe.
  2. assuming that the boot process wasn’t working, I also flashed the boot.img from same version in the same way: "fastboot flash boot boot.img
  3. lastly, I did the 4th method from the manual install page. Unlike Gauthier67, I used the -w option and not the -u.

Here is a hardcopy of the fastboot output for step 3. There must be something else wrong with the phone… I’ll file a service request and wait.

bassan:~ lomig$ fastboot -w update FP2-gms54-1.3.6-img.zip
target reported max download size of 536870912 bytes
archive does not contain ‘boot.sig’
archive does not contain ‘recovery.sig’
archive does not contain ‘system.sig’
archive does not contain ‘vendor.img’
Creating filesystem with parameters:
Size: 27845963776
Block size: 4096
Blocks per group: 32768
Inodes per group: 8176
Inode size: 256
Journal blocks: 32768
Blocks: 6798331
Block groups: 208
Reserved block group size: 1024
Created filesystem with 11/1700608 inodes and 150772/6798331 blocks
Creating filesystem with parameters:
Size: 671088640
Block size: 4096
Blocks per group: 32768
Inodes per group: 8192
Inode size: 256
Journal blocks: 2560
Blocks: 163840
Block groups: 5
Reserved block group size: 39
Created filesystem with 11/40960 inodes and 5256/163840 blocks

Bootloader Version…:
Baseband Version…:
Serial Number…: fbecf69c

checking product…
OKAY [ 0.002s]
sending ‘boot’ (13662 KB)…
OKAY [ 0.431s]
writing ‘boot’…
OKAY [ 0.316s]
sending ‘recovery’ (12292 KB)…
OKAY [ 0.388s]
writing ‘recovery’…
OKAY [ 0.282s]
erasing ‘system’…
OKAY [ 0.308s]
sending sparse ‘system’ (522736 KB)…
OKAY [ 16.395s]
writing ‘system’…
OKAY [ 14.189s]
sending sparse ‘system’ (396568 KB)…
OKAY [ 12.490s]
writing ‘system’…
OKAY [ 14.398s]
erasing ‘userdata’…
OKAY [ 5.716s]
sending ‘userdata’ (139025 KB)…
OKAY [ 4.354s]
writing ‘userdata’…
OKAY [ 3.752s]
erasing ‘cache’…
OKAY [ 0.204s]
sending ‘cache’ (12520 KB)…
OKAY [ 0.394s]
writing ‘cache’…
OKAY [ 0.327s]

finished. total time: 73.951s

[update] After filing a request, I received a notice automatically closing it along with an email giving the advice I already followed, and stating that “we’re currently dealing with an overwhelming backlog of requests”. I’m afraid I’m not going to see my FP2 up and running any day soon. :cry:

Running fastboot -w update softwareupdate.zip with the -w flag you are overwritting the recovery and boot flashed on the previous steps PLUS deleting all your userdata from the phone. ALL.

$ fastboot help ... -w Erase userdata and cache (and format if supported by partition type).

I really hope you made a backup of important stuff from TWRP before executing the third step you describe. That was the only purpose of my tutorial.

And why did you flash TWRP as recovery without using it? The file you downloaded holds the images for the whole OS, so flashing it all has to remove the just flashed recovery and boot.img.

Instead you could have used TWRP to backup the images “system”, “cache”, “boot” and “userdata” and then flash the images from the zip-file (without “recovery”) via TWRP.

Try again, this way you’ll learn …

Thanks for your concern, I did what I did perfectly knowing that I would erase my userdata partition.

Maybe I wasn’t clear enough, but I did not succeed in any of the steps, so I couldn’t either have TWRP running. I have a backup of all important things because a phone is just a phone…

My concern now is that there may be tens, or hundreds, or thousands of Fairphoners in the same trouble and that I’m not going to have an FP2 up and running any soon… as the repair service is « overwhelmed » as they are stating it.

Best regards,


1 Like

By any chance, maybe you didn’t wait enought time on the “Fairphone / powered by Android” black boot screen?

who are you actually talkin to?

Sorry, you are right, I should have pointed my answer to Lomig.

Each time, I waited for several minutes, let’s say 3 to 5, isn’t that enough ?

No definitely not!
If I am correct, I red in this forum that some people had to wait at least half an hour (or hours?) before the device finally finish installing everything.
Can everybody confirm that?

1 Like

I had the same problem. Fairphone powered by android for hours.

Volume up plus power button for 15-20 sec. solved it for me. dont release after it vibrates!
After 15-20 sec. TWRP started and i was able to restore a backup.

@Zwetschke: I guess you are using the free software version for FP2, as you mention TWRP which is included in it.

On my side, I reflashed the normal 1.3.6 version of Android with fastboot, which went smooth, but then the reboot was still stuck on “Fairphone powered by Android”. I tried what you said, waited for a few seconds after the vibration (but not too long either because after another 10 to 15 seconds, another reboot occurs) and released volume up and power buttons. Same behavior, no recovery tool being launched :frowning:
Questions: how long did you wait after vibration before releasing buttons ? Does it matter whether the USB cable is connected to the computer ? Does it matter whether battery is inserted or not ? Mine seems to be discharged now and I’m not sure that it gets charged without any OS controlling it.

I’m going to reflash the latest open source 16.06.0 image for fastboot, which includes TWRP as far as I know. But I’m not expecting much out of this. I’m afraid there is something else wrong with the phone.
[update] nothing better with this open source version :cry:

@Gauthier67, did you make any progress on your side ? Did you get any feedback from Fairphone support ?

@Lomig, I did exactly the same as you, and still nothing better. I have no answer from the support either.
The only news is that last time I didn’t manage to flash the system.img, and now it worked.
Just for info, what system are you using on your computer? I’m on Ubuntu 14.04. I’ll try the procedure from windows tomorrow.

I’m using MacOS 10.11.5 El Capitan. I currently gave up and I’m waiting for the support to answer, hopefully during the week to come. I will try it from windows if you report some success, which I doubt very much.

If you all flash so much, why don’t you simply flash TWRP as recovery. If that works, you won’t have any trouble flashing the other images oder single images, doing backups and restores. And if you are working with TWRP be aware, not to flash any recovery-image - or tell TWRP to prevent that. Flasing the update via this recovery is under 15 minutes.

By the way: working with adb and fastboot is always the same on Mac, Win, Linux …

Update: After reseting the phone, it still bricks. So, it’s probably not a problem with the update…