FP2 Battery Problems (drains quickly, CPU gets hot) - See batteryguide for workarounds

I don’t have any more SIM cards to try (!) but as each individual SIM card works fine alone and doesn’t create any problems I’m guessing that it would be the same with some other cards…

I know that it’s weird… my FP2 is quite fond of doing weird things… I finally wrote to support and waiting for their answer…

Support’s answer came and it’s a general “battery problems answer”. Unfortunately nothing about SIM card related… :frowning:

I write in french because I’m not so good in english.:Il faisait assez chaud ici en Alsace aujourd’hui…
la charge de mon FP2 s’interrompt quand la température monte au delà de 41…42 ° et le voyant s’éteint . L’arrière du téléphone est très chaud et la température peut atteindre 47°. Si je le met au frigo , la température baisse et il recommence à charger…
mon FP2 a un peu plus d’un an …

est ce la batterie qui commence à faiblir?
Avez vous eu ce genre de problème? et que faire ?
Merci d’avance pour vos réponses

I found out what the problem with my battery is!!!

The data connection 4G, 3G

I was on vacation and turned the data off… battery worked fine lasted quite long, phone worked fine… didn’t get hot at all.
Then I came back… at the airport I turned the data on. My phone was at 60% and one second later it was at 20%!!!

Since it gets really hot, battery lasts very little… this is definitely not normal behaviour, is it?

PS apparently nothing to do with any particular applications.


This has just started happening to me. Brand new phone (Support replaced mine a few months ago due to restarts). The battery would last probably 7-8 hours max. (100% at 8:30 when took off charge, It would be dying by 17:00ish if I didn’t charge it.

Yesterday it just drained really quickly.

Today, took the phone off charge at 8:30 at 100%. It is NOT connected to mobile data. It is not connected to a Wifi ssid apart from about 30mins first thing. It’s mostly not been used sat on my desk at work (due to no data connection). It’s now 10:44 and the battery is at 15%. So, it’s lost most of it’s charge with no use in about 2 hours. See images:

1 Like

I had a very similar behaviour after installing Open OS update 17.07.6. After charging and switching on the phone, the charging level of the battery remained almost constant for about an hour and then it started draining very quickly - e.g. from 95% to zero in just a few hours. I had the same behaviour with the same draining rate even in flight mode with no app running and the screen turned off most of the time (third loading unloading cycle in the screenshot).

Today in the morning I reverted back to 17.06.4 using a TWRP backup - and the problem is gone. Only 5% battery loss in more than 10 hours with WiFi and mobile connection switched on, today. So the problem is very probably contained in the Open OS update 17.07.6. I already thought about whether I installed any apps or changed any configuration settings after the update, but I’m pretty sure I didn’t.

1 Like

Yes it really sucks… This is a major problem that needs a solution…

In case someone else is facing the same problem - meanwhile I found the solution for mine: I have Open GApps (Pico) installed on my FP2. Flashing the Open GApps package again after installing the 17.07.6 update solved the problem - no more battery drain :slight_smile:


Haven’t upgraded yet (too scared to do it while on vacation and not have a working phone anymore) but I’ll definitely take your advice when I do.

Just one question though : did you flash Pico at the same time? Or did you finish the update completely and flashed Pico alone afterwards?

I did it separately. First, I took the update via Fairphone Updater. And after that was completed, I restarted the phone into TWRP and flashed the Open GApps Pico package.

I am facing the same issues. Installing a new gaaps pico version improved the behavior but I still have the feeling the CPU did not become that hot at fpoos based on Android 5. The power consumption is still dramatic if I use the phone to stream videos or if I use the phone for navigation.
The upgrade from Android 5 to 6 worsened the situation. I would appreciate a bugfix very much.

A post was split to a new topic: Reference to the battery kickstart procedure

OK did all that… Phone’s upgraded and gapps installed.

This seems to have made things a bit better WHEN PHONE’S NOT USED!

As soon as I use the phone battery consumption is disastrous…

I still think that this is NOT application related and that there’s something seriously wrong with FP2.

So conclusion : as long as phone is not used battery is OK… Unfortunately I don’t need a phone I don’t use…

I’m really sorry to say but it may be the end for me… My hope was that FP1 could be upgraded, well this ship has sailed (FP1 is the best phone EVER and I love it!!!) and FP2 been giving trouble right out of the box and till now… Completely unreliable…


Hello. I have the same battery problem. Before the update 17.4.8 it was the display that consumed the most, according to the indications of Parameters / battery. Then it was wifi. I tried all the save-battery tricks without improvement. I tried too Xposed Installer Smart Network module, who should cut wifi and mobile data when the screen is off, no more improvement. According to the statistics of consumption the wifi is always in function, even in airplane mode! In this screenshot phone was in airplane mode since 15:00 to 16:00, but wifi is always on

I would like to install Lineage OS, but it uses the same modem drivers: will there be an improvement?
We need a solution.

My problem exactly!!! We definitely need a solution…

I had the same problem with WiFi always on, now it’s gone. Take a look at this post, maybe it could help:

Thanks chrisse, I already noticed this post and tried all the suggested tricks. I installed yesterday LineageOS and now Wifi is no more on all the time.

What I still have no explanation for is the following:

  • When I charge my phone while it’s turned off, the charging is super slow or does not happen at all. But the phone (CPU) gets hot.
  • As soon as I start the phone, the charging starts at a normal speed and the phone (CPU) cools down.

This can hardly be due to a background process running.
Any ideas?
Of course I take the easy way and don’t charge my phone turned off anymore. An explanation would still be appreciated.

Anyone else seen this before? Phone had been in the whole time in a bag and unused (mostly). Picked it up to see it was at 1% which seemed odd

I rebooted it, and turned battery saver off and I’ve been using it solidly for ages now on 1%…

A post was merged into an existing topic: Battery life in LineageOS