FP2 'awake' when phone inactive, draining battery

I’ve had a problem the last few weeks with my phone constantly ‘awake’ and draining the battery. A few nights ago I went to bed with the battery at about 80% and when I woke up 7 hours later the phone was dead. I’d put the phone on airplane mode so it shouldn’t have been using much battery. From the battery usage chart, it looks like the phone was ‘awake’ all through the night, ironically when I was sleeping. The same happened this morning when it went from about 30% to 2% in a few hours with virtually no usage. I can’t show screenshots I took because it’s died now, but I’ve attached a screenshot from a couple of weeks ago showing the same problem. Has anyone else had problems with their phones coming awake through the night when they’re definitely not using them? What is the ‘awake’ function when the mobile signal, wifi and screen are all off? And how do I make sure it doesn’t stay ‘awake’? I’ve tried a battery saver app that closes all active apps, but that doesn’t seem to be helping.


This is very likely due to some apps that work in the background, or making wakelock calls. You may need to look for apps causing that draining. For example, apps like Better Battery Stats or Wakelock Detector
can help you to find the trouble-making app.


I’m having similar or related issues, but can add the problem of the battery draining even when powered down and plugged in.

I’ve gotten rid of any apps that might be causing this and gone as far as making a hard reset, but the phone still will not maintain a charge and will randomly reboot itself when I have been able to get a charge on the battery.

Any thoughts or suggestions?


1 Like

I have this awake problem and was about to reset my phone until i saw this. If you find out whats causing this please post it asap!

1 Like

Same here! I lost almost 50% of battery charge during the night. I don’t have any strange app in my FP2 and also tried to follow the battery saving guide and deactivate every thing accordingly. But apparently it doesn’t help.

I’m not sure how useful the findings of someone else can be. Particularly if its related to installed software, or may have very individual causes. So I guess you better look for yourself what is causing your battery drainage.

I’ve tried the Battery Doctor app https://play.google.com/store/apps/details?id=com.ijinshan.kbatterydoctor_en&hl=en_GB which worked for a while but then it started draining again due to the ‘awake’ being activated. The app has a more extreme setting, ‘Super Optimise’ that shuts down any active apps and that seems to have helped a lot, but I don’t know much about the app and how it is for privacy and the like. In terms of the battery drain though it’s worked very well on the more extreme Super Optimise setting.

I have to say I’ve been really disappointed with the FP2. I don’t know whether this awake problem is the phone or android, but it’s almost the last straw for me and I’m really thinking about returning it and switching for a conventional smartphone. Had problems now with the screen during calls, one section of the touchscreen not working, the camera not focussing and now the battery draining. Also had no response to a support request I filed 3 weeks ago.

This is usually not a hardware issue, but a software issue. As far as I know the awake means, that the phone can’t fall into deep sleep, indicating that some processes are running.
If it would be a fault of the Fairphone OS, everyone should have it, so I my guess would be, it has to be with your individual set up.
Some apps help to prevent background processes from happening, but in my opinion the only sustainable solution is to find and deal with the root cause, which however needs some analysis to find it.
This is one of the downsides of open systems where you can install many apps/program (e.g. compared to conventional, non-smartphones). If one is faulty, it can ruin the experience of the whole system.

Same here… a new bug which increases my patience for that phone… It happens when i turn off the phone at about 30-40% at night and when i turn the phone on in the morning it just goes wild…

I’m still having this problem with the phone staying awake. It stopped for a while but has started again. I’ve tried my best to disable apps that I think could be causing it and don’t really have any apps other than the usual ones I’m guessing a lot of people have. Yesterday I charged my phone to 100% and unplugged it at around 5pm. It stayed awake the whole evening and even when I put the phone on flight mode at around 10pm and it stayed awake the whole night so by 7am it was down to 30% charge. I’ve installed wakelock detector but can’t see what could be causing it. It’s still awake right now and I can’t work out how to stop whatever is keeping it awake. It’s making the phone almost useless as I can’t rely on it to last more than half a day on a full charge. I’ve attached some images of the battery life and what wakelock detector is showing me in case anyone can help.

I had the same issue and while investigating ~80% was com.android.phone under wakelocks.

But after doing a fresh install it works again like a charm.

I observed that after an OTU (for openOS) with openGapps installed it ALWAYS goes into the infite loop of preparing Apps. Only installing openGapps.zip via TWRP helps.
But then the battery drain starts.

Very wierd!

I’ve been optimizing my phone a lot with the help of BBS… For the background: I’m using FP Open OS with XPosed, Ampify and Greenify.
For the rest, it is heavily used with chats and twitter and feedly and ebook-Readers…
So, I’m getting a idle battery drain of 2.5% up to 3%, which looks not too bad for my usage (see http://forum.xda-developers.com/android/general/guide-0-0-hour-idle-battery-drain-stock-t2973588). Besides fiddling with amplify, what is the end result are some wakelocks which can’t be controlled (by me), which are kernel dependent, or even hw dependent…

Here is the gist of it:
Deep Sleep (): 5 h 35 m 46 s 67,3%
Awake (Screen Off) (): 2 h 42 m 36 s 32,6%
Screen On (): 14 s 0,0%

Awake, Screen of is way to hight, because of:
Kernel Wakelocks !!! wakeup_sources !!!

msm_ehci_host (): 2 h 25 m 8 s Cnt:(c/wc/ec)2964/0/0 29,1%

msm_ehci_host is probably connected to GSM or (more probably?) WLAN.
I had WLAN running and mobile data off.

So, as we can’t do too much here, probably (except for developing Cyanogenmod with its own kernel :slight_smile: ) I guess this is just for reference.


(If I know how to include the BBS File I’ll include it as a whole)

@lklaus I moved your post here to avoid duplicate threads.

@all: Please check if your wakelocks could be related to the proximity sensor. In that case please continue here:


hi @paulakreuzer, that’s fine. but it is not related to the proximity sensor issue. i disabled all actions using proximity sensor (which can be seen in the full statistics, and with proximity sensor the phone is 100℅ awake). here the phone is about 30℅ awake with screen off. according to knowledgeable people on XDA this points to a kernel issue (hw driver, probably). So, if this could get fixed battery stats would still be better… :slight_smile:

edit: anyone know how to include the bbs file? is the a way and is this accepted? it’s about 250KB

1 Like

btw, I happen to have an older bbs file, where i disabled WLAN. the i have 1.1℅/h drain per hour, which is way better. I don’t know wether it’s comparable (earlier fpoos version), so I’ll make a new one soon, but here awake with screen off is at 10℅

Kernel Wakelocks
bam_dmux_wakelock (): 22 m 24 s Cnt:(c/wc/ec)458/6/0 5,2%
msm_ehci_host (): 21 m 18 s Cnt:(c/wc/ec)437/0/0 5,0%

Well, just made a new BBS dump without WLAN… Its at 1.9%/h, “significantly” higher, but I really can’t see a problem. Except probably that I have a tasker profile using the motion sensor, which was active for practically the whole time I did this statistic… Will try to do a dump without the motion sensor…

Hi all,
I don’t know if my problem is the same as above, but I observed that the display of my FP2 “awakes” every 27 mintues all on its one.
I have noticed this behavior a few weeks ago and changed nothing (added no Apps or else bevore it started).
I tried to undersand the possible solutions mentioned above but I didn’t :blush:

Could anyone please tell me:
Is there a solution? If there is, how do I execute it?