FP2 1.2.8 several app don't work correctly

Since i’ve updated the FP2, some apps don’t work correctly. e.g. ocr reader: after taking the pciture of a code, the stopps. Or the german railway app it is not possible any more to change the date.
I remember the same problem at the very beginning with a turnaround you gave.
How to get them working?

1 Like

it is the privacy impact again, it seems still to be a problem with the new release.

I have the same problem. Several railway apps won’t work, it’s either impossible to set times or stations. Also, the Facebook app doesn’t work properly, for example I cant see profiles of friends, see the pages of groups etc. What to do?

Did you already try to re-enable the privacy impact? (settings --> sounds & notifications)

Yeah I did it a few months ago and it worked to some extent though not fully,

I guess you’ll have to do it again after the update.

Thanks to the replys and the hints… I did the privacy again (settings, sound & notification, privacy, ata strange place…). It seems that the update put the setting back. And I hoped that the update will solve the problem.

Yeah, it was supposed to solve it, but apparently the issue isn’t really solved.

I think that the FP team wanted to release the update as quick as possible in order to increase stability (regarding reboots, screen, and charging issues), so probably we’ll have to wait for the next update for having the privacy impact bug solved as well.

As for me: I just keep it now enabled, even though I don’t think that this app makes any sense …
And I guess that re-enabling the privacy impact will solve most issues that fit under this thread title :slight_smile:

Hi yes i am really glad for this update, my solved problem was that I couldn’t use the phone app. I had to use anasus pone up, copy the phone number and paste it into the aus app. So really I am glad to wait another while, with that turnaround it works well. thank you for answering.

I had the same problem with public transport app (9292OV) and with group management in what’s app. Changed the privacy impact settings and now the problem is solved. Thanks for the info.

@Ida_Lauridsen seems I got similar problems,
Since the update when I click a link in the Gmail app and it supposed to open in Facebook app instead of being taken to the right post or event or comment I end up on my FB main page, can’t edit Evernote notes either if I try to use round green symbol with pen on it. Tried to clear cache but did not make a difference, Emailed zendesk, let’s see what they suggest

Yes, the Privacy Impact problem isn’t solved by the update, so please
Re-enable Privacy Impact by unticking the option found at:
Settings > Sound & Notifications > Privacy Impact


Wow. After unchecking the Privacy Impact option, three misbehaving apps suddenly work normally again. There were a number of strange bugs, where I would click on an innocuous action and, inexplicably, nothing would happen; not even an error or warning. I’ve been in contact with the developers of one of those apps, assuming it’s a bug on their side.

I’m happy that my phone is now working again, but I must express my surprise that a bug this serious (it unpredictably disables functionality in third party apps), that the Fairphone developers already know about, was in no way addressed in the latest update. Even if you couldn’t yet fix it properly, shouldn’t the Privacy Impact option be unchecked by default? Shouldn’t users be actively informed about this?



Re-enable Privacy Impact by unticking the option found at:

:flag_gb: Settings > Sound & Notifications > Privacy Impact
:flag_de: Einstellungen > Ton & Benachrichtigungen > Privacy Impact
:flag_fr: Parametres > Sons et notifications > Privacy Impact
:flag_it: Impostazioni > Audio e notifiche > Privacy Impact
:nl: Instellingen > Geluid en melding > Privacy Impact
:flag_es: Ajustes > Sonido y notificationes > Privacy Impact

If it was already unticked, then tick it and untick again.

##For further discussion please continue here: