[FP1] USB connection not working

The usb connection dosn’t work anymore on my pc (while it used to). I can easily access the usb connection panel and the MTP box is ticked, the phone also charges but it doesn’t appear on my computer screen.

I have tried rebooting the pc, the phone, ticking “charge only” then back to “MTP”, tried with different USB ports and different cables, with and without the phone cover.

When I look in the computer device manager, it says “other devices” -> “MT65xx Android phone” with an error icon and says thay can’t find the driver.

I used to be able to access it on my computer (I last did it a few weeks ago) and I can still do it on other computers. I don’t know what has changed.

That still sounds good, at least the physical connection is still working somehow :slight_smile:

What version of Windows (I assume) do you use? This in important, normally it should work out of the box.

Maybe it will be best to keep this info under one topic here, else it could confuse people.

Maybe removing and reinstalling the driver will help? Which driver did you use? Be careful about installing drivers from strange sources (don’t :slight_smile: ), try to use the one from MS!

Maybe you can remove the driver and trigger the process on your computer that lets windows search automatically for latest driver?

Disclaimer: I currently do not own a working windows installation, I just try to remember what I normally did in that case.

First of all, this is a forum only for problems with the Fairphone. We do not support any other phones.
Secondly, it would be very helpful to include punctuation in a post to make it better understandable.
Don’t expect an answer in this forum.

2 Likes

Before the topic is closed - did anyone find another solution to this? When I click 'USB computer connection" it only refreshes the SD-card storage info, regardless of whether the phone is connected or not. The phone charges but there are no options on the screen :frowning:

Have you tried another cable? Does your FP1 connect to other computers?

Hi All, Just for Fairphone to know, I’m in the exact same situation as @c_c_chaos . I also think it is HW issue even if I just made 2 days ago the 1.8.7 upgrade… Strange coincidence…
@c_c_chaos : Did you solve the problem ? It’s very annoying.

Have you run all the tests described above? If it is a hardware issue, try to contact the support and try to get a new board using the warranty. I wonder how many devices are affected.

1 Like

Also having the danger of spamming my messages to often to the forum I try it anyway:
Did you all gave already a try with cleaning the USB port of the FP1, which maybe could prevent a proper connection between USB jack and connector and thus the proper recognition at the PC?
If not: please try it and report back if it helped!


Cheers, Robert

I agree, someone should do a usb-port checklist/how-to. :slight_smile:

Hi Sjouke,

From this thread I learned to check the following;

  1. Try out different USB cables,
  2. Try out a different USB port, or even a different laptop/PC if possible.
  3. Try to start the fairphone in safemode (see link above in the thread
    somewhere…) to rule out the possibility of software interfering with
    the USB connection.

If all that has been tried and the problem persists, then yes, it would
seem the USB connected is damaged.

Kind regards,
James

Hi Robert,

I don’t know how to describe it exactly, it was an USB cable that came
with the Amazon Kindle charger that worked. Here is the link to the
exact model I had purchased;

But I suppose any Micro-USB to USB cable that can transfer data should work.

Cheers,
James

@JamesR404: why not add as point 1.) Clean USB port caruflly with a screwdriver from dust?

Seems that the FP-community is quite sceptical about this, but in my case it helped!!!

Hi ! Yes @fp1_wo_sw_updates , I tried all this, and I can add that when just pluging any cable, there is no charging, Since a few days ago, I have to apply a special oriented pressure on the plug to make it charge the phone. It really means that there is an HW issue and the USB PC connection appeared at the same time.
Thanks @therob I also tried to clean it up carefully.

Message sent to the support, waiting for their answer. I don’t know if I’m still under warranty since I’m from the first batch…

1 Like

I used to have W7. The problem (not being able to see the phone on my computer or transfer data to and from it) occurred while I still was on W7. Now I moved to W10 and the problem still occurrs. I have another computer with W8 and the phone works fine with it.

I didn’t install any driver for the phone to work (when it still did), the computer detected it automatically. So I don’t have any driver that I can uninstall and reinstall. I also have updated every driver and software I had on the computer and nothing changed regarding the phone.

Here are two drivers to try:

Does one of them solve your problem?

Adb wireless may help bypassing an USB port broken.

If you cannot connect the FP1 to a PC even trying different cables and different PC maybe the FP1’s USB port is partly broken. It occurs…

Fortunately you can use adb over wifi if your PC and your FP1 are connected to the same wifi LAN. You just need to install an app on the FP1. There are some useful apps on Google store, among them “ADM wireless by Henry” is very simple to use. Juste launch it and you will see the command to run: "adb connect ", where ip-address may probably vary according to your network configuration.
It helped me a lot to install the alternate 4.4.4 ROM :wink:

2 Likes

Hi,

I have the same problem - no USB connection in settings. I have found the USB Computer connection like @c_c_chaos said but when i press it, it just disappears and doesn’t open anything.

Any ideas?
Thanks,
Mark

There is a difference in usb-cables. Two wired = only useable for charging
Four wired = useaable for charging and data-transport.
So make sure your usb-cable is suitable for data-transport.

2 Likes

Thanks this worked for me - photos transferred to PC now