[FP1] USB connection not working

Problem statement
When I connect my FP1 (OS 1.8.7 / Kola Nut, no single partition upgrade) to a computer, the phone charges, but nothing else happens. In particular,

  • the phone doesn’t show up in any way on the computer (e.g., the phone is not in the output of lsusb on a Linux machine);
  • neither the phone’s internal memory nor the additional sd card may be accessed via the computer; and
  • there is no mention of a USB connection in the notification screen of the phone.

What I’ve tried

  • Tried several USB cables;
  • tried several computers, some running Linux, some Windows;
  • connecting the phone in both locked and unlocked mode;
  • restarting the phone before and during USB connection;
  • enabling and disabling the “USB debugging mode” in the phone’s options; and
  • in the Linux situation, following several tutorials such as those linked here (e.g., using the package mtpfs).


  1. Could this conceivably be a hardware problem with the phone? How could I make sure?
  2. What options are there for making the USB connection work?
    (I am aware of other methods of file transfer and don’t seek advice on them. I am interested specifically in the USB connection.)

Please check your “USB computer connection” settings screen first!

Check the "connect as" section, make sure that you do not use “Charge only”!

Make sure that you check this dialog first! And change the settings (best to MTP) before you read the rest of what I’ve written here. The dialog is a bit hard to find. Really double-check this! I read what you wrote, but it’s sometimes better to check twice.

If this did not work – other possible reasons (hopefully not in your case)

The “no messages part” worries me a bit. So if all the above really did not work, the usb connector could be damaged.

There is some info about usb here on the forum. I’m not an expert, but to me it looks like maybe the data ports (they are in the ‘middle’) of the usb connector became loose, while the pads for the power (on the “outside”) are still working.

But I can be wrong and it’s just a software issue, see above!

You could make sure by peeking inside the phone (are the pins of the connector on the board still okay?). Or by carefully cleaning the connector from the outside with a thin needle (lint, sand, etc.)

Only do this if you know the risks.

Please also wait for answers from the others before you do something, maybe they know more than I do. Maybe in the end contacting the support will be the better solution.

Update: This is how my FP1 looks like if connected (3.19 kernel):

[13426.291616] usb 1-8.3: new high-speed USB device number 6 using xhci_hcd
[13426.380887] usb 1-8.3: New USB device found, idVendor=0bb4, idProduct=0c02
[13426.380895] usb 1-8.3: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[13426.380899] usb 1-8.3: Product: MT65xx Android Phone
[13426.380903] usb 1-8.3: Manufacturer: MediaTek
[13426.380906] usb 1-8.3: SerialNumber: XXXXXXXXX

Depeding on the mode (MTP or debugging) it should show up with usbview as


0bb4:2008 xxxxxx

or with usb debugging as

0bb4:0c02 xxxxxxx

Thank you very much for your suggestions.
The problem is: I can’t find the “USB computer connection” settings. In particular, the button in the top right corner seen in this picture you linked to is not there. Nor does anything happen when, while the “storage” settings screen is displayed, I touch the standard button in the lower left corner which sometimes opens menus.
I’ve tried several other places found via Google (apparently the location of this particular settings screen within the menu varies greatly depending on the Android version?!). I’ve tried all of this with or without an USB cable plugged in.

Probably I’m overlooking something. Is there a more precise guide indicating how to access the “USB computer connection” settings?

Try to swipe down the notifications panel (on the top) and choose the USB notification. Below are “real” screenshots (FP1/1.8.7) for the notifications panel:

And for the “settings screen”:

Do you sometimes see messages like “device not responding”, “device not accepting address”, or “device descriptor read/XX, error -XX” in your logs? This is how faulty usb devices (computer or the client!) often look like in a log file if they still try to make some kind of connection.


When I don’t have a USB cable connected, pressing this button in the storage settings screen brings up a single entry, which is ‘USB computer connection’. Tapping it only refreshes the storage usage info. If I do connect a USB cable, I do get options there. So you’re looking in the right place.

You could try safe mode to rule out apps interfering with the USB connection. I’m not sure whether there is a hardware test for the USB connector available in testing mode, and if so, how it works. @fp1_wo_sw_updates’s explanation is very plausible though. Some people report that they need to angle the usb plug slightly downward (when the phone is screen up) to charge/connect, which is also indicative of a break between the port and the mainboard. Be careful if you want to try this though, as you can damage your phone this way as well.


I have the same issue as the original poster, tapping “USB computer connection” after the strange route of Storage > bottom left hardware button (aka menu button) > “USB computer connection”. This does nothing. Regardless if I connect the fairphone per USB cable to laptop or not. I see the phone is charging, so this implies the USB connection is working.

How can I diagnose why the button “USB computer connection” does nothing?

Eugh, I just want to put some of my songs on my phone.

1 Like

I think I have a similar problem. When I connect my phone (FP1U) to the USB port of my laptop, it says ‘connected as a media device’, but it won’t show up in My Computer, and the autoplay doesn’t work. I can find it in Device Management as a portable device. The phone is charging, but I cannot see the storage or exchange data with my computer. From the discussion in this thread, I think the micro-USB connector of the phone my be damaged. Is there a way to verify this?

Thank you again for your replies. By now, I am quite certain that the problem prevents me from accessing the “USB computer connection” settings screen (the 2nd picture in this answer). To be more precise,

  • there is no notification “Connected as a media device” (or any other USB notification) in the notifications panel after plugging in a USB cable; and
  • after installing the unified partition upgrade, I can now access the “USB computer connection” entry from the storage menu (as described by Johannes), but tapping it does not get me to the options - even while a USB cable is plugged in.

Since the problem seems to show up independently from the computer and the USB cable used, I conclude that it is most likely due to a hardware failure, as suggested by fp1_wo_sw_updates in their first reply.


There is a difference in usb-cables. Two wired = only useable for charging
Four wired = useaable for charging and data-transport.
So make sure your usb-cable is suitable for data-transport.



You can always use a SD card to “move” data/music onto your phone! :smile:


  1. Check the usb-cable and the computer with a different device. To exclude cable and computer issues (as @Lidwien describes)

  2. Check the software revisions on the phone (latest?).

  3. Once the FP1 is usb connected to the computer, try once again:

The setting dialog in the old =<4.4 Android versions is confusing. But the notifications panel (see pictures above) should show “something” if connected to a working computer with a working cable.

  1. Send it back to FP. Let the FP guys have a look at it. We are just users helping users.

  2. Let us know.

Good luck!


Thanks guys! Really happy. A different cable on a different laptop works, via Store > menu button > USB computer connection, I now get the list of choices.

So, indeed, if the “USB computer connection” doesn’t work, it’s a hardware problem. If different known good USB ports and USB cables don’t help one, then it’s probably a broken USB port on the phone.

Thanks for the help :smile:

Nice to hear, that you solved this.
For sake of completeness: which USB-cable did you use
Cheers, Robert

My problem looks somewhat different. I have posted a reply in another thread: Problem with sms and Time display

The usb connection dosn’t work anymore on my pc (while it used to). I can easily access the usb connection panel and the MTP box is ticked, the phone also charges but it doesn’t appear on my computer screen.

I have tried rebooting the pc, the phone, ticking “charge only” then back to “MTP”, tried with different USB ports and different cables, with and without the phone cover.

When I look in the computer device manager, it says “other devices” -> “MT65xx Android phone” with an error icon and says thay can’t find the driver.

I used to be able to access it on my computer (I last did it a few weeks ago) and I can still do it on other computers. I don’t know what has changed.

That still sounds good, at least the physical connection is still working somehow :slight_smile:

What version of Windows (I assume) do you use? This in important, normally it should work out of the box.

Maybe it will be best to keep this info under one topic here, else it could confuse people.

Maybe removing and reinstalling the driver will help? Which driver did you use? Be careful about installing drivers from strange sources (don’t :slight_smile: ), try to use the one from MS!

Maybe you can remove the driver and trigger the process on your computer that lets windows search automatically for latest driver?

Disclaimer: I currently do not own a working windows installation, I just try to remember what I normally did in that case.

First of all, this is a forum only for problems with the Fairphone. We do not support any other phones.
Secondly, it would be very helpful to include punctuation in a post to make it better understandable.
Don’t expect an answer in this forum.


Before the topic is closed - did anyone find another solution to this? When I click 'USB computer connection" it only refreshes the SD-card storage info, regardless of whether the phone is connected or not. The phone charges but there are no options on the screen :frowning:

Have you tried another cable? Does your FP1 connect to other computers?

Hi All, Just for Fairphone to know, I’m in the exact same situation as @c_c_chaos . I also think it is HW issue even if I just made 2 days ago the 1.8.7 upgrade… Strange coincidence…
@c_c_chaos : Did you solve the problem ? It’s very annoying.

Have you run all the tests described above? If it is a hardware issue, try to contact the support and try to get a new board using the warranty. I wonder how many devices are affected.

1 Like