FP1 says that SDXC card is "Damaged", while Card works fine with PC

Dear all,

I am a new Fairphone user, just got the phone shipped last week. I want to extend the storage space, so I bought the following microSD card:

Intenso - microSDXC memory card - 64 GB - class 10

The card works fine with my PC (using an adapter to fit card in regular size SD card slot - I just tested it there after FP1 said the card was damaged). However, the FP1 (or Android OS) do not work with this card. After booting the OS, a message: “Damaged, SD Karte ist beschädigt” is shown in the top left next to a symbol representing the SD card with an exclamation mark in it. Then, the message disappears, but the symbol for the card with the exclamation mark inside it remains. Hence, the card as such is obviously detected, but somehow the hardware/software are do not fully work with it.
Also, trying to activate the card from the “Einstellungen->Speicher->SD Karte bereitstellen” (Settings->Memory->SD card) menu only gives the same behavior.
Just for your info: So far, I left the FD1 with preset factory settings. Hence, I did not activate SD card protection in the “Einstellungen->Entwickleroptionen” (Settings->Developer Options) menu. As you may have guessed, my language setting is “German”.

Your help is very much appreciated! Thanks in advance,

1 Like

It maybe the format of your ad card

Have a look at this article for more help reformatting the card

Hi Chris_R,
many thanks for your suggested fix. I tried formatting the card with FAT32 format, but according to the fromat.exe started from the command shell (cmd) that was not possible. The following error message was generated (translation): "The volume size is too large for FAT32"
Then I tried to format the card with the Windows Explorer. There the FAT32 option is not offered by the Windows 7 operating system. The only alternative available was NTFS. I tried a cluster size of 4096 bytes and 16 kB. However, both options also did not change the situation - the card was still not accepted by the FP1. It was also not possible to format the card with the FP1, because this option is not presented in the settings menu. Obvioulsy, the phone does not recognize the card sufficiently.
Many thanks for your help,

Do not use NTFS, use VFAT (that’s my guess on how it’s probably called, maybe the name is slightly different).

Dear haffenloher,
many thanks for the suggestion. However, VFAT does not seem to be the solution. VFAT is not a file system variant next to FAT12, FAT16 or FAT32, but it is an optional add-on, which was designed to use long file names (traditionally there had been the limitation of filenames with 8.3 digits - a heritage of the DOS age). I think, you can still see the effect if you use the DOS Command Shell (CMD) on FAT drives. Then the long filenames appear with full size in the Windows File Explorer, but the DOS prompt shows them abbreviated (e.g. filena~1.doc, or so). Anyways, I would strongly assume that WIN 7 is using the FAT32 with VFAT option by default, when you format a drive in FAT32 format. (VFAT is also not available as an extra option under Windows when trying to format a drive.)
Most importantly, however, VFAT has nothing to do with the limitation of the maximum storage capacity of a given drive (here miniSDcard), hence, this will not be the solution to the problem. This is, VFAT will not change the fact that FAT32 cannot handle a 64 GB drive.
Nevertheless, many thanks for spending the time and giving my issue a thought,

Dear all,
I very much appreaciate the suggestions so far, however, this seems to be a dead end. You could help me to investigate into the issue further, if a few (max 5-6) of you would share what microSD card you are using including details such as:

Manufacturer - Type of card - storage capacity - class - file system format/cluster size
in my case the options I tried are:
Intenso - microSDXC - 64 GB - class 10 - exFAT/128kB, NTFS/4096B/16kB

(Maybe even include a link to the web page where you bought it, if it was purchased online. If you do not know the cluster size, don’t worry. Knowing the file system should suffice.)
Please only post your card details, if they are really different from what has already been posted (or if you have a contradicting experience, like someone says this card works, but it did not work for you). So no need to post: “I use the same card”. If we know for sure that a certain card works, that’s sufficient. (Thanks!)

If I then, thanks to your replies, know that a certain set of cards should work, I can go back to the computer store, where I bought my card (or to a friend) and ask them if they have one of these cards for me to try out (hence, a set of different working options makes it easier for me to get hold of a working card). This way I can determine, whether this is an issue with my specific card (my FP1 works with a different card), or an issue with my FP1 (another card that should work, also does not work on my FP1 - could be the card reader or software related).

Many thanks again for your help,

@RobertGrosch, I tried several SD cards, and some of them did not work. Sadly, I did not keep track of it.

Upon a twitter recommendation from another FP user, I ended up with a 64 GB SanDisk SDXC Class 10 UHS-I. (Formatted in the phone, I did not check which file system is applied.) Works, flawlessly.

Windows has a lot of problems formatting big FAT32-partitions, p. e. for big USB-sticks or SD-cards.
There are different ways to solve this problem.

  1. Use a Linux system or a Linux Live-CD to format the SD-Card. No recommendet when you are not used to mount and format Linux partitions.
  2. Download and use the Freeware “HP USB Disk Storage Format Tool” V. 2.2.3. This tool does not be installed.
    3.Download and install the Freeware “MiniTool Partition Wizard Home Editionhttp://www.partitionwizard.com/free-partition-manager.html.
    This tool can also be used when you want to make a second partition on the SD-Card, P. e. for using an App like Link2SD http://www.link2sd.info/description.

I formatted my 64 GB MicroSD with the MiniTool Wizard and made two primary partitions: One 60 GB FAT32 partition for data and one 4 GB Ext4 partition that Link2SD can link big Apps to the external SD.

Hope that helps, best regards

1 Like

Dear Bobby,
you hit the nail on the head! Many thanks for your very detailed, considerate and understandable description of the fix! I followed your instructions:

  • I split the card drive into two partitions and formatted the larger one with FAT32 file system, using “MiniTool Partition Wizard Home edition” (quite a neat tool!). Afterwards, the FP1 recognized already the large partition.
  • Then, I chose the option “SD-Karte löschen” (erase SD-card) from the “Systemeinstellungen->Speicher” system settings->memory menu, so that it would be “formated” by the FP1 - just to be on the safe side.

Now it all seems to work just fine!

Just a hint for other people running into a similar issue: Initially my PCs card reader recognized the card, but after formatting it a few times, the card was not connected as a drive anymore, when I inserted the card into the slot. I wanted to return the card, but in the store the card worked fine on a new computer. So I got a new external card reader with USB connection. Using the new card reader my PC recognizes the card again reliably. It seems that even 3 year old card readers sometimes have issues with very new cards…

Thanks again to all contributors who had taken the time to answer my initial post! All contributions helped me in a way to pin point and understand the problem a little better. :slight_smile:
Best regards,

1 Like

Same card, no problem neither. Formatted in the phone.

This topic was automatically closed after 5 days. New replies are no longer allowed.