FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Just a user experience. I installed 1.9.9 pre2 on a fairphone that had kola nut and unified storage. I never flashed a rom on it, so it was an original config.

  • update of macadamia by using installer on fairphone pre2 download worked flawless.
  • then update of gapps using installer on gapps 1.9.9 download worked flawless
  • i was surprised that most of the apps installed in jelly bean just worked without reinstalling or reconfig,like the email app, banking apps, office mobile, SwiftKey, even the soft security token of my work worked without reconfig.
  • agenda sync with office365 had to be redone
  • some other apps did not work (crashed/stopped), but after uninstall and reinstall they worked,eg YouTube, dutch anwb apps, yellowbrick,
    -new dialler app: manual dial number keypad doesn’t appear during first usage. After some playing around it suddenly pops up and works after then.
  • some apps worked better than with jelly bean: google maps works without crashing, onenote works without crashing
  • gps seems to ‘hook on’ faster, at least with google maps
  • dutch ov9292 app does not find location, so doesn’t seem to connect with GPS
  • dual sim cards work, but had to make a small config change in service provider settings to get 3G working again.
  • proces pico-tts crashed (i don’t need it)
  • battery life is good and battery indication is working fine.

So in general an ok experience, but the average/non-technical user should be instructed how to deal with apps that crash/stop (reinstalling) and that some settings will be reset and should be entered again. (esp. to set the expectations correctly.)


Tiny update: I won’t release pre3 today because I forgot to include Superuser in the build (bummer).


###Today we release the third pre-release of Macadamia for Fairphone 1.

The update should be pushed to the Updater app if you are part of the alpha program already. Alternatively, you can download the image from the link below.

For this release we have applied significant changes to the build system. In order to ensure we have not introduced any regressions, please test rigorously including all components that have worked already (e.g. on Monday I had found out that Superuser did not work anymore, which could also happen to other components).

####Notable changes include:

  • Start migrating from Mediatek buildsystem closer to AOSP.
  • Shrink and strip kernel to make room for changes to recovery.
  • Correct power profile.
  • Add reboot button.
  • Deactivate automatic conversion from SMS to MMS.
  • Fix bug in conversion of boot logo (that caused the blue background).


The update should show up in the Updater app.

Please note that this image flashes the recovery partition. You might need to reflash your custom recovery.

####Reporting bugs

Before posting in this thread, please check whether there is already a thread on that bug tagged with #kitkat and add your observations to any existing thread. In any case, please tag new bugreports with #kitkat.


Been there, done it, 5-minute-test revealed no errors which is good.
Wifi works.
GSM works.
data survived.
xPosed had to be reinstalled as alway, works.
NetApp SD Fix reapplied, works.
Google services not visible, just how it is configured by me, good.
OSMAnd works, maps downloadable, good.
F-Droid can update apps, good.
Tests will continue - when no msg from my side, it looks good.

Thanks a lot for this work to keep FP1 living as long as the remaining devices are not broken.


Same here!
Works perfect.
No difference until now.
But the Fairphone Updater does still not work…
And it is still Android 4.4.2 !??

Thank you for your great work!


Is this the issue if you try to open an OTA package from the Downloads app? Yes, I have not fixed that, because the updates should show up in the Updater directly.

Yes, this is ongoing work.


I received a notification about a new update from the Updater. I’m however trying to install the zip using CWM recovery, in order to avoid the recovery flash.

The zip is placed in /storage/sdcard0 (linked to /sdcard), but when I try to install it from there, CWM outputs E: Can’t mount /sdcard. Mounting it manually in CWM also doesn’t work. I’m now going to move the zip to the external SDcard (sdcard1), but I wonder why CWM can’t mount the internal storage (sdcard0).

Edit: Couldn’t avoid the awful stock recovery being flashed… :angry:

No, if I try to open the Fairphone Updater it just crashes.
(I installed the Update manually from recovery…)
Maybe I should delete all data from my phone to resolve this problem, but I do not have time for this…
Am I the only one with this problem?

Won’t work. The recovery is flashed in the updater script. CWM cannot prevent that. Usually recovery is flashed at first reboot and CWM stops that from happening. However, in our case, we need the new recovery during flashing already. That’s why we first flash recovery, immediately reboot and then flash the system. This means recovery is overwritten in any case. Sorry about that.

That sounds bad.
Can you please get an adb bugreport when that happens and send it to beta@fairphone.com? Thanks


Ok, thank you for the explanation. Please make the users aware of this, when you publish the final release.

Edit: SMS to MMS conversion is disabled! :+1:


I am trying this, see: https://forum.fairphone.com/t/saving-logs-with-mtklogger-adb/19452/2?u=uudddu

I have installed the newest preview from today. Is version 36 the right version of the Fairphone Updater?

Thanks for this.

I installed it with no problems. When it restarted I was getting messages saying ‘Unfortunately Play Services has stopped’ and ‘Unfortunately Hangouts has stopped’

I re-installed Google apps (as prompted by the Updater app - I probably should have thought to do that earlier :slight_smile: ) . After a reboot, everything was working fine

I will have a play to see if the Bluetooth works any better with my Garmin vivoactive: I’ll report in the Bluetooth thread

Updated from pre1 to pre3. Had to reinstall Google Apps. Didn’t FP team say this should get fixed already after several patches?

What is strange that on my 2nd SIM there is a R (i guess for romaing) which wasn’t in pre1. I know that there was a romaing bug which was fixed in earlier patches.

Just a side question: Is it possible to pre-install Emoji One, instead of the awful Android emojis? I’m puzzled everytime as of their actual meaning…

Yes, version 36 is the latest one.

Indeed, Google Apps need to be reinstalled after every update.

No, Google Apps always have to be reinstalled. I am pretty sure we never said anything like that. This will never change for various reasons. Most importantly:

  • We do not have a license to ship Google Apps included in builds for FP1.
  • There are many users that would crucify us if we would include Google Apps by default because they prefer a Google-free phone.

For these reasons Google Apps cannot be part of the system partition by default. That necessarily means that they need to be reinstalled after every update. Sorry for that.

Good catch. I did not apply these patches when merging/splitting repositories.

I don’t know whether it is possible (probably it is), but I’d rather keep the stock Android emoji. I think it’s less confusing for people if they have the default and can change if they don’t like the default, instead of the other way round.

1 Like

Installation went fine through installer. Re-installed Gapps through installer also without any problems.

So far so good. Bluetooth connection to my fitbit still doesn’t work (I was really hoping that it would!).

I’ll keep using…

Seriously, who understand these confusing emoji??? :smiley:

Already in the first row there are two emoji that look exactly the same. Who can tell me the equivalent to real standard emoji? :stuck_out_tongue_winking_eye:

I’ll try to get rid of them myself… ^^

If you’re talking about the grinning one … one of them has tears :stuck_out_tongue_winking_eye:

But you’re right… I don’t like those ones… the ones of whatsapp are great though…

No, I’m talking about the first and the last but one.^^

The Whatsapp emojis are the iPhone-emojis, AFAIK. The great thing about Emoji One is that they are open source.

Easy: one is small and the other one is big!!! :grin::joy:

And the smile is kind of different… :stuck_out_tongue_winking_eye: OK you’re right… :wink: