English

FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Several people did that already - so yes.

2 Likes

Got the G letter on the status bar for my second SIM card although it’s mobile data is not activated on this card.

  • Both SIM slots (separately and dual-SIM)
    -> only tested slot 1
  • calls
    -> works for me
  • text messages
    -> works for me
  • MMS
    -> not tested
  • data
    -> only EDGE available here, works for me
    -> I can confirm that the “G” symbol remains left to the SIM slot 1 symbol if data is turned off
  • wifi
    -> works for me
  • Bluethooth
    -> not tested
  • GPS
    -> no errors, but could not get a satellite fix so far with “device only” mode (maybe due to heavy rain here?)
  • Apps that use the sensors
    -> works for me. At least the sensor values in Satstat seem to behave as before (accel, gravity, rotation, azimuth, pitch, roll, lux).
  • Updating with the stock recovery
    -> not tested
  • Encryption
    -> not tested (never worked on this device)
  • Sound, speakers, ear phone, microphone
    ->Not really tested, but it is ringing for incoming calls :slight_smile:
  • Headphones/Headsets (both cable and Bluetooth)
    -> not tested
  • FM radio
    -> not tested
  • SD card
    -> not sure. The SD card seems to work, but some apps got problems with missing permissions, even after erasing the SD card. Probably due to the Android 4.4 access management and not a fairphone issue?
  • Camera
    -> works for me
  • Notifications
    -> works for me (sound, vibration and LED)
  • Battery
    -> charging works both while running and powered off
  • Performance
    -> The FP1 feels much slower and less responsive with Android 4.4. Examples: If I receive a call while copying photos/videos around, it takes 2-3 seconds until the screen is updated just to accept the call. Scrolling through offline maps in Osmand sometimes takes so long that Android thinks the app has crashed.
  • Other observations:
    -> The “reboot” option is gone from the power button menu (not relevant for me, but certainly a change)
3 Likes

Re: SDCard: Yes, that’s a policy change in 4.4. further up in this thread, there is a link to the netApp utility that fixes the permission issue.

16 posts were split to a new topic: Bluetooth connections are unstable in FP1 alpha

I can not connect to the wifi network at work anymore, which uses a PEAP authentication method.

Thanks for reporting. It’s noted, we will investigate.

Is anyone able to confirm this already? Maybe anyone is using eduroam?

All works fine!
I will try Eduroam tomorrow!
Like in the build from chrmhoffmann it is not possible to enter the phone number in Settings->Sim management for Sim 1, only for Sim 2 it is possible. Well not important!
The new launcher is much better! But I use the nova launcher prime…

Why is this “only” 4.4.2?
And what is the difference to 4.4.4?

1 Like

eduroam is no problem here. (Other wpa2 enterprise secured networks work as well.)

Also my device is encrypted (only internal storage not SDcard) and just works. Battery usage was not different to the unofficial built thus far.

1 Like

Hi,

I’ve updated my FP1 to the Android 4.4.
But I’m not able to run Google apps anymore.
Playstore is stopped.
I tried differents tricks llisted here.
If someone has any idea ?

Regards
Pierre.

Try to install OpenGapps while waiting that the Gapps problem is solved…

You can find everything you need here OpenGapps project

eduroam works perfect for me

Sorry, after removing the old settings and reentering them it does seem to work. Seems the upgrade might have messed the settings up somehow.

2 Likes

Can anyone please give me detailed instructions, how to install opengapps?

One method:

  1. Download on your FP an open gapps package on http://opengapps.org/. Usually the nano package is a good option (ARM/Android 4.4/nano). This gives you a .zip file on your phone.
  2. Boot in recovery mode() and choose “Install from zip” to install the open gapps zip file from your phone
    (
    ) to get it you have to push simultaneously the buttons volume up AND power for about 10s. Be careful though if you never did this kind of operation…

Thanks four your reply

In recovery mode I have the options.

  • reboot system now
  • apply update from adb
  • apply update from sdcard
  • apply update from cache
  • wipe data/factory reset
  • wipe cache partition
  • backup user data
  • restore user data

I have already tried “apply update from sdcard” and choose the opengapps.zip, but it abadons after some seconds
I have also tried to wipe the cache partition before

Could it cause problems, that I have uninstalled the Google Play Services?

edit:
a.t.m. I try to get another recovery tool. I have downloaded the “recovery.img” (I think it is CWM Recovery) here: http://forum.xda-developers.com/fairphone/orig-development/rom-fairphone-fp1-kitkat-4-4-2-t3243623
but I dont know what to do whith it

“Apply from sdcard” is the right option. Are you sure you choose the right options for open gapps: Platform ARM, Android 4.4 and Variant nano?

From my experience, having uninstalled Google Play Services doesn’t matter as it comes again with the open gapps package. Also I don’t think the recovery image is a problem as soon as you have access to “apply update from sdcard”.

Did you read the HOW TO for the topic “[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U?” on this forum? There is a description of how to install a new recovery image, and another way to install opengapps with adb an the sideload command.

In my experience the original recovery refuses to work because the opengapps verification key is invalid. I had to use CWM which allows you to install even if verification key is invalid.

1 Like

That makes sense. Hence the need @Lukas to install a new recovery image as described in [UNOFFICIAL] ✏ HOWTO Testing the latest UNOFFICIAL 4.4.4 ROM and switching back to FP OS again [for Unix & FP1].

I did it, and installed opengapps too, and the play store seems to work :slight_smile: (thanks for your help)

But now the android-keyboard stopped working which is nearly as bad as before, because i cannot login to my account :cry: I only want to validate my poweramp which requires google play

so… are there any alternative keyboards I could use?

E: Okay i simply installed another keyboard :smiley: (adaptxt https://www.apk4fun.com/apk/6440/)

1 Like