FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

Yes, this is annoying.
However, I found a workaround:
You can turn off the screen while talking by pressing the power button.
The call will continue but your face can’t hang up the call anymore.

1 Like


[20 chars needed]

It works!
While this can’t be considered as a permanent solution, it’s a great workaround.

1 Like

Hello! I’ve finally installed pre3. So far so good, except the updater app still doesn’t work for me since pre2 for some reason… It crashes instantly when I try to launch it. I have already contacted @jftr by email to explain the problem, but we could not figure it out.

Any news regarding the next update?

The following things are nice to have and not bugs:

  • Increase the amount of zram. Currently, the device uses one zram with 512MB. On desktop Linux it’s quite common to create a zram per CPU (core). That would be 4 in our case. So perhaps 4x256MB? (This will need some fine tuning.)
  • Include a build of busybox. It is a bit tedious to reinstall Busybox after each firmware upgrade. And it would be better to use a recent build made by the people who build the ROM than an old build from F-Droid (or some unknown build from the Play Store).
  • Do something about the kernel ring buffer. It isn’t possible to get old messages with only three days uptime. My laptop has those logs even after more than a week.

@jftr Is pre4 (all repos updated to 4.4.4) in sight?


It’s hard to say. I have merged all changes in AOSP code and now have to go through incompatibilities in Mediatek code. Unfortunately I can only see what breaks one project at a time: I fix one project, the next project breaks, I fix that, and so on …

Edit: While I was typing this, I was building … the build succeeded without failure. Exciting. Fair warning though: If something compiles does not mean that it works …

Edit Edit: Bootloop :frowning:


I added another finding to the dialer lag investigation.


One thing I noticed yesterday is that the CA bundle is out of date.

I wanted to open this image - but the operating system didn’t trust the CA that signed that site’s certificate.

It would be great if you could include a current version of the CA bundle with new builds (perhaps get it directly from Mozilla?).

(And while you’re at it, the timezone database needs an update, too.)

Yes I had this problem too… very annoying. Vidéo works great on my phone but other person gets pixel like images. Sound’s ok though… What’s that about?

Very weirg stuff happened to my phone during ski vacation: suddenly battery lasted longer that usual… I was very surprised that after several hours I was still around 80%.

Then I got a notification that the SD card was damaged… I took it out (managed to save all data on computer because for the computer it was not damaged) and then, without SD card battery life started dropping… after few hours I was at around 30%.

I formated the SD card, put it back still got a message that it’s damaged. Took it out again…

Battery life still not good…

I really don’t get it…

1 Like

Oh no, these are new issues … sounds bad. I will have a look asap.

I turned the second post into a wiki. Guys, can you please add your issues there (with a link to the topic or post describing it). Thanks.


I had that issue when sending videos via Telegram.
And it occurred to me with Android 4.2, too, so at least it’s no regression. :slight_smile:

1 Like

I added two issues (those that bug me the most, tbh). :slight_smile:

The Peace of Mind App from the Google Play Store from mudar.ca works perfect for me on the pre3

But the battery life is really not good :frowning:

1 Like

I’ve compiled the issues I experienced in this post.
I didn’t add them to the second post because I don’t in which way these issues impact others.

Issues that are new to Macadamia (sorted from bad to annoying):

Things that would be great and issues that have always been there (sorted from annoying to would-be-nice):


I can’t confirm the updater crashes. My updater here doesn’t crash, so that seems some other problem and not a bug.


Thanks a lot. You can file them as unconfirmed and let other people confirm them. If it affects two users, it is issue enough to be considered.

That’s certainly interesting because I can reproduce this at will just by restarting my phone or just starting the updated.
And I get a stacktrace which looks like a bug in the app.
Perhaps a clear of the download manager’s storage will help?
Edit: No.

03-02 14:34:24.580 D/su      (27434): 10160 com.fairphone.updater executing 0 /system/bin/sh using binary /system/bin/sh : sh
03-02 14:34:26.023 E/AndroidRuntime(27393): Process: com.fairphone.updater, PID: 27393
03-02 14:34:26.023 E/AndroidRuntime(27393): java.lang.RuntimeException: Unable to start service com.fairphone.updater.UpdaterService@422cef58 with Intent { cmp=com.fairphone.updater/.UpdaterService (has extras) }: java.lang.SecurityException: Invalid value for visibility: 2
03-02 14:34:26.023 E/AndroidRuntime(27393): 	at com.fairphone.updater.UpdaterService.startDownloadLatest(UpdaterService.java:255)
03-02 14:34:26.023 E/AndroidRuntime(27393): 	at com.fairphone.updater.UpdaterService.downloadConfigFile(UpdaterService.java:170)
03-02 14:34:26.023 E/AndroidRuntime(27393): 	at com.fairphone.updater.UpdaterService.onStartCommand(UpdaterService.java:112)
03-02 14:34:26.308 I/DEBUG   (27488): [OnPurpose Redunant in preset_info] pid: 27393, tid: -1361051648, name: UNKNOWN  >>> com.fairphone.updater <<<
03-02 14:34:28.253 I/WindowState(1751): WIN DEATH: Window{42fa1d88 u0 com.fairphone.updater/com.fairphone.updater.FairphoneUpdater}

Edit 2: According to Stack Overflow, this issue occurs when the app trying to download something tries to hide the download from the user but doesn’t have android.permission.DOWNLOAD_WITHOUT_NOTIFICATION (which holds true for the updater). So I guess the solution would be either to download without hiding the notification (eg. removing this line:


) or giving the updater the required permission.

@jftr could you try this?


Thanks for the detailed investigation, @YtvwlD.

We have a fix lined up for that already. It is going to be in our upcoming releases. However, we did not consider it urgent, because afaik this should only ever happen if Updater is run as user app. This should not happen when Updater is installed as system app, which is the case for all our phones…

1 Like