FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

I have the exact same problem. My promity sensor only displays those two values and as a result my screen doesn’t go black when I hold my phone to my ear.
My proximity sensor may be a bit broken (because I had my broken USB port repaired), but it worked enough for the last ROM to detect whether my phone is near my ear or not.

The sensor has never put out any other values than 0 and 1. So SatStat is not displaying any distance, but rather covered and not covered


My OS still feels quite slow. Never had issues before the alpha. But now it might take like 3 secs to load the menu for calling. Since no one reported this yet as it seems, i think it is a individual problem here.

My situation is that I have to wait some seconds after pressing the call button until the call actually starts. It was solved when I switched to Kitkat, but it has returned at some later point…

Yeah this occurs here, too.

Another thing that really annoys me is that the notifications seem to be very broken. Some apps don’t seem to show any notification anymore (like twidere for twitter). Others like ebay kleinanzeigen or signal seem to update only when i turn internet off and on again or switch from wifi to mobile internet.
I don’t know if this might have something to do with but i am playing animation throwdown and whenever i switch from 3G to wifi or back it restarts the app and says that the time of the device changed so it has to restart. Could this be connected to my problem above?

It worked for me without having to re-enter the settings (WPA2-Personal and WPA2-Enterprise).

But there are a few problems:

  • Sometimes I loose connection. This is probably a combination of the building I’m in, using 2.4 GHz and the other people who use it, too. This happens with other devices, too.
  • After a few hours of having connection, loosing it, reconnecting and so on, my phone won’t reconnect. It simple stays on mobile (which mostly isn’t available in the building). The wifi settings say “Disconnected.”. I guess that it gives up after a few times loosing connection. I would count being connected for more than 5 minutes as successful.
  • Sometimes when using memory intensive apps (e.g. Firefox), I’m loosing wifi. The connection goes away and there are no available networks listed in settings, only the known ones. This goes away when I disable and re-enable wifi. I guess that wpa_supplicant is killed when the system runs out of memory.

@NeoXtrim are you using Google Services? If push notifications don’t work, it is probably because GCM’s configuration is defunct.

1 Like

Anybody here, who has the Bose Quietcomfort 35 headphones and can test the microphone quality during calls? We are trying to figure out what’s the problem here.

How can I install that? Since upgrade /manual install of 4.4.4 i get the "android"
bootloader. Not a problem, but I like yours a lot.

Sadly I don’t know why it doesn’t work.

It works for me in an Android emulator (at boot and when run with bootanimation).
On my FP1 it only works when I execute bootanimation after bootup. It won’t show during boot. :frowning:

I deleted your post in the #kitkat -FAQ. Please ask development questions here (like you have done).

THX. I really have problems following the right threads here. I don’t really have an overview where I am, most of the time.

Were is this “android” bootanimation.zip stores at?
And how can I get the Fairphone updater for #kitkat without gapps?
The rest works fine, I’m about to use my FP1 as my main phone again.

Hi everybody, haven’t read you for sometime and if my comment is redundant I’m sorry.

I get very weird behavior from my phone:

Notifications are completely non reliable… sometimes they appear normally sometimes I only get messages when I unlock my phone.

Phone is in silent mode but a video clip sent to me via whatsapp can be heard (and pretty loud).

Applications like “BBC News” crash without reason after 1 sec or after several minutes… or not!

I have the same problem other reported about delay when phone rings and being able to answer it. Same delay when I’m the one calling.

The Mediatek chipset is simply weird. Read this recent story:

1 Like

9 posts were split to a new topic: Migrate user profile from Firefox to IceCatMobile

One weird thing that I’ve noticed:

The factory mode is entirely in Chinese after the update. Before, all labels were in English and Chinese.

OK, something weird just happened regarding the call lag:

I searched around because it bugged me (pun not intended!) and found this Stackexchange post. One suggestion was to install an alternative dialer app. I went to F-Droid and installed Dialer2 from 2012. When I then placed a call through my launcher KISS it was as fast as it gets! The effect stayed after I had uninstalled Dialer2.

My hypothesis: Dialer2 managed to load the required information (caller list? Contacts?) into the RAM and the call manager could make use of it, bypassing the stock dialer. The first time you try to call someone it takes some time until the telephony app is loaded into RAM and the following times it’s there already and calling is faster.

@NeoXtrim Do you use Xposed? I do.

PS: I’d like to split this topic, but I’m undecided whether it is #kitkat specific or happens on Kola Nut too…

Edit: An hour later, I press on that contact in KISS launcher again and the call starts as slow as always (~5 seconds). The second try is “rocket”-fast again though (in comparison).

I deleted my call history now (and uninstalled Dialer2 again, but I no longer think it’s relevant) and will report back in an hour or so.

Edit2: It’s not the call history. An hour later, the first (and this time the second a very short time after the first) placed call takes about 5 seconds until the call window appears.

Some people suggest problems with hardware acceleration and “keep in memory”-settings or Whatsapp.

Edit3: Ok, the call goes through and it can be embarrassing, if you are testing this and can’t hang up because the call screen doesn’t come up. Luckily I was testing this by calling my mother, so no harm done! :grin:

Edit4: Nope, Deleting data of “telephone /sms storage” with Titanium Backup doesn’t solve the issue.

1 Like

If you’re using XPosed you could try this.

But I don’t think you can ever solve this problem.
The dialer app has been opening slow on all Android devices I’ve ever owned (on one device it was even so bad that I couldn’t accept any calls).
Android is not that optimized as the firmware on dumb phones. It will never be that responsive.

You can try to solve this issue by throwing RAM and / or processing power against the problem but as the FP1 is not easily upgradable, that won’t be possible. (And this won’t happen, either, I guess.)

You could try to remove all apps and data from your phone. But what’s the point in having a smartphone then?

(It may be a good idea to prioritize some apps regarding RAM, but I don’t think that it possible on Android. It may be possible for the dialer app to display a steady notification.)

1 Like

Yes, this is annoying.
However, I found a workaround:
You can turn off the screen while talking by pressing the power button.
The call will continue but your face can’t hang up the call anymore.

1 Like