FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

What does that mean? What is the “SMS Service Center on [your] sim-card”? Are you speaking of the Short Message service center (SMSC)?

How could it be removed and how can you tell? What are consequences of this?

We definitely will do this. However, it is a little bit tricky to extract everything from the build system necessary to create a working build while at the same time ensuring not to leak source copyrighted by Mediatek. We have released kernel source for previous releases and for our other phone already and will continue doing so.

2 Likes

Yes I am talking about he Short Message service center (SMSC). I think normally Android gets this number straight from the sim-card but in my case the number on the sim-card couldn’t be read or was deleted in the update process. Going back to Koala Nut didn’t change anything.

When the SMSC isn’t set, the phone can’t send a sms and it always tells “failure the message couldn’t be sent” and nothing more.
The same with non standard apps like Signal Messenger with sms functionality.

I found this number on the website of my carrier and set in the options of the standard sms app.

I can imagine 2 reasons for that:

  • my sim-card has kind of hardware defect
  • Signal was the standard messenger app in the update process, but the smsc is set in the standard app so it wasn’t retrieved on update, but this does not explain why going back to 1.8.7 and a wipe wasn’t working.

I hope this helps, maybe for a FAQ.

1 Like

I cannot find a pattern. Rebooting solves the problem for some days

… And besides the stability issue of BT LE When I try to turn BT off an on again the set button doesn’t react. I have to reboot the phone before being able to change Bluetooth settings again.

Can you please create an adb bugreport and send it to beta@fairphone.com when this happens again? Thanks

Hej, I have been using 1.9.9 for some time now, so I wanted to share what I have noticed.
I haven’t read all the previous comments though, so I might be repeating known issues, I apologize for that.

So this are the problems I’ve encountered

  • repeting popup of with the message that Google Play-Services were stopped
  • the GPS is working working good with some apps, but acts really poor with others
  • I have to charge more often than with the previous version
  • one time I had an abrupt drop in charge (see )
  • the display doesn’t go in standby when I’m talking on the phone, which caused some interrupted phone calls, because I hung up with my ear
  • I’m not sure it is about the os, but the app c:geo does not work and firefox crashes quite often

not really bugs, but things that bother me:

  • no restart option, when long-pressing the top button
  • the reminder that my second sim-slot is empty after every start

to summarize: I haven’t encountered any severe bugs, overall it works great. But I think I will switch back to the Kola Nut until a stable version is out.

Thank you to the Fairphone-Team for your great work! I really appreciate this open way of software developement :slight_smile:

3 Likes

Hey, some comments on my behalf:

This has been reported by some other people too. Maybe we should move the posts reporting this into a new post/bug report.

https://forum.fairphone.com/t/battery-level-drops-in-fp1-u-alpha/21692?source_topic_id=19450

The automatic turn off of the display is triggered by the proximity sensor. Use an app that can display the output of that sensor (like SatStat), to see if it is working properly (in my case the sensor output is “-” because my proximity sensor is broken).

I’m most interested in this issue. I experience it myself and other people too:

Did you at one point use Pokemon Go?

1 Like

Thank you for your quick answer.

I checked with SatStat and the proximity changes between 0 and 1cm when I hold my hand before the sensor, no other values.

I had indeed pokemon go installed for like a week. I didn’t came in thought that there might be a connection, but when I remember correctly the crashes started around that time. They happen mostly on websites with many interactive elements or high data usage, f.e. YouTube…

2 Likes

Is there any news? :slight_smile:

1 Like

Oops, sorry for not posting the link here. We have updated the FAQ on this topic and this is where we will continue doing so:

Some more in depth update for you guys here:

  • We are slowly migrating away from the Mediatek build system. Our first step was to split the one giant git repository into several repositories and using repo for managing them.
  • That also means that we have moved all code into repositories based on AOSP which will make it easier to merge the upstream patches for 4.4.4
  • There is some progress on the erratic battery consumption (also thanks to @sampumon)
  • While moving repositories and splitting commits, I have also implemented the requested reboot option in the power menu and have deactivated the automatic conversion from SMS to MMS after three concatenated messages.
  • Currently we are testing a new alpha build and might release it this or next week if no major blocker shows up.
  • Lot’s of tiny other stuff.
7 Likes

Oh, and I forgot to mention: We are excited about @danxuliu having gotton TWRP to run on FP1:

2 Likes

Just a user experience. I installed 1.9.9 pre2 on a fairphone that had kola nut and unified storage. I never flashed a rom on it, so it was an original config.

  • update of macadamia by using installer on fairphone pre2 download worked flawless.
  • then update of gapps using installer on gapps 1.9.9 download worked flawless
  • i was surprised that most of the apps installed in jelly bean just worked without reinstalling or reconfig,like the email app, banking apps, office mobile, SwiftKey, even the soft security token of my work worked without reconfig.
  • agenda sync with office365 had to be redone
  • some other apps did not work (crashed/stopped), but after uninstall and reinstall they worked,eg YouTube, dutch anwb apps, yellowbrick,
    -new dialler app: manual dial number keypad doesn’t appear during first usage. After some playing around it suddenly pops up and works after then.
  • some apps worked better than with jelly bean: google maps works without crashing, onenote works without crashing
  • gps seems to ‘hook on’ faster, at least with google maps
  • dutch ov9292 app does not find location, so doesn’t seem to connect with GPS
  • dual sim cards work, but had to make a small config change in service provider settings to get 3G working again.
  • proces pico-tts crashed (i don’t need it)
  • battery life is good and battery indication is working fine.

So in general an ok experience, but the average/non-technical user should be instructed how to deal with apps that crash/stop (reinstalling) and that some settings will be reset and should be entered again. (esp. to set the expectations correctly.)

6 Likes

Tiny update: I won’t release pre3 today because I forgot to include Superuser in the build (bummer).

6 Likes

###Today we release the third pre-release of Macadamia for Fairphone 1.

The update should be pushed to the Updater app if you are part of the alpha program already. Alternatively, you can download the image from the link below.

For this release we have applied significant changes to the build system. In order to ensure we have not introduced any regressions, please test rigorously including all components that have worked already (e.g. on Monday I had found out that Superuser did not work anymore, which could also happen to other components).

####Notable changes include:

  • Start migrating from Mediatek buildsystem closer to AOSP.
  • Shrink and strip kernel to make room for changes to recovery.
  • Correct power profile.
  • Add reboot button.
  • Deactivate automatic conversion from SMS to MMS.
  • Fix bug in conversion of boot logo (that caused the blue background).

####Updating

The update should show up in the Updater app.

Please note that this image flashes the recovery partition. You might need to reflash your custom recovery.

####Reporting bugs

Before posting in this thread, please check whether there is already a thread on that bug tagged with #kitkat and add your observations to any existing thread. In any case, please tag new bugreports with #kitkat.

8 Likes

Been there, done it, 5-minute-test revealed no errors which is good.
Wifi works.
GSM works.
data survived.
xPosed had to be reinstalled as alway, works.
NetApp SD Fix reapplied, works.
Google services not visible, just how it is configured by me, good.
OSMAnd works, maps downloadable, good.
F-Droid can update apps, good.
Tests will continue - when no msg from my side, it looks good.

Thanks a lot for this work to keep FP1 living as long as the remaining devices are not broken.

5 Likes

Same here!
Works perfect.
No difference until now.
But the Fairphone Updater does still not work…
And it is still Android 4.4.2 !??

Thank you for your great work!

3 Likes

Is this the issue if you try to open an OTA package from the Downloads app? Yes, I have not fixed that, because the updates should show up in the Updater directly.

Yes, this is ongoing work.

3 Likes

I received a notification about a new update from the Updater. I’m however trying to install the zip using CWM recovery, in order to avoid the recovery flash.

The zip is placed in /storage/sdcard0 (linked to /sdcard), but when I try to install it from there, CWM outputs E: Can’t mount /sdcard. Mounting it manually in CWM also doesn’t work. I’m now going to move the zip to the external SDcard (sdcard1), but I wonder why CWM can’t mount the internal storage (sdcard0).

Edit: Couldn’t avoid the awful stock recovery being flashed… :angry:

No, if I try to open the Fairphone Updater it just crashes.
(I installed the Update manually from recovery…)
Maybe I should delete all data from my phone to resolve this problem, but I do not have time for this…
Am I the only one with this problem?

Won’t work. The recovery is flashed in the updater script. CWM cannot prevent that. Usually recovery is flashed at first reboot and CWM stops that from happening. However, in our case, we need the new recovery during flashing already. That’s why we first flash recovery, immediately reboot and then flash the system. This means recovery is overwritten in any case. Sorry about that.

That sounds bad.
Can you please get an adb bugreport when that happens and send it to beta@fairphone.com? Thanks

2 Likes