FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

I wish I had a option for white or black background colour for the menu…

[quote=“jftr, post:20, topic:19450”]
Ohoh, that needs to be fixed. Probably it’s too much work and doesn’t make sense to list each and every non-translated string. But, is there a pattern to it? What parts are in English and what parts are in French?[/quote]

Everything in “settings” is in english and everything in screen and apks menu is in french.

By the way I must say: Thank you so much for this update!!! this is incredible, I love my FP1 but it wasn’t easy to use lately with some apks not compatible. The unofficial kitkat was great too and I’m really glad this phone is supported like this (officialy and inofficialy) :+1:

1 Like

I came from Kola Nut, without using the factory reset. Everything seemed fine till I tried to update google apps and I got stuck on the Setup Wizard error. After that I installed CWM and installed opengapps. I have not lost any data during all this.


May I ask which package of opengapps you installed? did you have any problems with the keyboard?

I used the aroma one. I did not install the google keyboard during aroma selection process. I did try installing it from google play afterwards, but am getting an error. Was considering rerunning the aroma installer to try and install it from there (I miss the key swiping).

The error I get is:

Package file was not signed correctly. Uninstall the previous copy of the app and try again. 

I guess the previous version might be left overs from the Kola Nut version, but I don’t see any method to remove the leftovers.

But can you use the keybord? or you get an error message?

You could try Swiftkey keyboard… it’s great! :wink:

I have no issues using any of my keyboards (Android AOSP keyboard or hacker’s keyboard)

Just installed over the port of CRMHoffmann.
Easy doing:
adb reboot recovery
clear cache, clear dalvik.
adb sideload (downloaded rom)
adb sideload (opengapps nano)
adb reboot

Happily seeing the new rom.
Even XPosed is installable again.
Desktop image stayed, launcher configuration naturally not.

NetApp SDFix still necessary in order to make osmand work.

I’ll be sharing issues WHEN they arise.
Up to now, it looks quite good.


YES!!! This is so great! it was so easy to install I couldn’t believe it!!!

I’m using XPosed also and now the NextApp SDfix (for those searching it as it’s not on F-Droid).

On 4.2.2 it is not necessary to use it as it was a decision made for kitkat. But would it be possible for you guys to integrate it or better, add a setting / installer like thingy - as it was reasoned to be a security feature - to enable it without external apps? I’m using it for osmand and syncthing (Music library as it’s to big for the internal space and i want it in sync on my devices against hardwarecrashes).

Does someone know how newer Androidversions like 5.x oder 6.x (soon 7.x) handle it?

I came von Kola Nut 1.8.7

Hi everyone!

I installed the update this morning. These are my experiences so far:

  • update process from Kola Nut worked like a charm. I didnt wipe any caches or did a factory reset.
  • I can confirm the 1-pixel line on the bootscreen. In my case there was a line on the left and also one on the top.
  • There are random google play service errors. So far they seem not to interfere with any function or app.
  • Play store doesn’t work

I also updated from the unofficial rom without any issues beside of the translation things. (Installed it via sideloading with CWM. Also used the nano package of gapps.)

Just to be curious, beside of the fact that it is Android version 4.4.2, which security patch level is applied? Is this rom at the head of the current security updates provided from google?

I don’t know which security updates are included (I don’t find the information in the settings where the were in the unofficial port), but i just saw that the fairphone build is using Android 4.4.2 (Settings->About phone) but the unofficial used 4.4.4 (with modifications).
Will this be bumped too?

None yet.

Yes, that’s the plan: Update to 4.4.4 and include all security updates.


We’re currently not taking any feature requests because our focus is on stabilizing the build and include security fixes. Sorry for now.


Installed over 4.4.4 port by @chrmhoffmann (so it’s a… downgrade ;)) + last open gapps mini package. I just wiped cache and dalvik cache. Also installed NextApp SDfix.
Everything OK till now including:

  • Gmail working with many accounts including a Microsoft Exchange one
  • PlayStore working
  • Minuum keyboard working
  • Dual SIM working

Minor points:

  • Blank one pixel vertical line on left side of the first splash screen
  • Light background on first init screens: text not much visible + battery consumption

I use English as system language: no problem on this side.

Can you please elaborate on these issues? What init screens do you mean? The ones from the GApps package? The bootanimation?

And what can you say about battery consumption?

Edit: And of course also thanks for testing the other stuff and confirming that it works :smiley:

24 posts were split to a new topic: Battery level drops in FP1(U) alpha

There is a first splash screen with “FAIRPHONE powered by android”. Then a boot animation which starts with two quick screens ~“Start a movement”, then a screen with “LOADING” blinking. This last one has a light grey then grey background which lasts more than 10 seconds: very flashy under nightly conditions and this display burns battery uselessly, and the text “LOADING” is white: not so much readable on grey background.

Battery: at this time Android System got the first place with 25% since yesterday evening. I will check again by the end of the day.

1 Like

I have an issue with the google app - it crashes shortly after open it. Here’s the relevant logcat:

I/dalvikvm(19370): Could not find method android.os.UserManager.getUserProfiles, referenced from method com.google.android.apps.gsa.shared.util.cc.bh
W/dalvikvm(19370): VFY: unable to resolve virtual method 2492: Landroid/os/UserManager;.getUserProfiles ()Ljava/util/List;
D/dalvikvm(19370): VFY: replacing opcode 0x6e at 0x001c
D/dalvikvm(19389): threadid=10: interp stack at 0x5fe3e000
D/dalvikvm(19389): init ref table
D/dalvikvm(19389): init mutex
D/ActivityManager(  692): getContentProviderImpl: from callerandroid.app.ApplicationThreadProxy@42ff5f30 (pid=19370) to get content provider com.google.android.voicesearch
V/ActivityManager(  692): getContentProviderImpl: can't get cpi from packagemanager
E/ActivityThread(19370): Failed to find provider info for com.google.android.voicesearch
D/ActivityManager(  692): getContentProviderImpl: from callerandroid.app.ApplicationThreadProxy@42ff69b0 (pid=19370) to get content provider com.google.android.gsf.gservices
W/ActivityManager(  692): Permission Denial: opening provider com.google.android.gsf.gservices.GservicesProvider from ProcessRecord{42a78408 19370:com.google.android.googlequicksearchbox:search/u0a17} (pid=19370, uid=10017) requires com.google.android.providers.gsf.permission.READ_GSERVICES or com.google.android.providers.gsf.permission.WRITE_GSERVICES
W/System.err(  692): java.lang.SecurityException: Permission Denial: opening provider com.google.android.gsf.gservices.GservicesProvider from ProcessRecord{42a78408 19370:com.google.android.googlequicksearchbox:search/u0a17} (pid=19370, uid=10017) requires com.google.android.providers.gsf.permission.READ_GSERVICES or com.google.android.providers.gsf.permission.WRITE_GSERVICES
W/System.err(  692):     at com.android.server.am.ActivityManagerService.getContentProviderImpl(ActivityManagerService.java:8317)
W/System.err(  692):     at com.android.server.am.ActivityManagerService.getContentProvider(ActivityManagerService.java:8590)
W/System.err(  692):     at android.app.ActivityManagerNative.onTransact(ActivityManagerNative.java:705)
W/System.err(  692):     at com.android.server.am.ActivityManagerService.onTransact(ActivityManagerService.java:2265)
W/System.err(  692):     at android.os.Binder.execTransact(Binder.java:404)
W/System.err(  692):     at de.robv.android.xposed.XposedBridge.invokeOriginalMethodNative(Native Method)
W/System.err(  692):     at de.robv.android.xposed.XposedBridge.handleHookedMethod(XposedBridge.java:631)
W/System.err(  692):     at android.os.Binder.execTransact(Native Method)
W/System.err(  692):     at dalvik.system.NativeStart.run(Native Method)
E/AndroidRuntime(19370): FATAL EXCEPTION: main