English

FP1: Macadamia 1.9.9-pre3 Alpha (Android Kitkat)

What Google installer did you use?

I went to the Updater and clicked on install Google Services. I did a couple of nice screenshots but I can;'t extract them. Now the phone is stuck on “Unfortunately, Setup wizard stopped.”

1 Like

Just realised that I wrongly said serviceupdate in my previous I meant SetupWizard. So see above for how I worked around the phone being stuck on that error.

@BlackEdder, does that mean you got Google Apps working with the old installer?

No, google apps is not working. I just found a workaround for being stuck with the setup wizard error message (which keeps infinitely popping up)

Edit: Did get Google apps working using opengapps and CRW

8 posts were split to a new topic: Possible to install TWRP/CWM on FP1?

I had the unofficial version running on my FP1 so I updated via ROM manager cyanogen to install. Worked fine.

But then it got stuck with a message

I had to go to Apps Fairphone OS and launch for it to work but everytime I presse the homescreen button the same happens and I have to do the same all over again. Phone says it’s not rooted anymore…

So now I’m going to go back to kola nut and try everything once again see if it changes something…

It’s adviced to wipe data, cache and dalvik cache before installing a new ROM. Had you done that before installing Macadamia?

1 Like

I restaured factory settings (don’t mind don’t use the phone right now) and now it works…

Also tried to install opengapps pico which worked with CWM recovery but then the keyboard didn’t work anymore and I was blocked so I had to go back and start again… how can I correct this keybord problem?

1 Like

Go to CWM recovery and wipe data and cache. Additionally wipe Dalvik Cache in Advanced. You should start with a completely blank phone!

I installed google keyboard and then chose it and then swipe keyboard normally from googleplay which works by the way with pico installation from OpenGapps. I still got the popup message that keybord stopped working but it matters little as I now have a keyboard to work with…

So far so good… some small problems so far:

  1. When the OS is loading a white line appears on the left and up screen edge of the phone.

  2. Also there are some language problems: language is set to French but 70% of menu is in English.

Forgot to say: I have an FP1 first edition :wink:

Is that new launcher “Fairphone Launcher 3”, the Launcher from FP1X/FP2? Because I updated from FP1X and didn’t lose any widgets or launcher settings. :thumbsup:

All in all the update went smoothly, no data loss, no issues found so far. :slight_smile:

1 Like

Good to see that you could solve it. Chris’ and our build could potentially be close enough to not have to factory reset. However, wiping Dalvik cache is probably always necessary.

Did everyone here come from Chris’ build? Or are there also some people that updated from Kola Nut 1.8.7? In general this is the more important case to test, because most of our users will take that path.

Yes, this solves many problems (although Dalvik Cache is on the data partition which means that you don’t need to wipe Dalvik Cache if you factory reset).

But please don’t all factory reset before flashing: Most people will want to update from Kola Nut without loosing any data. Therefore it would be great if these scenarios are also covered by our tests.

Yes, I can verify that. I will look into it.

Ohoh, that needs to be fixed. Probably it’s too much work and doesn’t make sense to list each and every non-translated string. But, is there a pattern to it? What parts are in English and what parts are in French?

Yes, it is the very same launcher.

Great to hear.

Thanks a lot everyone. Keep up the good work! :thumbsup:

3 Likes

I just switched from the unofficial port to this on an encrypted FP1. It seams to work and i can confirm for german that:

  • the quick-settings and other direct accessible parts are correctly localized to german (including the launcher and updater). Default widgets like music are localized.
  • the settings menu and all settings accessed through the quick-settings are in English, Adding a widged I’m also promoted in English to confirm that i’ll allow the launcher to add it.

Besides that I really like it and will start to take a closer look and use it.

Forgot to mention, that I did not a complete factory reset, just wiped the caches and used the recovery to install this update as a new one. So my settings and apps remained as did the encryption.

3 Likes

I wish I had a option for white or black background colour for the menu…

[quote=“jftr, post:20, topic:19450”]
Ohoh, that needs to be fixed. Probably it’s too much work and doesn’t make sense to list each and every non-translated string. But, is there a pattern to it? What parts are in English and what parts are in French?[/quote]

Everything in “settings” is in english and everything in screen and apks menu is in french.

By the way I must say: Thank you so much for this update!!! this is incredible, I love my FP1 but it wasn’t easy to use lately with some apks not compatible. The unofficial kitkat was great too and I’m really glad this phone is supported like this (officialy and inofficialy) :+1:

1 Like

I came from Kola Nut, without using the factory reset. Everything seemed fine till I tried to update google apps and I got stuck on the Setup Wizard error. After that I installed CWM and installed opengapps. I have not lost any data during all this.

2 Likes

May I ask which package of opengapps you installed? did you have any problems with the keyboard?

I used the aroma one. I did not install the google keyboard during aroma selection process. I did try installing it from google play afterwards, but am getting an error. Was considering rerunning the aroma installer to try and install it from there (I miss the key swiping).

The error I get is:

Package file was not signed correctly. Uninstall the previous copy of the app and try again. 

I guess the previous version might be left overs from the Kola Nut version, but I don’t see any method to remove the leftovers.

But can you use the keybord? or you get an error message?

You could try Swiftkey keyboard… it’s great! :wink:

I have no issues using any of my keyboards (Android AOSP keyboard or hacker’s keyboard)