FP Open OS 16.07 is now available

Update worked fine for me, but can someone explain the difference between the update you see when just starting the updater and what shows up when you choose “Advanced Mode” / “Android for Fairphone”. Both showed 16.07 and I tried both and both worked, but I probably just applied the same update twice :wink:

I think I’ll wait with the update. 50:50 bootloop and OK are not my odds.


Why should there be a difference?

As usual: People with problems are more likely to post - but suit yourself.

Why should there be two modes in the Updater, if they offer the same ?

The start screen offers an update if available, the advanced mode offers the latest update to reinstall and an option to switch to and from FP (Open) OS.

1 Like

Alright, seems to run again.
I had openGapps pico installed, that seems to have caused the problem.
I downloaded the latest version and (re-)installed it via TWRP, and after the next app optimiztion the phone started again. Only the home screen, i.e. the Fairphone launcher, seems to be broken, so I need to configure it again.
Edit: Launcher problem solved thanks to Titanium Backup :-))

Interesting side note: I also tried to wipe Dalvik & cache in TWRP, which failed. I assume it is because I have the /data partition encrypted. Can someone confirm that the cache is on the /data partition?

I really really hope Fairphone will soon port TWRP 3+, it is really annoying that the current TWRP version cannot handle encrypted /data!! This steals a custom recovery most of its advantages!


Seamless update from 16.06 to 16.07.

/cache lives in it’s own partition.

TWRP 2 already handles encrypted data (I used it in my former Nexus 4), so it should be a misconfiguration. I cannot clear your doubt, though, because I won’t encrypt my FP2 until I consider the software stable enough.

About the Updater improvements, anyone can check if the storage folder is not being created now on the user data? (it shouldn’t be created, /storage already exists, and I had troubles in the past with some storage subfolder and MTP…)

1 Like

I see, i thought that it was a version issue with TWRP that couldn’t handle encrypted /data.
In any case, I hope this will be fixed rather sooner than later.

Interesting finding:
FPOOS 16.07.01 still runs on the old baseband firmware, so the version from FPOS 1.4.2+ hasn’t been implemented in the FPOOS yet.


I solved it by wiping the dalvik cache. And then re-installing Gapps Pico. But then one must reinstall everything, including the homescreens.

Update went fine for me.

Well, there has been a change in encryption with lollipop at least on some devices (Qualcomm?). If one checks XDA or twrp forums, you can see this problem. I successfully updated after quite some hassle, also probably because of too old opengapps. My devices is encrypted also, btw
I also got the error wiping cache, but at least on Android cache indeed seems to be on its own partition. Maybe some more investigation is necessary, but not this evening :slight_smile:

And, after everything was OK again, I also flashed Xposed. Successfully

Yes, re- installing open Gapps did the trick also for me. I finally should write down my update routine, as I think it’s anyways always the same issues where one can stumble over. :wink:

Though, I did not have to reinstall anything else, apart from xposed and fdroid into /system/priv-app.

Wiping Dalvik failed for me.

Btw: I also realised that titanium backup also backs up the launcher, so I simply pulled the backup for the launcher only, and everything was as before.

I love this app, very well spent 5 euros. :slight_smile:

You could also add your findings to the update guide.

Update went fine (as always).


They did it again!

And again our two FP2 where updated perfectly.
Both are unencrypted and without Xposed or Gapps of any kind.

Good work! Thank you Fairphone!


Same problem as freibadschwimmer on my side… Since I did this update, my phone is continously optimizing the apps and reboot. Impossible to start my FP2 anymore…

I confirm that. Last three updates I had to re-install Gapps via sideload. Note to myself: Hold a copy of Gapps on the sd-card.

Actually I had that, Just didn’t install it right away. :blush:

Though I am also not sure if this would work (I should test it some day), since for example GMS got an update since the last FPOOS update, so I’m not sure if installing the old openGAPPS package would be a good idea.

Update went withoutany problem.
Fairphone is not rooted, without any kind of GAPPS, not yet encrypted