FP Open: No local Calendar and Calendar only syncs with Google

To things to add to this thread:

  • A Feature Request: I have installed “Offline Calendar” from F-Droid that is an easy way to have a local calendar. As it makes little sense to provide a calendar app that only works with cloud services on an operating system that is dedicated to avoid exactly these I would request the “Offline Calendar” being part of the standard FP OpenOS build - maybe even on the standard FP OS if it’s not forbidden by big G’s gagging rules. For the ease of use a preconfigured local calendar should be already on the system.

  • The strange behaviour that my calendar complained “you have to create at least one calendar account…” although there where DavDroid calendars on the system was a DavDroid problem: The calendars that did not sync where marked with a grey symbol that looks like the “Entrance Forbidden” traffic sign or the London Tube logo. After tapping on the menu icon in the “CalDAV” section and choosing “refresh calendar list” the symbols disappeared and my ownCloud calendars became usable again.


My thread was closed and I am supposed to continue here, my prblem were error messages but:
It seems with re-installing the FP Open OS the the Offline Calendar + Etar (+ sync) is working again (an update maybe?) no more messages about not having granted permissions etc. pp.
In case anyone wanted to give it a try again …

1 Like

I managed finally to get a calendar on my FF OS. Using aCalendar, davdroid and Framagenda. Works fine.
Unfortunately I don’t manage do synchronise with my Thunderbird + Lightning. In Thunderbird/Lightning I can create a calendar and make the connection to Framagenda using calDAV, but the calendar does not synchronise, displaying à small sign saying “The calendar XXX is momentarily not available.” :frowning: Anyone found à solution to this ? Using Thunderbird 45.5.1 and I tried several Lightning versions.
Sorry, it’s not really an FF problem anymore, but it started with one :slight_smile:

Try to install the SoGo connector extension on Thunderbird https://sogo.nu/download.html#/frontends
and see if that helps. I am using it with great success to sync. contacts, calendar and tasks with my own owncloud server - and from there to my FP2 via DavDroid.

Hi, thanks for the hint. I already tried the connector, but then a message pops up "A username and password are being requested by http://sogo-demo.inverse.ca. The site says: “SOGo”. You know what that means ? I tried the password and login of framagenda, but that doesn’t work. Do I have to create a SOGO account somewhere ?

No you do not need a Sogo account. You have to replace the sogo server URL with that of your own sync server (framagenda, ownCloud etc.) and then you can use your own password.

It works, great :slight_smile: FF OS aCalendar <–> Framagenda <–> Thunderbird. The SogoConnector is still demanding a sogo password and login when launching TB, but I can click it away and it still works. What I changed : When creating the calendar in the Lightning module, I didn’t take the Primary CalDav address but the address of the calendar :

In Framagenda : MYCalendar --> More --> Link

Something like https://framagenda.org/remote.php/dav/calendars/XXX/XXX/

By the way, where can I change the SOGO Server URL ?
I won’t ask further questions on non-FF issues, promised :sunglasses:

I did not have that problem with the Sogo server when I installed the addon. I simply used my owncloud sever caldav / carddav URLs in lightning and the address book. Usually your TB address book has only two address books: “Personal Address Book” and “Collected Addresses”. If there is any other “sogo”-related addressbook then I would delete that one. Or you set up a remote address book to sync / backup your contacts on your server. The same applies to Lightning: Check if there is any remote calendar that you have not created and delete it if in doubt.