FP Open (Android 5.1) > FP Open (Android 6) > FP OS (Android 5). What the hell went wrong?

Hi all.

I was really scared of the update from FP Open with Android 5.1 to FP Open with Android 6.0.
So I decided to switch back to FP OS (with google services and so on), expecting to have a Fairphone that works fine without the need of spending hours in forums, support pages, etc.

After backing up everything, I did the following:

  1. In FP Open 17.04 (Android 5.1) I did a factory reset
  2. Update to FP Open 17.06 (Android 6)
  3. Manually install FP OS dowloading the switcher from here

Then I tried to upgrade to Andoid 6 manually (following Procedure number 1 from this guide) and through the Updater app, and I always get stuck in the following error:

Finding update package…
Opening update package…
Verifying update package…
Installing update…
Verifying current system…
Verifying radio-update…
System partition has unexpected contents
E:Error in /cache/fp_update_.zip
(Status 7)
Installation aborted

I wiped the cache partition, and tried twice more. Always the same error. I truly think I’m dowloading the full OTA zip file every time (it is around 500MB, the second file of the ones listed in the support guide), and yet I’m unable to upgrade my Fairphone to Android 6!

If possible, I’d like to just erase everything and start from scratch, so that my Fairphone is predictable and exactly the same as any average Fairphone that was never tweaked (no root acess, no switch to FP Open OS, no gapps, no encryption, no Xposed…).

How can I do that taking the minimum risk of bricking the phone?
In the case it is risky, how can I upgrade my Fairphone???

Just in case anyone stumbles across this pages and faces a similar problem:
I contacted support and they asked me to follow option 4 of this support page.
It worked! :slight_smile: