Flashing LineageOS is not working

Just tried, works like a charm. Thanks for your effort.

Does this build work for both hardware? If yes: then I’ll update the instructions for OTA.

I think it is:

So it seems to work for both hardware revisions indeed :slight_smile:

1 Like

So next step, flashing LOS succesfully. @z3ntu started a build with the new kernel included. Can somebody with the new, and somebody with the old hardware test this release?

If this release works for both I’ll make this a OTA release.


You all are awesome, guys, :wink:


Just successfully flashed the current test build (12th August) on my (1 year old) and on my wife’s (1 day old) FP2 :smile:
Thanks a lot @z3ntu @snevas


Thank you! Just to be sure, your wife’s phone had the blue-screen issues before?

Yes, she had with the old TWPR image and the old lineage build

So let me test that now and be happy, then this thread will be marked solved :blush:

EDIT: This thread can be marked as solved. New Kernel is working now and I am happily using LineageOS now :slight_smile:

EDIT2: This Thread may now be closed :wink:


Thanks guys

have a new fp2 since yesterday and had the same bluescreen issue with TWRP
z3ntu image works like charm! =)

I am having the same trouble like the people here. My fairphone is new (1 day) and I am not a real tech (although I use linux, know terminal shit but only the basics). I followed the dummie installation:

FP Open installed and after that:

Download the file onto the external SD card of your phone.
Start into TWRP.
Perform a full backup of your system to the external SD card.
Wipe the phone.
Install the downloaded image of Lineage.
For me then: Bluescreen.

How do I flash a .img file? I could only flash .zip in the recovery mode :frowning:

FP2 lineage Installation log.pdf (50.0 KB)

Because I was too lazy to reboot, I googled twrp flash img … first result …

1. Boot into TWRP recovery mode, […]
2. It is necessary to have your image file already placed on your device’s storage (Internal or external).
3. Tap on Install in the TWRP main screen.
4. Now, the default mode is to flash zip files, you will need to toggle the mode to images.
5. To do so, tap on the Images… button on the bottom-right of the screen.
6. The recovery will now only see the image files, select the one you desire to flash, this could either be a kernel or recovery image file.
7. Once you select, you will be prompted to select the type of image it is, select Boot or Recovery corresponding to the image file you selected.
8. Finally, swipe the button on the bottom of the screen to start the flashing process.
9. Once complete, you can go to Reboot > System.

That sounds about right.

If this fails, continue here.

1 Like

Did you use the latest build of TWRP AND Lineage? Older Versions won’t work due to missing drivers. And I’m not sure if FPOOS’ TWRP works for flashing LOS. It’s quite old…

With fastboot. I think a bit forum search will help you… :wink:
The way @AnotherElk described only works for /boot and /recovery.

1 Like

Did you use the latest build of TWRP AND Lineage?

I am not sure about TWRP because I only installed the newest version of Fairphone Open OS.

EDIT: I am using the latest version of everything to 100%. Why do I need fastboot for that? I did it like @AnotherElk said, it should work like that too, but it did not. Would it be possible to put a link, which shows the fastboot installation of an .img?

I am sorry but I don’t understand that at all, I am a german speaking person. How do I tap on the images? When I go to INSTALL I can still only tap on.zip files. If I go to ADVANCED - FILE MANAGER I find it, but I can not flash it. What am I missing?

Da gibt’s einen Knopf, auf dem “Images” steht, und damit schaltet man die Dateiliste um, so dass IMG-Dateien statt ZIP-Dateien angezeigt werden :wink: .

There’s a button labelled “Images”, which switches the file list to list IMG files instead of ZIP files.

1 Like

Thank you a lot! I tried it now, the installation was successful, without ANY errors (before I had a minor one), but still I am here with my bluescreen… wow. Do you want a log? Does it help? What info do you need? Thanks for the german explanation, I feel very stupid, I should have seen that button hours ago :D…

EDIT2: This Thread may now be closed :wink:

Maybe not? I am not sure, but I think I now did everything like it was said in this thread.

@z3ntu What do you think?

Ok, dann von vorn … Achtung! Das löscht alle Daten …

  • Du brauchst auf der Mikro-SD-Karte aktuell folgende Dateien von hier (USB funktioniert bei gebootetem TWRP):

    • TWRP_3.1.1-0-ota-fix.img (Wenn Du das nicht schon hast, aktuelle TWRP-Version mit Patches für neue Hardware)
    • modem-17.09.3.zip (Aktuelle Hardware-Treiber, übernommen von Fairphone OS)
    • lineage-14.1-20170911-UNOFFICIAL-FP2.zip (Aktuelles LineageOS)
  • Zuerst installierst Du TWRP_3.1.1-0-ota-fix.img (wenn Du das nicht schon hast), dann bootest Du da rein.


  • Settings - “Zip signature verification” deaktivieren (Haken rausnehmen) - Zurück zum Hauptmenü

  • Mount - Aktivieren: “System”, “Cache”, “Data” und “Micro SDCard” - Zurück zum Hauptmenü

  • Wipe - Advanced Wipe - Aktivieren: “Dalvik / ART Cache”, “System”, “Cache”, “Data” und “Internal Storage”, NICHT aktivieren: “Micro SDCard” - Swipe to Wipe - Zurück zum Hauptmenü (wenn es nicht automatisch dahin zurück geht)

  • Install - Select Storage: “Micro SDCard” - modem-17.09.3.zip - Add more Zips - lineage-14.1-20170911-UNOFFICIAL-FP2.zip - Swipe to confirm Flash - wenn fertig, Reboot (kann eine Weile dauern, nur die Ruhe)

1 Like

Ich hab alles gemacht, aber bemerkt, dass ich nicht die > lineage-14.1-20170911-UNOFFICIAL-FP2.zip Version habe, sondern die einzige die ich im Web fuer das Fairphone 2 gefunden habe.

I did everything 100% like the walkthroughs said to, but I don’t have > lineage-14.1-20170911-UNOFFICIAL-FP2.zip , where do I find it?

the bluescreen stayed with Version lineage_FP2-ota-2017-06-14.zip and the installation is still marked successful

https://androidfilehost.com/?w=files&flid=181284&sort_by=date&sort_dir=DESC/ SOURCE

What I have as software:

recovery.img (from here)
(preinstalled Fairphone OS so I should have TWRP_3.1.1-0 and it’s showing that Version in the menu bar)

How did you find different things?