Flashing image fails, including SP FLASH TOOLS

I might need the help of the community for a last time.

I have a quite bricked FP1(U). It started rebooting without a reason a while ago, then sometimes went into bootloops, and now doesn’t boot further than the Fairphone logo.

I tried flashing it from the recovery mode with
adb sideload FP1-Fairphone_OS_v1_8_7_Image_2015081400.zip

However, after transmitting, the FP just reports back
installation aborted.

I went over to the great XDA wiki, and wanted to try flashing with the method described there. Howewer, the links in this XDA post to version 5 of SP Flash are dead, so I went to the other thread explaining the use of SP Flash Tool and found working links there.

I installed the drivers, and unpacked SP_Flash_Tool_5.1728.00.000_Windows.zip, and started following the instructions.

Now, I ran into a wall again: SP Flash Tool doesn’t want to load the scatter file. It reports Platform MT6589 not supported on this version. Please update to the latest flashtool and try again. Which, of course, doesn’t make much sense.

Can someone on the forum please help me finding out how to revive the phone?

Are you trying to sideload via CWM or via the stock recovery?

I suppose stock, since I had to follow your link to find out what CWM was.

I’m using FP1-Fairphone_OS_v1_8_7_Image_2015081400.zip, since I ran 1.8.7 on a FP1U, i.e. with the modified storage layout.

CWM (ClockworkMod recovery) is a custom recovery that not only lets you create full backups (so called “Nandroid” backups), but also is more permissive and powerful when flashing images. Please try CWM out. (If you can, first push the zip to your phone and then flash it directly in CWM, rather than taking the detour via adb sideload.)

I can’t access the phone, at all. I can get into recovery mode, most of the time - but sometimes even that fails.

Do I get that right, I can use CWM instead of adb / fastboot? And the stock image I named above which I got from here, i.e. this file? (You were talking about a specific recovery.img here, right? That’s not the zip I linked, right?)

I’m looking at the CWM webpage and the XDA page right now, and can’t say I fully comprehend what to do next. Looks like I need adb and push the recovery image to the device?

Edited to add:
FFS, the installation of the Mediatek drivers seems to have caused more havoc. I can’t see the FP1 with adb devices!

What you need to do is to follow the installation guide.

Yep, that’s simply the CWM recovery image, not the zip (that zip includes both Fairphone OS and the awfully limited stock recovery). Unfortunately FP1 doesn’t support fastboot and that’s why we have to use the installation procedure I linked to above.

That’s not good. Better get rid of the drivers. Are you on Windows?

Jepp. Win 7.

I’m trying to troubleshoot the driver issues. Damn, this is so annoying.

Erm. When I press the power button and keep volume up pressed, I come to a menu which reads

`Select Boot Mode:
[ VOLUME_UP to select. VOLUME_DOWN is OK.]

[Recovery Mode]
[Fastboot Mode]

So I suppose there is a fastboot mode on my FP1U?

Try it out. :stuck_out_tongue: Believe me, it does not work. I have tried it multiple times.

1 Like

I’m still at a loss. Stefan, as you are very active on the forum, do you know if someone here would be probably willing to give me help with this? I think I need an experienced flasher… :confused:

(I’d like to keep it on the forum for people to find, otherwise I’d head over to xda.)

Oh, and BTW, when I chose fastboot mode, nothing seems to happen on the device, but fastboot devices actually finds a device. With an ID which is not the usual 1234…

However, I’m not sure if this helps in any way.

Oh really? That’s intersting! :open_mouth: But flashing *.img's does not work, right?

Maybe the #fairphoneangels ?

I didn’t try in fastboot mode. Flashing with adb didn’t work. I’m hesitant to do try and error trials here, because I might as well hardbrick the device for good.

For example, what should I try flashing from fastboot? The recovery image you linked? Or the FP OS I tried through ADB? Should I wipe the device through fastboot? What about the bootloader?
I’m willing to learn, but I feel that some help here would be… helpful. :wink:

ETA: had a look at the #fairphoneangles - I’m quite far from the next community. Anyone on the forum you could recommend for an online chat?

You could try the Matrix/IRC chat. Contact info is here: #communityguide

Ps: Yes, try to flash the recovery.img.

fastboot flash recovery.img

if I’m not mistaken. System etc. don’t get touched by this, so it’s relatively save to at least try it.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

For the record, fastboot flash recovery recovery.img returns:

>fastboot flash recovery recovery.img
target didn't report max-download-size
sending 'recovery' (5688 KB)...
OKAY [  0.187s]
writing 'recovery'...
FAILED (remote:
partition 'recovery' not support flash)
finished. total time: 0.219s

@humorkritik What’s the end of the story? :slight_smile:

Edit: For the record, I just updated the xda guide “when you totally bricked…” after having done some thorough testing for someone else. I found out that the latest confirmed-to-be-working version of SP Flash Tool was v5.13.32 and I downloaded it here from Mediafire. Everything worked fine with this version.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.