Fixing OTA after rooting

Great! What exactly should we do?

Normally I’d say wait for someone to dump a partition with the correct hash, but I’ve checked every dsp partition / dsp.img I have and all of them, every single one, including the factory images have the SHA256 hash 8b52788ea43f580b6641b78170df42908b5c39b8c23d54b0d749ed37f5931a73.

So either you were on an ancient build before (for which I deleted my backups) or something else is going on here :thinking:
Whatever it is, it’s not directly related to Magisk, that only touches boot.
What Magisk modules did you install, did you run any other scripts with root privileges that could have altered your system?

  • F-droid privileged extension
  • Font Manager
  • Shamiko
  • Systemless Hosts
  • Universal SafetyNet Fix
  • Zygisk - LSPosed

I don’t think so.

This is my second FP4 and I didn’t brick it like I did with the first one. I just rooted it following your instructions and I applied the OTA until now, but following @rar0 instructions in this topic. Present build number is: FP4.FP3W.A.128.20220516

Hmmm hmm :thinking:

LSPosed might play a role here, not sure why it would touch dsp I don’t see any audio module here.
Did you install any additional LSPosed modules?

In any case, I’d first try a reboot to get rid of all the “systemless” changes that might still hang around and start the update again after that.
That also means you’ll have to reroot manually again once (if) that’s successful.

Edit: dsp is not only related to audio… :man_facepalming:

No more succes logcat.txt - pCloud

Yeah, same error…

We could try to figure out what happened on the 25th of June…

07-12 10:16:52.117  1493  1493 W update_engine: [WARNING:mount_history.cc(66)] Device was remounted R/W 1 times. Last remount happened on 2022-06-25 04:31:39.000 UTC.

…when the dsp partition got mounted R/W for some reason, but honestly I’d nuke and pave at this point.
Who knows what else got changed on your system, better to start fresh from a clean slate.

…at 5:31 am…
So it is better to do a fresh install, isn’t it?

I would suggest it, yes :see_no_evil:

This might be fixable or we might chase one edge case after the other, but without a matching dsp.img there’s no use in trying to figure out what caused it.
I’d say perform a fresh install and if you run into that same problem again down the road we’ll have to seriously look at possible causes.

I’ll upload a Magisk patched boot.img in the meantime so you can at least get rerooted faster :slightly_smiling_face:
Edit: FPOS-A.142_magisk_boot.img

Thank you! I’ll do that

Please: where can I download the boot.img of build A.0128?

I’ve uploaded you a patched A.128 one here, there’s a folder with all my previous patched boot.imgs as well and you can always get specific stock kernels on Fairphones kernel page and patch them yourself if necessary.

Thank you a lot! Before I start with the factory reset I want to try if I can update following the @rar0 method


Update : I can’t… :unamused:


Update 2 : after a factory reset I got same hash problem. I think I’ll flash FPOS factory image.

I meant flashing factory images when I said nuke and pave / fresh install, doing a factory reset doesn’t restore damaged partitions, that only deletes userdata.

I see… Download in progress
I wonder if the problem didn’t begin here : Fixing OTA after rooting - #13 by cortomalese

It probably did, yeah, but I’m still not sure how that lead to a modified dsp partition, Magisk only modifies boot (by default) :man_shrugging:

Regardless, all that old baggage should be gone with a shiny new factory fresh install :smirk:

Done. Thank you very much! :sweat_smile: