First Steps after installing /e/OS | removing bloatware

I just want to second that. It seems that what you want is a bare-bones Android (I don’t mean that negative at all, after all I’m still using the FP1U which has a bare-bones Android), and LineageOS should be much closer to that demand.


Great news, sounds like LineageOS is not that far away from getting published for the FP3. The Freedom of joice is always good, eventhough I don’t know if I want to switch that fast again…

A bare-bones android sounds really nice. But I don’t think I can handle to install something like that with my experience. All the drivers on program parts that have to be installed…

From your responses it seems also, that there’s no easy way to edit the settings “app” or delete some entries of it.

I don’t know yet, I just have my system two days like that. But on the guide from @AnotherElk which I’ve mentioned in my first post, it was not mentioned. So I guess the apps keep uninstalled even with an update, but if you wanna have them back, you could just use that code line:
adb shell cmd package install-existing packagename

1 Like

No. That’s the point of this ADB way to deactivate them as far as I understood.

1 Like

You don’t have to install drivers on Android. The SoCs (System on Chip) are highly integrated and LineageOS imports the drivers from Fairphone OS.

PS.: /e/ is based on LineageOS.

1 Like

Just bear in mind that LineageOS – like /e/OS – also comes with a set of very basic apps pre-installed. You just don’t get any app store pre-installed unless you choose to add one yourself.

I uninstalled openkeychain. The entry in settings is still there. Is it not full removed?

Does the entry now say it’s not installed for the current user? If so …

Edit: I just tried this myself and I could uninstall OpenKeychain without a problem. The App entry is gone, and the account it had in Settings - Accounts is gone, too. The OpenKeychain entry in Settings is still there, but Settings crashes when I tap on that.

Are you sure you uninstalled the package org.sufficientlysecure.keychain, and not perhaps, which would be something different?

1 Like

The OpenKeychain entry in Settings is still there, but Settings crashes when I tap on that.

Same at me. I uninstalled org.sufficientlysecure.keychain. I ask for the entry in Settings, is it always there?

Apparently. Same as with microG.

1 Like

Ok, thanks for sharing the recommendation you linked, it’s very interesting.

Yes, I uninstalled org.sufficientlysecure.keychain and
it isn’t in settings/accounts anymore but it’s still as an entry in settings as well as settings/Apps and Notifications with the note “not installed for this user” but even with the help of your link I can’t get rid of this note. How do I have to do this?

hm… probably the solution of getting rid of the entries under settings is more complex…

Yeah for LinageOS, /e/ and all the other roms it is clear, but @urs_lesse was talking about, that he has a bare-bones Android. Is it there as well like this? If so, where can I find such a bare-bones OS or is that or is it one who everybody has to do it by its own.
Or was LinageOS ment by that? I guess as the Fairphone 1 came out, the idea of GSI wasn’t even published…

I only know the way I linked to.
The App is not installed for you as a user, I guess you would have to live with that then.

The solution in this case is to build your own Android and remove the stuff you don’t like from the source code.

The “bare-bones Android” would be AOSP, on which every Android OS out there is based.
LineageOS is close to what AOSP would be like.

Yes. You don’t install hardware drivers as a user, they are built into Android, apart from basic stuff mostly by the smartphone vendors so Android works with their phone’s hardware.
If you would want to change something there, you would have to build your own Android.


He was talking about AOSP, which uses the proprietary drivers. The GSI idea (which indeed didn’t exist when FP1 came out) also relies on proprietary drivers. If you are looking for a real Linux distribution, you should support postmarketOS. However, there has not been any work implementing pmOS on FP3.


For reinstall openkeychain is the right command: “adb shell cmd package install-existing org.sufficientlysecure.keychain”

Nothing with --user 0 or so? --user 0 is in the uninstall comand.

I didn’t try.
In case of doubt a factory reset will bring it back (I did one in the meantime for other reasons).

Yep, it works fine! I’ve needed it several times.

I’ve marked the threat as solved, because their are a lot of solutions mentioned, like the following:

1st Solution

2nd Solution

3rd Solution

4th Solution

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.