Fingerprint gone from device menu

Hi, since a few days my fingerprint sensor is not working anymore and this function is also gone from my device settings menu. I’ve been reading the forum and tried a few things:

  • restarting my phone
  • disabling the pin on lock screen and restarting my phone
  • checking for updates, but there isn’t one available

None worked. Any suggestions on what I can try?

Hi have you tried the internal test. Dial *#*#66#*#* and select the Service tests> Test single > Fingerprint test

If you get no response it could be a loose connection so you could try a DIY.

Will update with more detail

See this post for removing the screen and basic access


Thanks, I saw this suggestion on the forum indeed, but did not try it. Now I did and I get: ‘finger_result.txt is not exist’

The iFixit guide for an alternate view of disassembly is

WARNING: If you go past step 7 you will void the warranty, which otherwire you may still benefit from.


Thanks, not sure if I pressed the right connectors, but it worked!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.