Fairphone4 with LineageOS2, can't play videos on Netflix oder Disneyplus

Hi all, I’m running a Fairphone4 with lineage-20.0-20230226 . I wanted to get Netflix and Disneyplus to work, but was not successful until now. The bootloader is unlocked because otherwise lineage won’t boot.
I’ve installed Magisk 25.2, enabled systemless hosts, zygisk and denylist. In the denylist I’ve configured google playstore and google services framework, Netflix and Disney+. I’ve added Universal SafetyNet Fix as module.
I’ve wiped data and cache from Netflix, Disneyplus and Google Play Store.
After this configuration the configuration passes SafetyNet Checks and also Netflix shows up in the playstore - which doesn’t without the magisk configuration.

But when I start the Netflix app, only the splashscreen appears. After 60s or so some error message appears, but there are several different errorcodes that change when the app is stopped and restarted or the phone is restarted.
In Disneyplus I can choose from films, but whichever I want to play, I receive “Error 39”.
I’ve attached four screenshots showing details of my magisk configuration.

I assume there is an issue with drm protected videos, but I don’t know how to debug this further.

Any help is appreciated!

Best regards

While I don’t use those apps, have you tried installing Shamiko? Denylist doesn’t necessarily seem to work with some apps that are specifically looking for traces of root or Magisk.

Maybe have a Lok at this topic

Thanks for the hint. Both YASNAC tests are passed with the configuration shown. I think that makes sense because Netflix shows up in the playstore.

Thanks! Didn’t know that. I’ll give Shamiko a try and report back.

Netflix seems to work without any DenyList settings on iodéOS, but with microG instead of the original Google apps.

Though I have the MagiskHide Props Config module installed and my device fingerprint is set to the FP3. I did this to fix some problems with my health insurance app, maybe this is needed for Netflix, too.

1 Like

As above, shamiko and props to fp3, and try to block the whole app in the deny list, those blue lines above the apps show that you are only blocking part of the apps.

FWIW, there may an issue beyond whether or not the phone is rooted and the SafetyNet checks pass. My phone is not rooted, and I can install Disney+ but get an error when I try to play a video. When I search for Netflix in the Play Store I’m told the app is not available for my device. I’m using a FP4 running LOS 20, build 20230312-NIGHTLY-FP4, with MindTheGapps (and I’m in the US).

I have the same constellation as you.
Disney+ works for me when I use it in the browser in desktop mode, not in the app. But I can’t get Netflix to work.

Thanks for the hint. Installed Shamiko today (and went through the config steps) but the “blue bars” on the Deny List haven’t changed and still Netflix refuses to start…

I was already half way to install MagiskHide Props Config but then I quit because the download page has the disclaimer: This project is dead and has been for some time. So I wonder if it is still usable.
Thanks a lot for the explanation of the blue bars. But I don’t know how to “block the whole app in the deny list”. Is there more than selecting the “Netflix” app?


i dont use netflix to be honest, i just saw those bars. hope you can get it to work. i tried the new props beta, but that always fails, old one works great.

We did some tinkering with Magisk but in the end we went back to stock Fairphone OS as described in this support article .Went smoothly and Netflix now can be used.

I’m having the same problem. Reading online it seems the issue wasn’t even magisk, but the rooted phone. And, If I understood correctly, the phone being rooted itself is technically not the problem, more accurately its the fact that it has the unlocked.

This sucks, because I already tried to re-install from scratch with the official instructions, But the re-locking part always fails, the easy-installer seems to skip it, and doing it manually make the phone go into a boot loop.

So I think the promise of a degoogled phone is false unless you’re willing not just to give up google but other items too. :frowning:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.