English

Fairphone root partially broken?

Hey everyone,

I’m still trying to get Titanium Backup to work after the MM upgrade to my FP 2 running rooted FP Open OS.
Titanium Backup says the su-binary is out-of-date.
I installed root verifier and it says that “Root permission not granted or superuser app missing”.
Also tried updating BusyBox, but can’t because “Require superuser privileges”.
However, root is enabled in the developer setting and I can regularly access the root directory via Amaze.

Is this all due to the way FP Open OS handels root or is there something wrong with my root?

Thank you very much for your help!
Best,
Dominik

If Amaze can access the root directory then nothing is wrong with root. TB always complains (a bit) about FP’s root, but still works well.
Have you tried a different BusyBox installer?

Thanks for the quick reply!
The first quote came from “BusyBox” on F-Droid, now I tried “BusyBox Free” from the Play Story, but got a similar notification:

Additionally, i just tried to create a folder in the root directory.
Though I get no error message, also no folder is created.
I guess, I don’t have write permissions?
Also tried to delete “stk.app”, an unwanted system app created by my network provider in system/app.
It says I have all the permissions needed and displays “Deleting” and “Done”, but the file is still there after refreshing.

I dont want to open new threads all the time, so I post this here:
On every reboot, 3-5 random apps are deleted from my phone.
I removed my sdcard, so it’s not due to these apps saving data on there and get lost when the card doesn’t remount.
Considering also my above stated problem, I guess it’s time to factory reset. I’d like to reinstall some of my apps though.

As I can’t get Titanium Backup to backup on my SD (probably related to my half-broken root, I guess?!), can I copy my Titanium Backup from internal storage to my computer, reset the phone, copy back the files and restore my apps and settings then?

Thanks for any advice on this and/or the other problems I’m having!

Solved by flashing regular FP OS then reflashing FP Open.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.