Fairphone OS 18.03.1 release

That specific one was already fixed in FPOS 18.02.0. See the more complete history.

3 Likes

Afaik at that point you are able to get into recovery and have a look at the detailed reasons (when you see the Android robot: hold the power button, then press the volume up to display the recovery mode).

1 Like

After this last update it seems like everything on my external memory card has been erased (or can’t be read by phone?). Does anyone else have this problem?

Thanks for the hint.

It says
Verifying current system…
System partition has unexpected contents
E:Error in /cache/fp_update_FP2-gms-18.03.1
Status 7
Installation aborted

I had Lineage OS installed before, but was is strange is that I completely reset the phone afterwards. Also, the special post 18.02 update installed without any issues.
I guess a manual of the 18.03 firmware would fix this. But I would like to find the cause. Evev tried a factory reset, which obviously did not help, since it leaves the system partition untouched.

2 Likes

Well, to me it sounds more as a corrupt downloaded image. You might try to download it at a different internet access? Or as you said - probably a manual install will fix it…

I thought so too, but I did a factory reset and then tried the update again, with the same result. The /cache should be deleted on a factory reset, right?

Update: I wanted to make sure that updates in general work and reinstalled 18.02 and then updated to 18.03.1.

2 Likes

Please, also make the update available as binary images through: https://support.fairphone.com/hc/en-us/articles/213290023-Fairphone-OS-downloads-for-Fairphone-2

I have been using these images in the past to update my FP2 with great success and I would like to continue doing so :wink:

4 Likes

I´m having reboots with the extension since the update…

I am running LOS 14.1 on my FP2. When I did the update to version 2018-03-14 yesterday my phone couln’t read the SD card anymore and asked me to format the card. I did not, instead I rebooted the phone and after that it was all o.k. again, with all data at the SD card.

2 Likes

And now I’m back to the phone rebooting itself for no good reason several times a day…

You could revert back to the previous modem drivers to see whether the new modem drivers are the culprit:

Download modem-17.11.2.zip and put it somewhere simple to find on the phone, e.g. external SD card or Download folder …

https://io.pinterjann.is/public/misc/fairphone/modem/

Boot the TWRP recovery without installing it …

https://forum.fairphone.com/t/howto-use-twrp-without-flashing-it-e-g-for-backup/23747?source_topic_id=38707

In TWRP there’s an “Install” button, from there select the storage (Internal or SD card), select the modem file and Swipe to flash it, then reboot.
The modem drivers get installed somewhere separately from the OS, so your OS and data will not be touched.

It should be possible to install the file with the built-in recovery of Fairphone OS, too, but I never used that, perhaps somebody else can give the steps for this way.

I have the stock FP OS and try to update from 18.02.0 to 18.03.1
Twice in a row, I had an error after reboot, while the system was updating. Removing and reinserting the battery allowed me to reboot my phone, the update was not applied.

What do do?

EDIT: Answering my own question: The manual update works.

Ever since the update, my battery is draining super fast, even in flight mode. I cant even use the phone as an alarm clock in that state, because it‘s dead until morning. Any idea what to do?

1 Like

Hy, I would like to know what is exactly means “Adjust memory interface parameters”.
It’s a hardware problem or only a software problem?

It’s not a problem at all, it’s a fix for a problem - #randomreboots in phones bought after Q3 2017 to be exactly.

It seems to me since the newest one updates needs fairphone extremely long to the store and the accumulator is faster empty. I have tried it with a new accumulator, however, the result is the same one.

To make your battery last longer, there are some things to try in the #batteryguide .

2 Likes