Fairphone OS 17.08.1 (Android 6.0) release

Kudo’s for releasing updates regularly! However, although I think you absolutely make the right decision of releasing incomplete (but functional) rather than complete but heavily delayed, I’m a little concerned about this note appearing three consecutive months in the release notes. Is there any more specific information known about which patches are missing, from which vendor, and what’s holding them up?


I too share this concern. If Fairphone could clarify that would be welcome.

Updated without any issue. Thanks.

Tried to update using the Fairphone Updater app, failed again same as for updates to 17.05, 17.06.4 and 17.07.6, even though the last update was a (full) manual installation.

Here’s how I tried to update:

  1. Load battery completely.
  2. Backup using TWRP w/o installation.
  3. Reboot phone.
  4. Delete data of Fairphone Updater app.
  5. Reboot to recovery and wipe cache partition.
  6. Reboot phone.
  7. Start Fairphone Updater app and check for update.
  8. Start update and reboot.
  9. After reboot, update runs for some time, then screen turns to dead android & „Error“.
  10. Go to recovery (Power & Vol+) and check error details / log.

Here’s the log:
Supported API: 3
Finding update package…
Opening update package…
Verifying update package…
Installing update…
Source: Fairphone/FP2/FP2:6.0.1/FP2-gms-17.07.6/FP2-gms-17.07.6:user/release-keys
Target: Fairphone/FP2/FP2:6.0.1/FP2-gms-17.08.1/FP2-gms-17.08.1:user/release-keys
Verifying current system…
system partition has unexpected contents
E:Error in /cache/fp_update_FP2-gms-17.08.1.zip
(Status 7)
Installation aborted.

Last update was done as (full) manual installation (as mentioned above), phone is not rooted (and was never), recovery was not replaced, no pre-installed apps are deactivated (neither Google nor other ones).
So the same questions arise again: what exactly are the unexpected system partition contents and is there a way (besides probably doing a factory reset) to get the system partition fixed again?

Hi everyone,
Just did the update and it went fine.
However, after reboot, the phone suggested a carrier app from my sim carrier.
Unfortunately, I accepted and now I cannot uninstall it.
Is there a way to uninstall it ?

I’m not shure what TWRP does with /system (maybe @z3ntu can help?), but it could be that it modifies anything there so the update fails.

Wrong OTA package probably. And no, TWRP shouldn’t modify any contents in the filesystem without asking

Hello everyone,
Does the Fairphone OS version 17.08.1 fix the bug of intempestiv reboot?? If not, does anyone knows when that problem will be solve??
Thank you for your reply,
Best regard.

I hope it’s not permanent. It would be very bad if the FP2 gets abandoned by its chipset vendors. (And if so, the next Fairphone should not use parts with proprietary drivers anymore. I want a long-lasting phone and not one which I can throw away after a few years because the chipset vendor is too lazy.)


Avoid this update! It erased all data of my SD card, half of my apps don’t work any more (all now with a strange bug that “cannot be fixed”) and I don’t have access to my file system any more. All file explorers have their acces denied. Thank you, Fairphone! There were many times that I was tempted to kick this phone into the rubbish bin where it belongs (freezes, crashes, battery died for the second time in 2 years, rubber cases disintegrate and a lot more of cheap quality). Now the time has come to do it. I’ll buy Huawei next. At least they don’t exploit those poor devils in Accra who die looking for scrap metal in the waste heaps of Sodom (if you know where that is, Fairphone! Better go and look for yourself before being proud), or deal with the ex-mercenaries who enslave villages to make profit with their coltan mines in the DRC.

Update worked flawlessly for me. I used the Updater app and updated from 17.07.x.


At least we agree on the “should not” part, even though it would be a logical explanation for the error message.

In this case the question would be, why the OTA package is wrong; I see two possible reasons:

  1. Updater pulls wrong package: the E:Error in /cache/fp_update_FP2-gms-17.08.1.zip message points into this direction. But then why is this error not more common? I checked Google Play for a new Updater version, but I have the current version 1.39.9 installed.
  2. Package got corrupted during download: so I tried the following to troubleshoot:
  • Cleaned Updater app data and downloaded update & installation using advanced mode.
  • Cleaned Updater app data and downloaded update & installation using normal mode.
  • Downloaded OTA update ([17.07.6 -> 17.08.1](https://storage.googleapis.com/fairphone-updates/d59ad3df-9615-435d-901a-c1160efd4eb4/FP2-gms-17.08.1-ota-from-17.07.6.zip)) from [support page](https://support.fairphone.com/hc/en-us/articles/213290023-Fairphone-OS-downloads-for-Fairphone-2) and tried to install using Updater app.

Result was always the same: error like described in my post above.
So I think I can rule out a wrong or corrupted OTA file.

As a conclusion this would mean it’s indeed an issue with the system partition. Still open for any suggestions or ideas.

1 Like

Then I’d guess there’s unwanted stuff on the system partition…

Yes, proabaly. I’m just completely clueless how that (whatever it might be) came there…

Since you have done a good analysis of that, maybe post it to the bug tracker?

Update worked flawlessly for me for Fairphone Open. I used the Updater app and updated from Fairphone Open 17.07.x.

Hi kofi, I am sorry you made such bad experiences with the FP2. For me, however, I cannot confirm yours. Using “one of the first” FP2 since January 2016, I use it for business and private phone calls, E-Mail and Organizer (incl. Exchange-Server-Sync), pedestrian (and car) navigation, public transport navigation incl. the service offered by myself (e.g. by my corporation), internet browsing, banking, some music (stored on the phone and via UPnP), some guitar tuning, camera. The phone is not rooted, and I use only one SIM and no SD-Card. (There are many FP2 Users using SD-Cards without having update problems.)

Every system update went smooth, the known software bugs disappeared gradually. Some are still present, but not severe for me. For the battery draining problem I made some suggestions here as for several other problems as well, however the battery in general is rather week. The only hardware issue I had happened some weeks ago when I left my phone in my tent having direct sunlight through the plastic foil window. At 60°C or more, the rubber band of the case dissolved at the volume switch. The phone worked perfect even in this heat, but of course I had to buy a new case at the accessories shop. This one seems to be more reliable and looks even better.

So my suggestion, send your FP2 to Fairphone for exchange (repair seems not be enough), suggested there is still guarantee. There seem to exist some really buggy devices out there. But give Fairphone a chance to provide you with a working phone. I would be glad to hear from you here in this forum.


In principle, you are right. Unfortunately I’ll not be able to follow up a bug report in the next weeks due to vacation. Therefore I did the usual manual update right now.
If the September update won’t work out either, I’ll seriously consider creating a bug report.

1 Like

Flawless update 2 days ago, works without issues. Fairphone Open