English

Fairphone OS 17.07.6 (Android 6.0)

Currently on 17.06.4 - non-beta version. I’ve had to stop doing the beta versions as my banking app kept breaking because it treats a beta os as a ‘security’ issue :frowning:

EDIT: I wondered if it might have been a past beta that was causing the issue, so I reinstalled the previous update using the binary image and then run the new update. This has now worked perfectly

2 Likes

We fixed the storage permission issue only (https://bugtracker.fairphone.com/project/fairphone-fairphone-os-android-6/issue/36).

And I thought, with the actual update I could move to the open 6.0 OS without bigger risks to run into problems :confused:

The app doesn’t ask for permissions when starting recording as it didn’t before (I have no SD-Card installed). The recording is just stored in the internal root folder, not the provided folder “SoundRecorder”. The settings are not accessible but only listed as key codes. The app stops immediately after saving so you cannot hear your recording. The app is unusable. I just installed the suggested app from FDroid which works well. In my opinion it makes no sense to spend more time and effort into this useless app.

2 Likes

My update lost Amaze file manager, so I spent a while figuring out how to reactivate Google Play store, setting up a new login ( forgot my old one), getting amaze again, and trying to disableplay store. Bit peeved.

Now I need to play around & find out all the new ways to do things. It does look as if there are improvements.

Would it be possible to add the new version on the website? That way, we can als update rooted phones. Thanks!

Afaik Amaze was removed along the upgrade from Android 5.1 to 6.0. You can use the built-in file manager, which you find in settings > storage > somewhere there :smiley:

1 Like

The manual archive is now online.

EDIT: I am not saying we are supporting root ;), just that the archive is available.
As always, be careful if you have modified system (e.g. by using Xposed) - you can hit walls there and have to wipe userdata.

1 Like

Hi there! Everything looks different now. Is it about the update to Android 6? I’m looking fir everything now. And also I miss my application for sms. I can not find it anymore. I don’t want to use hangouts and I can not find another one, so simple and supporting two sim cards as there was before the update? Did this really need to be deleted? Can’t see any approvement there. Can anybody recomand a new app to me please? I don’t need to send gifs or voice messages. I want to write normal SMS and I want to be able to chose, which sim I use for that…

Hi @amiramusikus, welcome to Android 6!

You want to install SMS Messaging (AOSP).

It was Google’s choice. Blame Google.

Here’s some reading material for a start :wink:

2 Likes

Thanks a lot! Only the link for the sms app - I allready installed that one again, but it doesn’t ask me anymore, which sim I want to use :(( I have it in the main settings, there is “ask every time”. It’s just not asking… Do you have a tipp for that?

If something similar happens again: You can have had it easier, if you use F-Droid or Yalp to download the (amaze) app!

There is still a sms app on your phone after updating to Android 6.0, but it’s now called Android Messages (blue icon). The default app also supports Dual Sim.
Please refer to the the blog post for all the info and changes from 5.1 to 6.0.

1 Like

Glad it all worked out well!

1 Like

@rick: You released 17.07.6.1? Is there any changelog? :wink:
I’m no longer on FPOS, but maybe it’s relevant for some people. :slight_smile:

Since updating to the latest version last night, I’ve already had two sudden reboots. This has never happened before, so I’m pretty sure it’s the update.

Anyone else seen the same thing?

What do you mean? :slight_smile:

If you talk about Fairphone OS 17.07.6, the changelog can be found here: fairphone.com/release-notes, as mentioned in the opening post.

I’ve sent you a DM for your device UUID, this way we can look into the cause.

The download-site now links to 17.07.6.1. It linked to another location with “17.07.6” yesterday (I don’t have the link now, but my autobuild-server for rooted boot.img’s never lies! :stuck_out_tongue: )

1 Like

Worked without any issues, just let it do its stuff while I was busy with something else. Only a pity that the audio recorder is still not well usable…
Thanks anyway!

1 Like