English

Fairphone open USB does not get recognized

Hello,

I have a problem with my Fairphone 2 running Fairphone open 18.01.1 and my USB connection

Without having the Developers Settings enabled, I do not get any USB connection (neither charging nor data transfer). Once I enable developers options & USB debugging, I get the notification menue to select the kind of USB connection (charging, data, etc.)

Can you please provide help how to get a USB conneciton without having the developers options turened on.

Thanks
Fabian

2 Likes

USB connection with which OS? Linux? MacOS? Windows?

Hi,

I was using Windwos 10.

I just figured out a way to solve this:

  1. Turn on “developers settings”
  2. Change setting “USB configuration” from “charging” to MTP
  3. Turn off “developers settings”

Now I have the dropdown menue once, I connect my FP to the PC and the phone is actually charging by default (MTP has to be selected manually). So in fact in this case I have the expected behavior.

So to me this seems as a bug in the Fairphone Open OS. Is there a way to report bugs?

2 Likes

https://bugtracker.fairphone.com/

1 Like

Just a thought, could your usb cable be faulty?

I’m not sure if this is the answer to your problem, but when you plug your phone into your computer, a small thingie will appear on top of your phone screen. Pull down the menu and select the thingie where it says that your phone is connected via USB. You can change the setting between charging/MTP/PTP/Midi etc. there as well, without having to enable the developers settings :slight_smile:

(sorry for the "thingie"s, english isn’t my first language and i don’t know how to call them :smiley:

1 Like

Thanks for all the help.

As mentioned in my second post, I found a workaround. so I just want to sum it up, in case someone else has this problem:

  • USB cable is not faulty (tested with several cables)
  • The MTP selection drop down does not show up, with “developer settings” disabled
  • The following workaround enables the MTP selection drop down
    1. Turn on “developers settings”
    2. Change setting “USB configuration” from “charging” to MTP
    3. Turn off “developers settings”

Thanks all

5 Likes

Hello flindner,

I just wanted to confirm your observation. As I just have the same symptom, I believe this is a bug introduced with 18.01.1 or maybe already with the previous 17.12.x.

I can add that I’ve also checked a dedicated charging device. During “regular” operation the device isn’t charged (no LED indication, nor a loading indication in the status bar).

Two further observations:

  • Rebooting the device while it is connected via USB cable initiates the logical USB connection and the charging.
  • Charging while the FP2 is switched off works as intended (animated charging screen and LED indication).

Have you submitted a bug report or contacted FP support?

Greetz
Phant

2 Likes

Yes I started a Bug report:
https://bugtracker.fairphone.com/project/fairphone-fairphone-os-android-6/issue/100

Greetings
Fabian

1 Like

OK, thanks.

I’m not familiar with that bugtracker yet. Do you have the chance to add information to the Custom Fields below the bug description (i.e link to this thread, OS version, etc.)? I believe, the more information the programmers have, it could be more likely that the bug is fixed soon.

Good point, I added a link to this page.

Let’s hope they will fix it, its actually annoying

Hi all
I suffer from the same problem
I Use debian 9.3, it is always at the current stable .
I Note that Fairphone2 with Open OS reports different usb Ids,
with Setting on Charging the report is
mtp-detect
libmtp version: 1.1.13

Listing raw device(s)
Device 0 (VID=2ae5 and PID=f003) is a Fairphone Fairphone 2.
Found 1 device(s):
Fairphone: Fairphone 2 (2ae5:f003) @ bus 2, dev 2
Attempting to connect device(s)
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
ignoring libusb_claim_interface() = -6LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.

Once USB is set to set to MTP : the output is
jmtpfs -l
Device 0 (VID=2ae5 and PID=9039) is a Fairphone Fairphone 2 OS.
Available devices (busLocation, devNum, productId, vendorId, product, vendor):
2, 4, 0x9039, 0x2ae5, Fairphone 2 OS, Fairphone
root@lenovo-R500:/etc/udev/rules.d#

So with Charging the output is different.

Only in developer mode !
I needed one week (calendar time ), work time was more like 16 hours to find all that out.

Stupid enough, I disconnect the usb cable and the setting MTP is gone.

The USB Cable I suspected defective works only in MTP mode for charging.
Another USB cable works always for charging !

I hope these hints help.
Best Regards Erich

1 Like

10 posts were split to a new topic: FP1 not recognized via USB

For me the solution of @flindner didn’t solve the problem ultimately
After shutdown/reboot the bug is back.

@Phant: In my case the bug was introduced with 18.01.1 or a bit later
But there’s already a similar thread:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.