Fairphone open OS version 19.11.2 can't install opengapps because TWRP is gone

I’m in a pickle, as the title suggests. Tried doing it the usual way when I update (even though it’s a hassle) by doing an open OS update, then flashing ARM x.x micro through TWRP. This time however, I found out that TWRP was removed and replaced by AOSP. So I tried flashing ARM 7.1 micro via sd card in AOSP, but that only resulted in “failed to verify whole-file signature” and “Signature verification failed”.

I’m at my wits’ end here. My phone became practically unusable because my battery gets drained (and phone heats up), probably because it keeps searching for google services, which I don’t have because I can’t reinstall them… Manually installing TWRP via the app doesn’t seem to do anything either. It’s either very buggy, or it says “TRWP img flashed successfully”, but nothing happened.

At this point I’m looking at a factory reset through AOSP, but I’m dreading losing my appdata, even though I have Titanium Backup.

If anyone has any advice, it would be much appreciated. Also, weird that no one else has encountered this?

The TWRP app does not allow you to install TWRP itself, it just allows you to update an existing TWRP recovery. Instructions how to install TWRP itself can be found in the general LineageOS instructions here (section: “Installing a custom recovery …”):

Make sure not to omit step 6 because otherwise TWRP will not stay on the device.


This actually solved it! Didn’t take me very long to flash TWRP with the link you provided. i was so happy when I actually saw TWRP launching instead of AOSP! After that I was on familiar ground and followed the guide below that I always use:

Thanks for pointing me in the right direction!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.