Fairphone Open 18.01.1 is now available

Hi all -

Fairphone Open 18.01.1 is now ready for your FP2 device. It includes the following changes:

  • (Fairphone Open only) This release includes the F-Droid privileged extension, which allows the F-Droid app to install, remove, and update applications without the user having to enable installation of applications from unknown sources in settings. The F-Droid privileged extension also enables F-Droid to automatically update applications in the background
  • Fixed an issue where the Camera app resolution wasn’t updated after installing new camera modules
  • Security fixes – Android Public Security Bulletin from January 2018 (partial)

Full release notes.




The question is to know if Meltdown and Spectre are “fixed” in this release ?
Will there be an impact on battery ?


Edit : yes finally as said by Amber below, I found the dedicated topic which indicates February …


No, as douwe stated in below article, Fairphone analyzes vulnerability and patches will be part of February update.


FP2 is not affected by Meltdown, anyway (Krait 400 are based on Cortex A-15, which were not affected).

Spectre is a set of vulnerabilities — most of them yet-to-be-discovered — and “fixing” Spectre will take longer for any vendor (thus its name: “it will haunt us for some time”). Nonetheless, they are difficult to exploit, so install software only from trusted parties (Google Play, F-Droid) and you’ll be covered until mitigations to Spectre arrive, in the next February update.

(Please, continue the discussion in the dedicated FP2 patch for Meltdown/Spectre thread)


The update went smoothly.


Furthermore everybody can watch out for the CVE numbers:

  • Meltdown (CVE-2017-5754) <- as explained by @Roboe not relevant for the FP2
  • Spectre (CVE-2017-5753 & CVE-2017-5715)

If a fix for these is part of the release notes the vulnerabilities are fixed.
If they are missing it is probably not yet fixed. :wink:


I installed the update manually and it went rather smoothly, albeit not entirely:

  1. After reboot and optimising apps it didn’t finish the booting process. I had to reboot manually by holding down Power for ten seconds.
  2. Although I cleared the recovery.img from the manual update package and adjusted the installation script and checksum files, the update package still overwrites the bootloader partition with an outdated TWRP 3.0.2 which
  • cant’t handle an encrypted data partition.
  • freezes the phone when trying to reboot to system.

I would be very glad when at least the second topic was fixed by the developers. What’s the problem with a new TWRP?

By the way, the addition of the F-Droid privileged extension was the best choice in years for this FLOSS friendly Android distribution! Thumbs up! :+1:

1 Like

The first time I tried to install this update, my phone rebooted into some sort of bootloader menu where I was asked if I wanted to “keep the system read-only”. There was a button for “keep read-only” and a slider that said “slide to allow modifications”. I used the slider (hopefully not making permanent changes by doing so) and got to more menu options, but only powered off the phone.

After the next boot, the OS was still at the old version and I could start the update process again. This time around it completed without problems.

The sort of bootloader menu you mentioned is the recovery mode, especially TWRP.

The update went smoothly. No problem so far.

1 Like

Hi, I did the update and ended up with the phone not recognizing any SIM card. It is also not possible to activate Wifi.

Currently, it seems to randomly reboot.


I have tried this on my phone twice now and in the process of rebooting the phone, it sits on a screen saying “teamwin recovery project 2.0.2-0” and heats up quite a bit. After a number of minutes > 20, I powered off the phone.

I rooted my phone in between attempts. Not sure if that would make any difference.

As it stands I have left my phone on this screen on my 2nd attempt so far.

Any suggestions please?

Same here! :slight_smile: Thank you, Fairphoners!

1 Like

Please answer some questions first:

  • How did you install the update? Via the updater app, TWRP recovery or manually with fastboot?
  • Are you able to use fastboot on your PC? Which operating system do you have?

Before installing the update, I wanted to backup with TWRP to my SD card, as I always do. I tried 3-4 times, it doesn’t work (the backup starts, the phone works on it for some time and finally, the backup seems to be done - but there are many lines of red text in the report. When I go into Amaze to find the file, it isn’t anywhere).
There seems to be enough space available on my SD card, though.
Backing up via TWRP to the Internal memory worked, but I cannot copy the file to my computer (I get an error message saying "Could not copy file “boot.emmc.win”).
I have not installed the OS update because I am not comfortable with doing this without having a backup available outside the phone.
Any ideas of what could have gone wrong? Thank you!

Possibly these hold a clue as to what is going wrong.

A common issue with backing up to SD cards, is that file of >4Gb are not supported.

Also, are you sure that the TWRP backup is backing up what you think it is?

1 Like

Thanks! I actually didn’t realize that photos or data weren’t included, but that’s OK because I’ve always been extra-careful and copied them manually. I make a backup before I update the OS in case the phone doesn’t work anymore after the update.

I don’t think I have added any large files since I made the last backup at the beginning of the month (before I installed the previous update).

The lines in red where Chinese to me, unfortunately; and it didn’t seem possible to take a screenshot while running TWRP.

PS No offense meant to Chinese-speakers. It’s just that I don’t know your language…

PPS I wondered whether I should try to erase my SD card and reformat it - can the phone do that and do you think it might help?

I just received my FP2 and installed FP Open from the start. Now I’m having two separate issues that are making my phone a hassle to use:

  1. Several times a day my phone reboots without warning (max up until now was 12 times in one day). This usually happens while writing SMS (I use the Silence app from F-Droid) and the problem occured after the newest update for FP Open.

  2. Some days I have to reboot my phone (if it has not already done so by itself) in order to receive SMS. My friends tell me they sent me an SMS over 2 hours ago, but my phone doesn’t receive them until after I reboot. I have contacted my phone operator, but they have found no fault at their end. This issue occured after I installed FP Open on my new phone (so from the previous update of the software).

Anyone know what might be wrong? Also sorry if I post this in the wrong place, it’s my first time on this forum. Thank you.