Fairphone Open 17.12.1 is now available

Which file did you download? You need the OTA package for upgrading via TWRP.

3 Likes

I just used the other one (because it said so in the thread linked above), but this was going to be my next try :wink:

Edit: Using the OTA file everything worked smoothly. I’ll edit the other thread, then.

Thanks for your quick response!

2 Likes

I just installed the update manually and everything went fine, despite after the reboot a black fullscreen app with only the back button was running past the lockscreen. Another reboot fixed that.

Once again the update went smooth and easy. :slight_smile:

Any update on the fp2-sibon-17.12.1? Since my phone tries to download and install it, but still with the partition problem of the TeamWin screen. So I need to manually install again, but not yet available.

12.1 or 11.2? Downloadpage still 11.2

Where do you look? Perhaps hit F5 on the page (reload).

1 Like

Ah thanks, that does the trick! - downloading

1 Like

BTW: the https://code.fairphone.com/downloads/FP2/blobs/fp2-sibon-17.12.1-blobs.tgz is not needed for non-development use?

It is offered in For developers - Additional downloads and its use is described in For developers - Build instructions - Getting the Binary Components.
I would very cautiously lean towards a Yes (it is not needed for non-development use) :wink: .

1 Like

Thanks. I’ll skip that one then.

But one more: why are the images stored on storage.googleapis.com ? Now Google keeps track of my download of the OS which I choose because I want no traces in Google’s world…

If Fairphone would host such large files on their own servers, that would cost money which I guess Fairphone chose to better spend elsewhere … but that’s just my speculation.

You are using Google’s Android OS and want no traces in Google’s world? There’s something more to do than choosing an OS then …

1 Like

Thanks for the update.
Immediately after the update to Fairphone Open 17.12.1 I’ve been affected by this:
https://bugtracker.fairphone.com/project/fairphone-fairphone-os-android-6/issue/96

Anyone else here?

Same here on both of my FP2

after start-up shortly shows the initilisation screen (new … choose region…) but switched to black fullscreen with back arrow only - reboot fixed it
no furhter problems

Update itself went well, I just have an issue with the open gapps I had installed.

After the last update I did not have to do anything. This time it’s corrupted.
Trying to install it (the FP Updater app opens the file) I just get the screen of the Updater telling me to restart - pushing on the restart button does not do anything. Restarting myself also does not help :expressionless: Any ideas on this…?

That happened to me as well.

Update went good. But I have an issue: my phone restarts with no reasons, two - three times a day. Strange.

See #rebootsguide for hints.

The update went smoothly, no problem at the moment…