Fairphone Open 17.11.2 is now available

Fairphone Open 17.11.2 has been released. You can get it through the
updater, or by download from Fairphone Open downloads.

Security fixes

Android public security bulletin for November (patch level November 6

CVE-2017-0427, CVE-2017-0830, CVE-2017-0832, CVE-2017-0833,
CVE-2017-0834, CVE-2017-0835, CVE-2017-0836, CVE-2017-0839,
CVE-2017-0840, CVE-2017-0841, CVE-2017-0842, CVE-2017-0848,
CVE-2017-0849, CVE-2017-0851, CVE-2017-0853, CVE-2017-0854,
CVE-2017-0857, CVE-2017-0858, CVE-2017-0859, CVE-2017-0860,
CVE-2017-0861, CVE-2017-7541, CVE-2017-9686, CVE-2017-9693,
CVE-2017-9701, CVE-2017-9706, CVE-2017-9717, CVE-2017-11013,
CVE-2017-11014, CVE-2017-11015, CVE-2017-11051, CVE-2017-11092

Hooray for @ben! Hooray for Fairphone’s developer team!


I just installed it manually on my encrypted phone. As always there seem to be no problems.

Interestingly, the about page in the settings area reports Android security patch level from October 5th 2017. Just a little accident?


Unfortunately, my mum can’t enter her PIN anymore since updating. If she enters the numbers, no dots appear and when she presses the checkmark, “Wrong PIN” appears…

Could have something to do with this (substitute Lineage with Fairphone) …

I don’t think so. Lineage relies on the AOSP, but Fairphone gets the patches directly from Google. They were able to release the update (as a beta) with the November security patches more than a week ago.

1 Like

Thanks for the update, the OS is getting even better :slight_smile:

Would it be possible to install updates using the Mobile Network?

When I installed Fairphone Open 17.11.2, the Fairphone Updater requested a WLAN connection :disappointed:

This has been added to the bugtracker with status “accepted”, but minor severity.

Flashed this version today. Worked fine this time even the method is quite time consuming. But today I wrote down some notes what I did, which fit to my settings and my level of knowledge. I hope this will help me to speed up the next update.

For those who are interested …
My facts:

  • FP Open
  • no Gapps
  • Xposed (XPrivacy is the only module I use)
  • AFwall+
  • currently not encrypted as I would like to use Snooperstopper again and I’m afraid that I will run into this issue again.

My update notes:

  1. Backup backup backup … oandbackup (app+data) of all apps + TWRP Backup before doing anything. Just to prevent data loss if something goes wrong while the update

  2. Download latest manual.zip: https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-installation-instructions.html

  3. unzip and remove that the recovery.img flash part, that it will not be flashed to an eventually older/outdated TWRP recovery version: ✏[HOWTO] Upgrade FPOOS without overwriting TWRP (don’t forget to delete the recovery.img from images folder, remove it from SHA256SUMS and MD5SUMS files as well and replace the checksums of the flash-for-unix.sh [make it executable in advance] with the new generated checksums)

  4. Flash procedure itself:
    -Prepare like described above
    -Go offline (disable WLAN and mobile data) and disable xposed framework and afwall+ (optional but maybe safer) → reboot
    -Boot into fastboot e.g. via „adb reboot bootloader“
    turn it off and use the hardware buttons → press „power Button + Volume Down“ (test connection via „fastboot devices“)
    -Flash the update via „flash-for-unix.sh“ (it should not flash a maybe outdated TWRP revocery.img after the preparation under point 3 - this is more important when the device is encrypted, but maybe Fairphone added a newer TWRP in the meanwhile, not sure)
    -Boot into TWRP recovery → press „power Button + Volume Up“ for some seconds
    -Flash latest version of all modifications you use (here xposed framework + fdroid privileged extension)
    -Reboot to system.

Notes which might be interesting if parts of the procedure are not clear anymore:

Thanks to all who provides a note listed above. This really helps. :wink: @StephanK, @freibadschwimmer, @random, …


Hi there,

Updater > Reboot > All good, as always in my case. Well done, thank you.

Worked nicely here as well. Used OTA update and after the installation got into TWRP again and installed fdroid and xposed and every thing went fine.
Only one thing, as noted before: Security Level is still on October 5th. Can someone from Fairphone confirm that you simply forget to update the string, but the patches are all in?


1 Like

The automatic update from 17.10.2 to 17.11.2 on my encrypted phone went well.

1 Like

New with a Fairphone. Everything OK changing from FP OS to FPOpen OS. Great phone, simple OS, but enough for me.

Only once the phone restarted, I don’t know why (I was using Open Camera). But, other than this, everything works perfectly.


Llamas, J.M.

1 Like

A post was split to a new topic: Updater doesn’t notify of Updates anymore

Fairphone Open 17.12.1 is now available

1 Like