English

Fairphone Open 17.06.4 (Android 6.0) release

:slight_smile: probably not enough Fairphones… But yes, i also have the strong impression that the phone is getting hotter, also while running on battery. I think the cpu clock is higher, on average

Just did the upgrade via updater. I was quite afraid by all the messages on this thread so I did a full backup before, but everything went well!
It went as fast and easy as the updates on 5.1 (nothing fancy on my phone, no Gapps, no Xposed, etc).
I can’t really see many differences on my phone (I don’t really like the launcher and the modes aren’t as easy to use, but everything works):

  • quick access icons: I still have the phone icon at the bottom left
  • I still have Amaze installed
1 Like

3 posts were split to a new topic: How to copy files via MTP from Linux? (Thunar filemanager)

After upgrading, my FP2 only showed the new animated bootscreen (no reboot loop). I have an encrypted partition, no xposed or GAPPS. If you have the same issue, don’t forget to try Safe Mode and uninstalling/reenabling apps. That solved it for me!

I flashed the phone with the previous Faiphone OS version. Now I can see the old bootscreen again.
But when I put the battery in and connect it to the charger, the LED is flashing red all the time. Even after hours and no battery loading animation shows up.
Could it be that my battery is broken?

Just did the upgrade last friday, went smoothly. Only a spurious reboot on saturday.

Also, the delivery reports for SMS do not work (as if no message is received). Delivery reports works for MMS.

I still have to check on taiga if the bug is known.

Made the upgrade via updater. Everything worked fine. No reboots, crashes or lost data.

Now it seems to be faster than before :dizzy_face:

Thank´s a lot Fairphone Team!

1 Like

I have installed Fairphone Open Android 6 successfully with the Updater :slight_smile:
Few points I want to remark, and I have one question:

  • the SD-Card had to be reformatted on my phone
    -The screen stayed black when using the phone for a phone call, the problem could be solved with recalibrating the “proximity sensor” -thanks for the forum for useful hints :smile: :thumbsup: (maybe that this behaviour was by chance at the same time as the update to Android 6)
  • when I want to boot into the TWRP mode (Power+Vol.Up starting the FP2) only a Logo of “team win recovery project 3.0.2-0” appears. How can I use the TWRP with Android 6, or better with Fairphone Open 17.06.4?

I never had a reboot issue. But I am on FP Open without gapps since the beginning. And now LineageOS.
Any Google-free guys here with reboots?

The red flashing LED usually means a deep-discharged battery.
If this doesn’t not change even after hours of being plugged it indicates a problem.
It is possible that the battery is broken (Li-Ion batteries can die if their charge once drops below a certain level), or also that there is something wrong with the charger or bottom module.
I suggest: First make sure you use the same charger that worked before. If this does not change anything, you may have a hardware issue. If you know someone with a FP2 you could temporarily swap batteries/bottom module to see which part causes the problem. Potentially it may also help to simply take out and put in again the bottom module (it is possible that the module/connection got loose).

An update how I fixed it:

  1. Downgrade to fp2-sibon-17.04.0-manual-userdebug.zip via fastboot
  2. Upgrade to fp2-sibon-17.06.4-ota-userdebug.zip via TWRP.
  3. Reset userdata: Destroy the LUKS Header for Filesystem Encryption
  4. Install Apps & Configure
  5. Encrypt the userdata partition

Status: When listening to audio via vlc (with and without bluetooth) stutter it from time to time.

Yes :slight_smile: But only 1 since the upgrade (last Friday).

Since the upgrade I have incredible battery problems… without any use battery passes from 100% to 0% in a matter of hours… this is unacceptable…:disappointed:

Hallo zusammen
hoffe, dass ich auch auf deutsch willkommen bin?

Wollte nur allen Zögernden sagen, dass mein Update vom bisherigen FP Open (unmodifiziert) auf FP Open17.06.4 durch die normale Updater-App gestern ohne jedes Problem auf Anhieb geklappt hat!

Habe zuvor erstmals über Power/Volume up TWRP gestartet und ein Komplettbackup gemacht. Vorher noch feige :wink: und händisch das Telefonbuch, Threema, K9-Einstellungen etc. gesichert.

Nach der Installation durch die Updater-App habe ich vor dem Neustart alle Apps beendet und sicherheitshalber das Telefon in den Flugmodus versetzt.

Selbstverständlich sind noch alle Kontakte vorhanden!
Der früher mal aufgetretene Call-Not-Send-Bug ist nicht “aktiv” :wink:
Auch das Problem mit dem Näherungssensor tritt nicht auf.
Antenna Pod zickt ein wenig herum, braucht aber vielleicht nur eine Neuinstallation.

Ach ja, die SD-Karte muss natürlich nicht neu formatiert werden, wenn sie nur als Speichermedium für Bilder etc. verwendet werden soll und nicht als Erweiterungsspeicher für Apps etc.

Insofern bin ich komplett zufrieden und poste nur, weil ich doch mit größtem Respekt die ganzen Problem-Posts gelesen hatte und ein wenig Mut brauchte, um mich trotzdem an das Update heran zu wagen.

In diesem Sinne entspannte sommerliche Grüße aus dem konstant heißer werdenden Frankfurt :slight_smile:
Barney

3 Likes

Same for me.

First I had to erase my ciphered internal storage after doing what’s listed here : Fairphone Open 17.06.4 (Android 6.0) release
Because I had a loop on : “Fairphone’s launcher has stopped working” and “android.process.acore has stopped working”, and “spooler impress has stopped working” and a lot more.

Now, started from scratch the device boots, I can reach the desk, but can’t charge from USB as the battery is draining too fast it seems.
[Edit 5h later: this battery problem was apparently caused by the auto-adjust luminosity feature included in Android 6].
[Edit 2016-06-21 : I think my problems came from TWRP unable to deal with ciphered /data ; and so unable to backup my /data… it’s quite a huge bug, hard to miss.]

To answer Fairphone Open 17.06.4 (Android 6.0) release No, the write permission bug is not fixed, you guessed it write.

I knew I should have wait… but I trusted Fairphone about regular updates. Deceitful.

So now I can’t access my SD Card, no write permission, Fix SD card app doesn’t fix the problem… it’s a disaster… what should I do?

Hello @Teemu_Hukkanen

I just upgrade to Open 17.06.4, the look is very different.
To found the runing applications is now in the developer tools, why choice that place? Strange, but ok, i agree and use, that’s all right.

I just have a little problem (that i also had on the 17.04) it is the intempestive reboot of the phone :rage:. Does exist a way to be quiet with that?

Thank you for your help. :relaxed:

Amaze file manage, when given root permission is able to write to external storage. It’s better than nothing… [Edit : Amaze tells it writes files, but nothing is written in facts]

Open Camera is able to use the Storage Access Framework of Android 5 and so to write directly to external storage.

(It’s not the case of OpenNoteScanner, I’ll have to move those one by hand… I did not sleep last night, trying to have my phone working for today. So I become weak. Why not to use the external storage as Android intend to ?)

[At least Fairphone is buying a legend… if you meet a Fairphone user, you have a 50% probability to know an Android recovery expert !]

Do you use any app that’s using the proximity sensor?
Works be interesting to see cpu statistics, e.g. by cpu spy. I do have the impression the cpu runs on 2GHz too long. I’m still trying to find a way to document this. And the find somebody still on LP for comparison

I don’t know… I asked this question several times as I have no idea which application uses proximity sensor…

Anyway I consider this to be a major deal breaker that irritates me and makes me not love my FP2…