English

Fairphone Open 17.06.4 (Android 6.0) release

Is it the same as with @ungutknut in the sense that it happens occasionally and not every time?

If it happens every time, then perhaps it is worth having a look at Apps that have display overlay permission, as they can cause UI elements to be unresponsive (but normally you should somewhen encounter an error message regarding this):

I had a similar problem. See post FP2 Won’t turn on or charge - See first post for troubleshooting
From all I gathered in the forum, I was sure that my bottom module was broken. Support figured it was the battery. They sent a new one (after 1 month) and it did not change a thing. With the new charged battery the phone worked, until the battery was empty. Still no charging and the red blinking light. So again I told them that I was sure the problem lies in the bottom module. They did not want to send me a new module, but wanted to repair the phone themselfes. I can understand this; they do not want to send out “free” spare parts because some strangers believe they will help. But in my case it was a pain in the ass. The repair-place (it is apart from the normal support) told me that they would definitely delete all my data and I should make a backup. But how am I to do this, if the phone is not working at all??? I contacted my “normal” contact person and she told me, the data will not be deleted. Who am I to believe? Luckly I trusted the technical support. So I had to buy an external charger to charge my battery (on my cost, but they are cheap, crappy pieces childlabour-electronics). Then I could do my backup. I sent the phone to the fairphone repair and got it back 2 weeks later with a report stating: Bottom module replaced. Of course they deleted all my data for privacy reasons.

So, in short:

  • You should contact support and they will help you. They are very friendly, but slow. Which is annoying, because people rely on a phone (I was back on my 10-year old phone for 2 months…).
  • Test to charge your battery with an external charger or a fairphone from somebody else. If it charges, the bottom module is likely broken. If it does not charge, it is likely a broken battery.
  • If you sent in the phone for repair, make a backup before. They will delete your data.
  • You should not buy spare parts on your cost, this is normal warranty.
  • Prepare a bathtub of green tea, buy a rubix-cube and try to solve it just by yourself (no help from the internet!). You will have time to cover and should stay relaxed.

A post was merged into an existing topic: [Bug] :pencil2: Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

Hey @conrad, I have the same problem: phone no longer knows what to do with an apk. How did you solve your problem?

Thanks

Hey @s99h, newbie here - grateful for your advice.

I have the same problem, the file manager can’t open apk files to install them. Which also means I can’t install another file manager which would work.

I see you said it’s not too much of a problem - care to share how you solved it?

Thanks

Initially and out of security reasons I wanted to use my local download folder on sdcard to install my network security app “netguard”. Unfortunately that idea didn’t work anymore because of the too limited preinstalled file viewer in FP Open OS Marshmellow, this thing is a sad joke and I can’t imagine why it is considered an alternative solution for anything.

In the end I acted against my conviction, went online, downloaded f-droid from f-droid.org that could be installed from within the Android download app.
Afterwards I used f-droid to find a simple filemanager that deserves this label and subsequently installed further selected apps.

I’m still very interested in better ideas. I am very reluctant to go online too early in the installation process without initial protection.

Thanks @s99h, that worked!

A post was merged into an existing topic: [Bug] :pencil2: Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

My FP2 is rebooting too many times a day, often if I use it again after a few hours, switching on wlan or using the Gallery App from F-Droid. I can’t determine a system when it hangs up, and of course their is no error message. After the enforced reboot everything is working fine for a while.
Is it possible, that I made a mistake during my installation of 17.06.4?

Before I installed 17.06.4 I deinstalled XPrivacy. But I neither deinstalled Xposed nore Xposed Installer. Now their is a red message in Xposed Installer, telling me to install a newer version of Xposed, and the download of XPrivacy doesn’t work. I don’t know how to install a new version because my FP2 is encrypted and read that TWRP can’t handle this. I also can’t find a description how to deinstall Xposed on an encrypted phone.

Can anybody tell me

  • if my problem will probably be solved if I uninstalled Xposed or which reasons come into consideration? (May be a hardware problem with the on/off-button? I’ve got the new slim case.)
  • how I can uninstall Xposed on an encrypted phone? (Do I have to unencrypt it first?)
  • how I can update Xposed on an encrypted phone?

afaik you must re-flash (with twrp) xposed framework (use the version matching your new android version if it is a new one) after flashing an update.
I dont know if some remains of an old xposed framework could break your system, but I don’t think so.

What’s encrypted is your data partition, not the system, so you should be able to flash in twrp.

Yesss!! Finally!! I managed to install 17.06.4 (OOS) directly over Android 5.
After using the updater app first which ended up in a bootloop, I did a factory reset in TWRP and installed from SD. Now everything works smooth.
The best news: my battery life is back to normal (around 28h with normal everyday usage vs 10h in Android 5) :smiley:
One question though: Since the update I don’t see the option “mount SD card” in the USB menu (when connecting to computer) anymore. Is this normal? Would be very disappointing if this feature would have been removed. And if yes, is there a Xposed module to fix that?

Cheers!

I want to follow your advice. May be you can give me an advice for one more obstacle: I’ve activated this SD card as internal storage feature. How can I copy the xposed-zip to a folder that I can reach with twrp?

you could install in TWRP when connected to your computer using adb commands

(adb install filename.zip) when the file is on your PC

You meant adb sideload <filename.zip>, and TWRP must be in Sideload mode, :wink:

1 Like

Thank you, yes, got that mixed up with sideloading on my FireTv, there you use ‘adb install’" :smiley:

Hello,

do you still got the Problem of the audio stuttering?
I have it a lot after the update and tried different audio player but they all stutter from time to time.

I thought about if it has something to do with the sd card, because it seems that there were a lot of changing since the update…
I didnt test to play files from the internal storage yet.

Ofcourse I would be happy to hear a solution… :slight_smile:

I can confirm the problem reoccurs after the last update.

I upgraded it, and lost all my contacts, half of the apps were removed and a few doesnt work anymore. i tried to install telegram with aptoide, doesnt work, with yalp store, doesnt work, downloaded the apk file, doesnt work.
it is just asking, do you want to install it? yes, then it says, couldnt install.
could anyone help me?

In TWRP (3.0.2-0) under Advanced I tried to activate ADB Sideload with following errors:

Updating partition details..
Failed to mount '/data' (Invalid argument)
...done
Unable to mount storage
Failed  to mount '/data' (Invalid argument)
Full SELinux...
Unable o mount /data/media/TWRP/.twrps
MTP Enabled
Starting ADB sideoad

and nothing happens. And of course adb sideload xposed...zip leads to error: device not found.

The “/data” thingies are not spilled when Sideload option is enabled, but on TWRP boot. That means your data partition is encrypted and TWRP can’t mount it without the password, obviously. It doesn’t have anything to be with Sideload.
The rest means ADB sideload has been enabled fine on the device, so your problem seems to be with your machine. I bet huge amounts of money* that adb devices doesn’t list any device on your computer.

Which OS are you running and how did you install adb?

*= money which I don’t have, :angel:

1 Like