English

Fairphone Open 17.06.4 (Android 6.0) release

Good point, but an updated phone is more secure than staying with an outdated one, and normally the updates go smooth, so taking the risk normally pays off.
But this time:

  • this is a major update, so it is riskier than usual
  • many users reported a very bad state after the update, which is what specially worries me.

You are absolutely right that I could seek help on my surroundings, I’ll try as well, thanks.

2 Likes

@Roboe and @Johannes: Thank you very much, reinstalling openGapps solved battery drain. Reinstalling “… has closed”-apps solved their new issue.

Now I have “time” to read and understand next steps to exclude openGapps again.

btw: forgot to write that I updated earlier from 16.11 to 16.12 while openGapps was installed, but maybe to few apps relied on that, because this time no drain or anything else than just “aCalender did not show anything”.

1 Like

I absolutly agree with @Neus . I’m not generally afraid of the upgrade. I write my questions here at this topic as I want to upgrade, but I would like to know if

–> minimize does not mean that I will not going to do it in general :wink: , as I know that it is important to apply at least security fixes. (apart from that which the german government would like to keep open for their “Staatstrojaner” :grin:)

This makes sense. I thought it could be a side problem.

So, I’m waiting for an official workaround and keep my phone in safe mode.

1 Like

You can try flashing official TWRP 3.1.1 via fastboot and backup your data partition from there (which works for me). At least this way your data won’t be gone after a complete wipe.

1 Like

If the encryption itself is the problem @StephanK is right. You can use the latest TWRP and it will ask for your encryption password when booting into it.

Initially there was no official TWRP for the fairphone and especially non with support for encrypted devices. (also discussed in this topic: ✏ Porting TWRP recovery in the meanwhile it has become a wiki post)

Link to the community port (or more exact it is an official one now) can be found here:
https://twrp.me/devices/fairphone2.html (Europe download: https://eu.dl.twrp.me/fp2/)

I was able to decrypt, backup (be aware /data/media is excluded) and flash new roms with TWRP 3.1.0-0.

What I was not able to do up to now is, to mount a USB-OTG device to write my backup to it. (in the past, with an Nexus 5 and TWRP I was able to do so)

Since the upgrade to FP OOS 17.0.4 I experience very distorted sound in the earpiece during phone calls. That is, I hear the other person fairly distorted, but the other person can hear me just fine. I tried to turn down the volume, but it did not help (in fact, did not seem to have any effect). Has anybody else experienced this and maybe found a solution?

A post was merged into an existing topic: [Bug] :pencil2: Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

Still looking for why phone feels hotter than before. I don’t have the comparison to lollipop, but i do have the impression the governor (interactive) changed significantly. Watching the copy frequencies, i see that, while shutting down cores works, the minimum frequency is mostly 1190 MHz. It very seldom goes below that, while i think it was much more often on 300MHz on 5.1

Anyone else?

1 Like

I resolved (apparently) this problem by taking the second SIM off the phone… phone now is cool to the touch and battery life increased significantly… (check out the topic about battery life). Do you use 2 SIM cards?

Bug?

After I navigate through applications and press home button again my phone goes to the far left screen every time… regardless where it was before I pressed menu button.

Anyone else experiencing this?

No, I only have one sim card.

How about SDcard? if yes, does situation improve if you take it out?

This i did not check. Will do this weekend

A post was merged into an existing topic: FP2 random reboots - see first post for workarounds

I don’t know any Fairphone user around me.
If I use the same charger, my FP2 is still flashing all the time.
Even reflashing didn’t helped.
First it seems reflashing was successful, but nothing changed.
I have absolutley no idea what I should do. :frowning:

If resetting the battery didn’t help (note that some users reported they had to kickstart the battery twice; see #batteryguide ) then, as I said above, I would assume faulty hardware.
If the battery worked fine before, my guess would be that the bottom module rather would have sudden failure than the battery, so this is where I would start. Yet, it is also possible that a battery is completely deep discharged and dead. Either way, in case of a hardware defect I would recommend to contact support.

After upgrade to Fairphone Open 17.06.04 my apps cannot access external SD card (which I have set up as portable storage).
I have checked platform.xml and there has been no WRITE_EXTERNAL_STORAGE section after upgrade!
I added the permission as discussed many times before (SD Card no writing permission in FP2), rebooted - but no access granted to SD card. I have no idea how to proceed.

1 Like

If an app can access the sd card seems to depend on whether apps have implemented storage access provider or not.

See above:

No difference of i remove the sd card. Still the lowest frequency stays at 1190MHz and nearly never goes below that.
Anyone knows someone who’s still on lp and can check?