Fairphone Open 17.06.4 (Android 6.0) release

I read my way through this complete topic, but I’m still confused what I have to-do to smoothly update my
FP2 to 17.06.4 (currently running: FP Open 17.03, no-Gapps, Xposed, TWRP 3.1.0-0, F-Droid as normal App). When I flashed the last few updates I simply followed the instructions here: ✏ Update Guide for a modified FP Open OS (with Gapps, Xposed and more)
But it seems that this is not the recommended way to update to this A6 version?
I’m afraid of running into boot-loops (or brick it completely), destroy my contacts-data (or other app data) or have to downgrade as worst case.

So is there any recommended straight forward procedure which minimize the risk of any of the mentioned problems?

Thanks in advance.

1 Like

Hello,
I have dared to upgrade as well. Of course after a backup with Titanium Backup…
So far my experiences are:

  • Update (using the standard updater-notice) went smooth
  • Installing Xposed (new version) was without problems (GravityBox also needed new Version MM)
  • No data losses
  • I did have froozen screens, when I tried to open amaze. Reinstalled it and so far it did not freeze any more and did not reboot by itself
  • The phone got extremely hot during the upgrade!
  • I like that the lockscreen is more simple now with just the time. I did not like the old “you own your phone since…”-stuff
  • Battery life seems (subjectivly) longer
  • Some apps work now, that did not work before. For example “outdooractive”. This app had a problem with the fused provider. Now this issue is gone
  • I tried to restart the phone in airplane mode and it seems that it remembers the time now. This would be a great success for me, because I am often in areas without reception and it was a pain not having the time any more.
  • SD-card seems to work better no. You have write permission (if it is kept “external/portable”) and can use it for backups with Titanium Backup without changing the platform.xml. Nice! I did format the SD as internal storage, but then I could not access it from a computer any more and the additional storage was recognized. I think then it can only be accessed by the phone, which makes no sense to me…

I do have a few quesions, which are not answered for me clearly yet (I have not found a solution yet):

  • The edge-swipe is gone. Is it possible to get it back with gravitybox? Is it possible to disable the “hot seat” (line with the 4 apps and launcher) with gravity box?
  • Is it possibe to reactivate the differnt options of the powerbutton (restart, boot to recovery) with GravityBox?
1 Like

Helo

I’ve updated my FP2 with the update app and I get pretty much the same problem as described above: screen freezes as soon as I try to do something and the phone rebooting in loop. The phone is encrypted and doesn’t use fancy apps like Exposed.

Booting with TWRP, it can’t mount the /data partition: mounting /dev/block/mmcrblk0p20 on /data failed: Invalid argument. Mounting manually through the terminal gives the same result. Thus, I can’t backup the /data partition.

So far, I’m not sure what I should do to fix this up. Many answers have been proposed, but I don’t know if they’re related to my case. Moreover, there are several conversations running simultaneously on this thread, which makes things worse. Since a lot of people suffers from the same problem, what about creating a new thread for this? Or wouldn’t it be nice to have a howto from the devs?

These two sentence correlate.

Bug has been reported to the bugtracker here. No official response yet.

No hacky solution worked for me neither, although some people were able to unblock their situation. I suggest to contact Support, linking to the official bugreport. Don’t forget to add your (possible) data loss and time loss as well figuring out what to do.

What you would like to have is another launcher. I do not know much about gravitybox but it is not likely that you get what you want that way.

The hot seat is part of the preinstalled launcher app and you can get rid of it by installing another launcher app and setting that as the default one. I’m not entirely sure but I think the fairphone launcher 3 is being adapted to android 6 by some community members but not yet available. There is also an inofficial version of the original fairphone launcher used on fairphone 1/1U.

It is a whole world of launchers out there (one of my personal favourites: T-UI, a geeky terminal-like launcher). I’m pretty sure you will find something you like.

Hmmm, again I’m not sure but wasn’t there an xposed module to add options to the power off menu? A little search revealed this one to me, but it is obviously discontinued…

1 Like

A post was split to a new topic: :nl: Fairphone Open 17.06.4

Hi there,
Same situation here as some wrote already. I’m not familiar with techie topics, I’ve struggled through FP Open too much already and I’m definitely not going to update to FP Open 17.06.4 if there is a risk of bricking the device, getting stuck in endless loops, having to downgrade & upgrade or anything the like.

I’m using FP Open 17.04.0 with openGapps: no encryption, no Xposed. I couldn’t deduce from this topic if my Fairphone will be affected by the dreaded bug. Is someone on the position of stating if I will be able to update smoothly?

Otherwise, I’ll switch to regular FP OS so I can get an OS that works out of the box, ready for muggles, and switch back some other time. Is there a guide to switch back to FP OS with FP Open + openGapps? I guess it’s not straight forward…

If you are anxious to damage your phone when an update is applied, you should not update at all. Potentially there always is a minimal risk something gets wrong during a flash.

Some stores might do the work for you if you do not want to try. Maybe even someone from the Fairphone community within your country can help you.

Good point, but an updated phone is more secure than staying with an outdated one, and normally the updates go smooth, so taking the risk normally pays off.
But this time:

  • this is a major update, so it is riskier than usual
  • many users reported a very bad state after the update, which is what specially worries me.

You are absolutely right that I could seek help on my surroundings, I’ll try as well, thanks.

2 Likes

@Roboe and @Johannes: Thank you very much, reinstalling openGapps solved battery drain. Reinstalling “… has closed”-apps solved their new issue.

Now I have “time” to read and understand next steps to exclude openGapps again.

btw: forgot to write that I updated earlier from 16.11 to 16.12 while openGapps was installed, but maybe to few apps relied on that, because this time no drain or anything else than just “aCalender did not show anything”.

1 Like

I absolutly agree with @Neus . I’m not generally afraid of the upgrade. I write my questions here at this topic as I want to upgrade, but I would like to know if

–> minimize does not mean that I will not going to do it in general :wink: , as I know that it is important to apply at least security fixes. (apart from that which the german government would like to keep open for their “Staatstrojaner” :grin:)

This makes sense. I thought it could be a side problem.

So, I’m waiting for an official workaround and keep my phone in safe mode.

1 Like

You can try flashing official TWRP 3.1.1 via fastboot and backup your data partition from there (which works for me). At least this way your data won’t be gone after a complete wipe.

1 Like

If the encryption itself is the problem @StephanK is right. You can use the latest TWRP and it will ask for your encryption password when booting into it.

Initially there was no official TWRP for the fairphone and especially non with support for encrypted devices. (also discussed in this topic: ✏ Porting TWRP recovery in the meanwhile it has become a wiki post)

Link to the community port (or more exact it is an official one now) can be found here:
https://twrp.me/devices/fairphone2.html (Europe download: https://eu.dl.twrp.me/fp2/)

I was able to decrypt, backup (be aware /data/media is excluded) and flash new roms with TWRP 3.1.0-0.

What I was not able to do up to now is, to mount a USB-OTG device to write my backup to it. (in the past, with an Nexus 5 and TWRP I was able to do so)

Since the upgrade to FP OOS 17.0.4 I experience very distorted sound in the earpiece during phone calls. That is, I hear the other person fairly distorted, but the other person can hear me just fine. I tried to turn down the volume, but it did not help (in fact, did not seem to have any effect). Has anybody else experienced this and maybe found a solution?

A post was merged into an existing topic: [Bug] :pencil2: Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

Still looking for why phone feels hotter than before. I don’t have the comparison to lollipop, but i do have the impression the governor (interactive) changed significantly. Watching the copy frequencies, i see that, while shutting down cores works, the minimum frequency is mostly 1190 MHz. It very seldom goes below that, while i think it was much more often on 300MHz on 5.1

Anyone else?

1 Like

I resolved (apparently) this problem by taking the second SIM off the phone… phone now is cool to the touch and battery life increased significantly… (check out the topic about battery life). Do you use 2 SIM cards?

Bug?

After I navigate through applications and press home button again my phone goes to the far left screen every time… regardless where it was before I pressed menu button.

Anyone else experiencing this?

No, I only have one sim card.