Fairphone Open 17.04.0 is now available

Fairphone Open 17.04.0 has been released. You can get it through the updater, or by downloading from here.

Fairphone Open 17.04.0 includes the security fixes published in the Android Security Bulletin for April 2017.

According to https://code.fairphone.com,
This is the last Android 5.1 update for Fairphone Open, in May Fairphone Open will move to Android 6.

Security fixes:
CVE-2014-1739, CVE-2014-2706, CVE-2014-3145, CVE-2014-4656, CVE-2016-10229, CVE-2016-10230, CVE-2016-10233, CVE-2016-10234, CVE-2016-10235, CVE-2016-2429, CVE-2016-5346, CVE-2016-7097, CVE-2016-8479, CVE-2017-0539, CVE-2017-0540, CVE-2017-0541, CVE-2017-0544, CVE-2017-0545, CVE-2017-0546, CVE-2017-0547, CVE-2017-0553, CVE-2017-0554, CVE-2017-0554, CVE-2017-0558, CVE-2017-0559, CVE-2017-0560, CVE-2017-0576, CVE-2017-0586, CVE-2017-6424, CVE-2017-6426

If you have modified your Open OS installation, e.g. by installing GAPPS or xposed, you may want to have a look at the update guide.


Does not seem to me that the source is released as well, though :unamused:
I wasn’t even able to download the source of 17.03…


Encrypted phone with Open GApps updated using OTA file and fresh Open GApps in TWRP 3.1.0-0 … no problem so far :+1:

1 Like

Hey @AnotherElk I got the same problem as @Dabuh that the download file is still the old one 17.03. Are you sure you got the new update? Your link leads in to the old update in the moment.

I think @Dabuh is talking about the source code, not the update files. They can be found under the link posted above. Maybe you need to clear your browser cache if it doesn’t show the latest files. But 17.04 is certainly available :slight_smile:

Thanks, the cache was my problem :grimacing:

I updated in TWRP to FP Open 17.04.0 without any Problems.
But my TWRP Version is still V2.8.7.0.
How do I have to upgrade TWRP?
And is it even usefull to do it respectively do I have some advanrages if I will upgrade it?

FP Open ships with TWRP 2.8, the available 3.1 is a community port (thanks to @z3ntu) and can be downloaded from here: https://private.z3ntu.xyz/fairphone/

To install it, simply flash it from the bootloader:

fastboot flash recovery filename.img

It is very useful if your device is encrypted, as - unlike the official version - it can decrypt /data, and thus also allows TWRP backups on encrypted devices. Moreover you can also access ADB while in TWRP.


Please download it from https://twrp.me/devices/fairphone2.html and not from my server :slight_smile:


Fairphone Open 17.04.0 installed and running without problems !

Downloaded from the updater… no problem installing, xposed no problem either but I have a problem with openGapps… don’t think they’re working.

May be because I updated from updater and installed gapps after? what should I do now? re-install from the beginning or re-install openGapps?

Just reinstalling openGAPPS from within TWRP should do it.

No problem here either, smoothly updated two FP2.
Thanks to the FP developers!

Tomorrow just reflashing old modem files for the proximity sensors and wakeup and there we go again :wink:

Will the recovery partition be overwritten after flashing a Fairphone Open update?

Might Fairphone Open Marshmallow bring TWRP 3.1 with it?

I hope so too. :slight_smile:

Update to 17.04.0 and reinstalling Xposed worked fine. Usually I had to change the /system/etc/permissions/platform.xml to allow some apps (OpenCamera) access to the SD card. However when I now try to open the file with Amaze, I get Error: File Not Found. I can read the file using Ghost Commander, however I cannot save any changes. Both Amaze and GhostCommander are allowed to have root access.

Anyone having the same issue?

Is there another workaround to give the OpenCamera access to the external SD card?

I always use this solution and it worked for this update just like always:

I got the proprietary app via the Yalp Store.

PS: Don’t forget to reboot after changing the platform.xml file yourself or via that app.

1 Like

I’m actually not 100% sure, but I do think that the recovery is overwritten as well with the update. At least I had to flash it again recently.
Anyhow, since the community FP2 port become an official TWRP port, I hope FP will ship it with the open OS in future.

1 Like

Did you remount /system as rw before the change? (edit: I just remembered that amaze is supposed to do this automatically. Maybe this somehow failed?)

I usually adjust the platform.xml right from the terminal (preferably via adb shell), and it works fine.

I had no problem changing the platform.xml file the following way:

I copied the original file, modified it and then used TWRP to copy it back to /system/etc/permissions/platform.xml.

Also I prefer this way over using an app with root permissions (so that I have full control over the changes).