Fairphone Open 17.03.0 is now available

Did you flash anything else (Did you ever go into TWRP and install anything there)?

@freibadschwimmer was once in a similar situation (not being able to access TWRP) and resolved it by reinstalling TWRP via #dic:fastboot .

Hi. Thanks for replying. I never installed anything in TWRP before. I can reach TWRP now, but I’m not sure where to go from there, since I can’t mount /data in TWRP due to encryption. Is my only option at this point a factory reset?

You should be able to reinstall the update via TWRP if you put the OTA file on your external SD card.

1 Like

A factory reset would only reset /data but not change your system, so that’s not what you want.
You can install another TWRP if you want to access /data, but I guess for now that’s probably also not what you need.

I’d recommend, since you can access TWRP, to reinstall the latest OTA update.
Just download it on your computer, put it via ADB (or MTP or another way) on your external SD card, and install it from TWRP.


Cool. Thanks for that! I’ve give it a try.

I have the same problem. I use AFWall+ as a Firewall. Even if I allow the Updater to access the internet. So I always shut down AFWall and then the Updater works. After the download I reactivate the firewall.


Thank you for your reply - that would fit. I also have AFWall+ and will try your method for the next update.

To get the update-file through AFWall+ you better dont shut down the whole firewall but you need to allow the updater plus the app 10006 Media Storage, Download Manager. Thats because the Updater has no built-in Download Manager.

1 Like

Bummer. Upate went well but now I have an unresponding bar in my touchscreen. A known problem and most probably unrelated but maybe not. Anyone else having this problem?
(I found the corresponding topic but i dont know how to link.)

OK, so I tried to install the OTA update from an external SD card, but my phone is still getting stuck in a boot loop. I’d like to do a hard reset, but when I try to wipe via TWRP it says “Unable to mount storage”. I’ve tried upgrading to the newer TWRP (3.1.0), but I couldn’t get adb sideload to work. “fastboot flash recovery TWRP_3.1.0-0.img” is unresponsive, and “adb devices” shows the device as “unauthorized”. Does USB debugging have to be enabled on the phone for this?

If I understood your other comments properly, you might have not (yet) succeeded with re-installng the system; or did you?

For using default recovery yes; then for ADB USB debugging needs to be active.

When using TWRP 3.1.0. (which is a community port) this does not need to be the case, because the porter (as far as I understand) compiled this TWRP version in a way that it does not look for this permission.
In other words, it allows ADB without USB debugging active, and additionally can decrypt /data.

I don’t see what you need that for. If you want to install the OTA package, you just need to choose “install” from the TWRP main menu, and point it to the zip on the external_sd. No need to sideload anything.

I succesfully installed TWRP 3.1.0 via fastboot. I’ve used TWRP 3.1.0 to do a hard reset, which worked fine. I also selected “format user data”, which has successfully removed encryption. Now I’ve installed the OTA latest FP OS from external SD card (I’m trying the non open source version for a change, to see if it works instead). My phone is still stuck in a boot loop though. Are there any steps that I could take to try to fix the boot loop? I’ve tried removing the sim card, but it had no effect. Thanks for your help :slight_smile:

Sorry to hear you had to reset /data, hoped you could avoid that!
Anyhow, now that this is done, I would recommend to make a fresh install of the whole system. (note that this will also reset TWRP to default)

Take a look at these instructions (option 4) but - as long you want to stay on FPOOS - use this file.
That should give you a fresh install of FPOOS.
Hope you had backed up your data! :slight_smile:

Yeah it’s no problem though. I don’t keep important data on there :slight_smile: . I’ve tried the manual install method for FP open OS as you mentioned, but it didn’t fix the boot loop. I actually couldn’t enter TWRP after that, so I had to reinstall TWRP 3.1.0, which worked fine. Now I’m trying the manual install for the FP non-open OS.

The manual installation for FP OS (non open source) worked. However, it crashed during the initial setup phase (when it asks you to connect to a wifi network etc.). After that, it reboots, and then crashes during the “app optimization” stage. Now it keeps doing this. Could this be a faulty hardware issue?

Maybe the following troubleshooting page helps?: How can I reboot my FP2 in Safe mode?
There are some more troubleshoot options at the bottom of the page.


I wouldn’t exclude that possibility.
Maybe the phone dropped at some point and some contact got loose.
You could try to disassemble and reassemble the phone.

Since the update phone gets easily hot again, freezes and I have to take the battery out in order to get it to reboot… :disappointed:

And localisation symbol is back!!! (when gps is turned off) :disappointed:

Yes, I strongly agree to that. It’s so annoying - waiting for the post saying that the new release is out, then waiting again and checking every day if the sources are yet available…
And sometimes even when they are available the blobs package is outdated or you get compile errors.

1 Like