Fairphone Open 17.03.0 is now available

No, the OTA won’t erase your data and neither will the flashing of microG or Xposed (as you already know). Basically the zips modify the system partition but the system partition is overwritten with each OTA update so that’s why you have to reflash the zips after every update.

2 Likes

I only have the phone for a month now, and so far I didn’t have this problem.
The first Open OS version I ran on the phone together with Open GApps pico was 16.12.

1 Like

Seamless update with no problems. And I do share the disappointment about the proximity sensor bug not being fixed - mainly for two reasons:

  • Using an app like “wave up” would very likely increase the mechanical lifespan on my FP2 because I would not need to press the power button so often.
  • The bug sits in one of the “closed source” parts of the system what means if the devs don’t fix it, then nobody will be able to fix it.
1 Like

Any clue how to do this? :sweat_smile:

As always, the update went fine for me from TWRP with an encrypted data partition.

Thank you for providing the security fixes. The update went without problems on encrypted device with xposed.
One question though that has been bugging me ever since switching to FP Open:
Why do I not get notified by the updater that there is a new version? I tried the manual check (multiple tapping on the version) too - no difference. Is the default URL (ota.fairphone.com) wrong?
Any hint about how to fix this would be welcome. Thank you!

So I’m getting stuck in a boot loop after installing this update. The update went fine, and my phone was working swell as usual. Then the next day it start randomly rebooting and now it’s stuck in the boot loop. It’s encrypted, but I’m not using gapps or xposed. I always install the FP open OS updates when they come out, but I’ve never experienced this problem before. I’m pretty stuck for ideas, because I can’t even get to TWRP. Anyone else experienced this?

Did you flash anything else (Did you ever go into TWRP and install anything there)?

@freibadschwimmer was once in a similar situation (not being able to access TWRP) and resolved it by reinstalling TWRP via #dic:fastboot .

Hi. Thanks for replying. I never installed anything in TWRP before. I can reach TWRP now, but I’m not sure where to go from there, since I can’t mount /data in TWRP due to encryption. Is my only option at this point a factory reset?

You should be able to reinstall the update via TWRP if you put the OTA file on your external SD card.

1 Like

A factory reset would only reset /data but not change your system, so that’s not what you want.
You can install another TWRP if you want to access /data, but I guess for now that’s probably also not what you need.

I’d recommend, since you can access TWRP, to reinstall the latest OTA update.
Just download it on your computer, put it via ADB (or MTP or another way) on your external SD card, and install it from TWRP.

2 Likes

Cool. Thanks for that! I’ve give it a try.

I have the same problem. I use AFWall+ as a Firewall. Even if I allow the Updater to access the internet. So I always shut down AFWall and then the Updater works. After the download I reactivate the firewall.

2 Likes

Thank you for your reply - that would fit. I also have AFWall+ and will try your method for the next update.

To get the update-file through AFWall+ you better dont shut down the whole firewall but you need to allow the updater plus the app 10006 Media Storage, Download Manager. Thats because the Updater has no built-in Download Manager.

1 Like

Bummer. Upate went well but now I have an unresponding bar in my touchscreen. A known problem and most probably unrelated but maybe not. Anyone else having this problem?
(I found the corresponding topic but i dont know how to link.)

OK, so I tried to install the OTA update from an external SD card, but my phone is still getting stuck in a boot loop. I’d like to do a hard reset, but when I try to wipe via TWRP it says “Unable to mount storage”. I’ve tried upgrading to the newer TWRP (3.1.0), but I couldn’t get adb sideload to work. “fastboot flash recovery TWRP_3.1.0-0.img” is unresponsive, and “adb devices” shows the device as “unauthorized”. Does USB debugging have to be enabled on the phone for this?

If I understood your other comments properly, you might have not (yet) succeeded with re-installng the system; or did you?


For using default recovery yes; then for ADB USB debugging needs to be active.

When using TWRP 3.1.0. (which is a community port) this does not need to be the case, because the porter (as far as I understand) compiled this TWRP version in a way that it does not look for this permission.
In other words, it allows ADB without USB debugging active, and additionally can decrypt /data.


I don’t see what you need that for. If you want to install the OTA package, you just need to choose “install” from the TWRP main menu, and point it to the zip on the external_sd. No need to sideload anything.

I succesfully installed TWRP 3.1.0 via fastboot. I’ve used TWRP 3.1.0 to do a hard reset, which worked fine. I also selected “format user data”, which has successfully removed encryption. Now I’ve installed the OTA latest FP OS from external SD card (I’m trying the non open source version for a change, to see if it works instead). My phone is still stuck in a boot loop though. Are there any steps that I could take to try to fix the boot loop? I’ve tried removing the sim card, but it had no effect. Thanks for your help :slight_smile: