Fairphone Open 17.02.0 is now available

Thanks. This seems to be the way I have to go ✏ Update Guide for a modified FP Open OS (with Gapps, Xposed and more)
(including installing TWRP Community Port in advance because of the encryption)

I will let you know if everything went fine.

Currently my phone is hanging when I try to boot into TWRP (but I’m still able to boot into the OS). I hope I will be able to somehow start or install the community port of a newer TWRP release using adb/fastboot.

Installed the update via the updater, during following reboot rebooted into TWRP and installed GApps and XPosed. Worked fine with unencrypted FP2.

Perfectly up and running, 17.02 with Xposed, I flashed the zip and in the same session within TWRP also xposed v87, rebooted and it works seamlessly :slight_smile:

OTA update from 17.01 to 17.02 with OpenGApps re-install.
Seems to work fine.

Update went smooth - thanks a lot!

I updated from 16.12 with encrypted data and XPosed, but only flashed XPosed after the update (i.e. within an extra TWRP session). However, I haven’t experienced any bootloop (as I expected from other’s reports with similar setups concerning 17.01)!

I updated to 17.0.2 and the phone starts without issues although I did not flash Xposed and OpenGAPPS again…

This is strange enough… but now I want to have Xposed and OpenGAPPS back, and I can’t seem to flash them.

My Fairphone is encrypted and I see TWRP not being able to mount /data.
So I moved the zips to my external storage and try to flash them from there.

But when I flash OpenGapps: TWRP reboots. And when I flash Xposed, the screen goes black, and I have to force a reboot.

I’d love to disable encryption, but that doesn’t seem to be an option; the settings app doesn’t give such an option.

Did anyone else ever experience this and what do you think is a good path to follow here?

Have a look at https://forum.fairphone.com/t/pencil2-update-guide-for-a-modified-fp-open-os-with-gapps-xposed-and-more/21117.

1 Like

Hey @Lidwien, thanks for the link. I followed those steps. But it doesn’t work…

Following the step in the link you provided:
1) I have the latest zips and (1.7), since my phone is encrypted, I saved them on an external SD
2) I did the update (updater says I am on 17.0.2)
3) Flashing goes wrong (see my first post)

Did you flash Xposed and OpenGAPPS at the same time? (As described in step (3).)

1 Like

I tried both flashing them at the same time and flashing them separately.

Check out this topic:

For the future - especially with encryption - flash all your modifications before rebooting after an update.

Thanks for the Update. I loste the hope that Use of Proximity Sensor Drains the battery will be fixed one day.
Calibrated the sensor with new modem and flashed the old modem afterwards.

I installed FPOSOS [FPOOS : don’t use censorship on my posts @paulakreuzer. I already don’t like it on wikified pages, but on my posts, it’s unacceptable] 17.02, with GravityBox on top, started my script to get external storage writable, rebooted twice in the process, installed back WaveUp, and nope… I lost 50% of the batterie in 5h.

So I uninstalled WaveUp and lost 25% in 10minutes, rebooted and everything want well back.

So it’s not yet fixed.

1 Like

+1 Today I flashed the old (FP2-gms59-1.5.1) modem files on three FP2’s. Is there any statement about Use of Proximity Sensor Drains the battery issue?

1 Like

I succeeded in installing 17.02 but not seamlessly.
I downloaded fp2-sibon-17.02.0-manual-userdebug.zip & open-gapps-arm5.1-pico-20170302.zip on my SD card.
(I did not unzipped any of these files)
Entered TWRP mode
and tried to install both files, but I get unable to mount errors

Then I tried the updater and installed 17.02
and installed openGAPPS in TWRP

it seems to work now

For updates of an installed OS, Fairphone recommends the use of the Updater App anyway (at least on the download page for Fairphone OS with Google services).

Update files for use with TWRP have “ota” instead of “manual” in their filenames, see download links at Fairphone Open OS downloads “OTA” or at Fairphone OS downloads anywhere but not “4. Flash the binary images from a computer”.

fp2-sibon-17.02.0-manual-userdebug.zip is not for use with TWRP, it is used with fastboot on your PC with the phone connected via USB in fastboot mode, see this guide, and it is not an update, it is a new install of your phone, erasing all your data.

I don’t have enough knowledge of TWRP and the OTA update process to say whether “unable to mount” errors would make a successful update via TWRP impossible, if you use the correct OS file, but you can get around “unable to mount” errors by wiping the partition that gives the error (TWRP - Wipe - Advanced Wipe - only check the partition that gives the error) … Of course, always be extra careful with wipe, I would always try the Updater App first.


Not if you have modifications. Afaik updating via the updater app doesn’t give you the opportunity to flash other zips before leaving recovery mode and rebooting before flashing your modifications can cause a bootloop.
I never use the Updater and never have issues updating.

And also “unable to mount /data” is normal if you have encrypted you phone (unfortunate still…)

1 Like

I second that and would like to add that you can simply ignore it for installing modifications like xposed or gapps, as you only need access to /system for that.

Ah, thanks for pointing that out, I just did the same as @Framb00s without putting much thought into it, updated to 17.02 via Updater and reinstalled Open GApps via TWRP as it was missing afterwards … So it could be more problematic, good to know.
Found this guide just now, have to search the forum more thoroughly, will do :wink: .